aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2005-07-01 19:12:09 +0800
committerlawrance <lawrance@FreeBSD.org>2005-07-01 19:12:09 +0800
commitf3b0e3361dc3988c119e68ceb33988fb30fe107d (patch)
treed9dcfe16d7acbb07aef4c8c1c2afa8c7ff7b9de0 /sysutils
parent4b4cd797905ce677afa9ff20014bccf3005a7da3 (diff)
downloadfreebsd-ports-gnome-f3b0e3361dc3988c119e68ceb33988fb30fe107d.tar.gz
freebsd-ports-gnome-f3b0e3361dc3988c119e68ceb33988fb30fe107d.tar.zst
freebsd-ports-gnome-f3b0e3361dc3988c119e68ceb33988fb30fe107d.zip
Add fatback, recover deleted files from FAT filesystems.
PR: ports/82393 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fatback/Makefile34
-rw-r--r--sysutils/fatback/distinfo2
-rw-r--r--sysutils/fatback/pkg-descr18
-rw-r--r--sysutils/fatback/pkg-plist6
5 files changed, 61 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index c28207a6ebf7..d05175931932 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -133,6 +133,7 @@
SUBDIR += extipl
SUBDIR += fanout
SUBDIR += fastest_cvsup
+ SUBDIR += fatback
SUBDIR += fcron
SUBDIR += fdupes
SUBDIR += fetchlog
diff --git a/sysutils/fatback/Makefile b/sysutils/fatback/Makefile
new file mode 100644
index 000000000000..cb2c60bedeff
--- /dev/null
+++ b/sysutils/fatback/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: fatback
+# Date created: 18 Jun 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fatback
+DISTVERSION= 1.3
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Recover deleted files from FAT filesystems
+
+GNU_CONFIGURE= yes
+
+MAN1= fatback.1
+INFO= fatback-manual
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/fatback-manual.info ${PREFIX}/${INFO_PATH}
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in fatback-manual.texi texinfo.tex ChangeLog AUTHORS
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/fatback/distinfo b/sysutils/fatback/distinfo
new file mode 100644
index 000000000000..6e5a0109de45
--- /dev/null
+++ b/sysutils/fatback/distinfo
@@ -0,0 +1,2 @@
+MD5 (fatback-1.3.tar.gz) = 4f1beb13670a7eff5b66cff84e5fd42a
+SIZE (fatback-1.3.tar.gz) = 190800
diff --git a/sysutils/fatback/pkg-descr b/sysutils/fatback/pkg-descr
new file mode 100644
index 000000000000..8a5e32c4c522
--- /dev/null
+++ b/sysutils/fatback/pkg-descr
@@ -0,0 +1,18 @@
+Fatback is a forensic tool for undeleting files from FAT file systems.
+
+Fatback is different from other undelete tools in that it does the
+following:
+
+ * Runs under UNIX environments
+ * Can undelete files automatically
+ * Supports Long File Names
+ * Supports FAT12, FAT16, and FAT32
+ * Powerful interactive mode
+ * Recursively undeletes deleted directories
+ * Recovers lost cluster chains
+ * Works with single partitions or whole disks
+
+WWW: http://sourceforge.net/project/showfiles.php?group_id=46038
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/sysutils/fatback/pkg-plist b/sysutils/fatback/pkg-plist
new file mode 100644
index 000000000000..e38cc82937e9
--- /dev/null
+++ b/sysutils/fatback/pkg-plist
@@ -0,0 +1,6 @@
+bin/fatback
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/fatback-manual.texi
+%%PORTDOCS%%%%DOCSDIR%%/texinfo.tex
+%%PORTDOCS%%@dirrm %%DOCSDIR%%