aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2001-02-28 04:53:58 +0800
committerolgeni <olgeni@FreeBSD.org>2001-02-28 04:53:58 +0800
commit18c152e746af387cdec56468977dfe715a0a9a3f (patch)
tree043607237ef3b844e702b2ec982558977e904fae /sysutils
parentf53849e52be66ab5bb51bbd3e9736b81961091d0 (diff)
downloadfreebsd-ports-gnome-18c152e746af387cdec56468977dfe715a0a9a3f.tar.gz
freebsd-ports-gnome-18c152e746af387cdec56468977dfe715a0a9a3f.tar.zst
freebsd-ports-gnome-18c152e746af387cdec56468977dfe715a0a9a3f.zip
Add WITH_UPDATES install option.
When the webmin version changes on the master site, patches for previous versions may be removed (they are not stored in a version dependent subdirectory). This means that the port of version A will break as soon as version B is released, because the required updates disappear. If the updates are optional, webmin users still get a chance to install the port without updating their ports collection. It is also easier to support users because, by default, they will run the same "official" version of webmin. PORTREVISION bump: if you reinstall without WITH_UPDATES you will get an unpatched version of webmin.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/webmin/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
index 9277670e15df..bc602974f1b5 100644
--- a/sysutils/webmin/Makefile
+++ b/sysutils/webmin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= webmin
PORTVERSION= 0.84
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= http://webadmin.sourceforge.net/webmin/updates/ \
http://webadmin.sourceforge.net/webmin/download/
@@ -23,12 +23,16 @@ NO_BUILD= yes
IS_INTERACTIVE= yes
USE_PERL5= yes
+.if defined(WITH_UPDATES)
WEBMIN_MODULES= apache.wbm.gz mysql.wbm.gz status.wbm.gz file.wbm.gz
+.endif
post-extract:
+.if defined(WITH_UPDATES)
@for webmin_module in ${WEBMIN_MODULES}; do \
${TAR} xfz ${DISTDIR}/$${webmin_module} -C ${WRKSRC}; \
done
+.endif
@find ${WRKSRC} -name "*.bak" | xargs ${RM}
post-patch: