aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2009-07-01 04:43:11 +0800
committerdhn <dhn@FreeBSD.org>2009-07-01 04:43:11 +0800
commit399f91bf7f7a86f4d942e03dbf3b5178fbfd4bc9 (patch)
treea7dc9400260721d5cb60983aae457ef37c49432b /sysutils
parent0488aa8d77beccf4641e2a16b48ae3bc82687664 (diff)
downloadfreebsd-ports-gnome-399f91bf7f7a86f4d942e03dbf3b5178fbfd4bc9.tar.gz
freebsd-ports-gnome-399f91bf7f7a86f4d942e03dbf3b5178fbfd4bc9.tar.zst
freebsd-ports-gnome-399f91bf7f7a86f4d942e03dbf3b5178fbfd4bc9.zip
- Fix a small Bug in samefile/samearchive
- Bump PORTREVISION PR: ports/136194 Submitted by: Alex de Kruijff <samesame@akruijff.dds.nl> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/samesame/Makefile1
-rw-r--r--sysutils/samesame/files/patch-matchmatrix.cpp10
2 files changed, 11 insertions, 0 deletions
diff --git a/sysutils/samesame/Makefile b/sysutils/samesame/Makefile
index 76e5da994b69..805eb62003f1 100644
--- a/sysutils/samesame/Makefile
+++ b/sysutils/samesame/Makefile
@@ -6,6 +6,7 @@
PORTNAME= samesame
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://samesame.kruijff.org/ \
${MASTER_SITE_LOCAL}
diff --git a/sysutils/samesame/files/patch-matchmatrix.cpp b/sysutils/samesame/files/patch-matchmatrix.cpp
new file mode 100644
index 000000000000..3e6360546637
--- /dev/null
+++ b/sysutils/samesame/files/patch-matchmatrix.cpp
@@ -0,0 +1,10 @@
+--- matchmatrix.cpp.orig 2009-05-22 12:45:27.000000000 +0200
++++ matchmatrix.cpp 2009-06-30 22:24:35.000000000 +0200
+@@ -35,6 +35,7 @@
+ arr[0] = ((signed char *)tmp) + n * sizeof(char **);
+ for (size_t i = 1; i < n; ++i)
+ arr[i] = arr[i - 1] + n - i + 1;
++ memset(arr[0], 0, (n + 1) * n / 2);
+ #ifdef DEBUG
+ if (tmp + n * sizeof(char **) + (n + 1) * n / 2 <= arr[n - 1])
+ {