aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-11-07 16:51:38 +0800
committermarcus <marcus@FreeBSD.org>2006-11-07 16:51:38 +0800
commit60f9130661bdb8263fcb4bd2a377c4b9bcf3374b (patch)
treef310b0e4bbb886a2552d5e263e770277b4db6309 /sysutils
parent7e5febc3ce91c33e0f0f1fd742fffe46d99b7de1 (diff)
downloadfreebsd-ports-gnome-60f9130661bdb8263fcb4bd2a377c4b9bcf3374b.tar.gz
freebsd-ports-gnome-60f9130661bdb8263fcb4bd2a377c4b9bcf3374b.tar.zst
freebsd-ports-gnome-60f9130661bdb8263fcb4bd2a377c4b9bcf3374b.zip
Don't continually install new throttles. This fixes a problem wherein
gnome-screensaver will stop showing screensavers and just blank the screen after g-p-m enables a DPMS sleep. See http://bugzilla.gnome.org/show_bug.cgi?id=355279 for more details. Obtained from: http://bugzilla.gnome.org/show_bug.cgi?id=355279
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/gnome-power-manager/Makefile1
-rw-r--r--sysutils/gnome-power-manager/files/patch-src_gpm-manager.c27
2 files changed, 28 insertions, 0 deletions
diff --git a/sysutils/gnome-power-manager/Makefile b/sysutils/gnome-power-manager/Makefile
index 6f9106ffdfee..d6bd6fa0f2b4 100644
--- a/sysutils/gnome-power-manager/Makefile
+++ b/sysutils/gnome-power-manager/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gnome-power-manager
PORTVERSION= 2.16.1
+PORTREVISION= 1
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
diff --git a/sysutils/gnome-power-manager/files/patch-src_gpm-manager.c b/sysutils/gnome-power-manager/files/patch-src_gpm-manager.c
new file mode 100644
index 000000000000..d590fca4919b
--- /dev/null
+++ b/sysutils/gnome-power-manager/files/patch-src_gpm-manager.c
@@ -0,0 +1,27 @@
+Index: gpm-manager.c
+===================================================================
+RCS file: /cvs/gnome/gnome-power-manager/src/gpm-manager.c,v
+retrieving revision 1.172.2.2
+diff -u -r1.172.2.2 gpm-manager.c
+--- src/gpm-manager.c 19 Oct 2006 16:47:59 -0000 1.172.2.2
++++ src/gpm-manager.c 6 Nov 2006 19:02:16 -0000
+@@ -680,6 +680,10 @@
+ manager->priv->dpms_throttle_id = 0;
+ }
+ } else {
++ /* if throttle already exists then remove */
++ if (manager->priv->dpms_throttle_id > 0) {
++ gpm_screensaver_remove_throttle (manager->priv->screensaver, manager->priv->dpms_throttle_id);
++ }
+ manager->priv->dpms_throttle_id = gpm_screensaver_add_throttle (manager->priv->screensaver, _("Display power management activated"));
+ }
+ }
+@@ -2863,6 +2867,8 @@
+ /* Do we ignore inhibit requests? */
+ manager->priv->ignore_inhibits = gconf_client_get_bool (manager->priv->gconf_client,
+ GPM_PREF_IGNORE_INHIBITS, NULL);
++ /* set no throttle */
++ manager->priv->dpms_throttle_id = -1;
+ }
+
+ /**