aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2004-02-22 00:29:18 +0800
committerleeym <leeym@FreeBSD.org>2004-02-22 00:29:18 +0800
commit79a264adeb9fda33ca05263ccd53aa86f006e990 (patch)
tree23e3d1fc92e0b8acb4e8ae45c813bf02f8c59cd2 /sysutils
parentd402fb925fdb434d471c2dc7a631d0e9d031e51a (diff)
downloadfreebsd-ports-gnome-79a264adeb9fda33ca05263ccd53aa86f006e990.tar.gz
freebsd-ports-gnome-79a264adeb9fda33ca05263ccd53aa86f006e990.tar.zst
freebsd-ports-gnome-79a264adeb9fda33ca05263ccd53aa86f006e990.zip
- fix IEEE violation/SIGFPE abort on alpha that failed the f_crashdisk test
(patch by Greg Lewis) - fix compile failure on FreeBSD 5 when older port version is installed (problem reported by Tim Robbins; FreeBSD 4 was unaffected) - ignore m_large_file test on alpha and sparc64, apparently the test only stumbles over a different default block size and the failure isn't serious (problem reported by Greg Lewis) - cosmetic: swap $(CC) and gmake check in post-build so check comes last - bump PORTREVISION: the patches change the code on some systems - pkg-message.in: * use install when ln fails, /sbin and /usr/local need not be the same file system * tell the user he needs to repeat the steps after port upgrade - revise pkg-message generation and move it to pre-install, no need to cat(1) the file, sed(1) can read files by itself. - add pkg-deinstall: remind the user to remove e2fsck and fsck_ext2fs from /sbin if he's deinstalling for good, rather than upgrading. PR: 63167 Submitted by: Matthias Andree <matthias.andree@gmx.de>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/e2fsprogs/Makefile16
-rw-r--r--sysutils/e2fsprogs/files/pkg-message.in8
-rw-r--r--sysutils/e2fsprogs/pkg-deinstall9
3 files changed, 27 insertions, 6 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index 163f558416b5..965caacfbd00 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= e2fsprogs
PORTVERSION= 1.35.w20040131
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -29,7 +30,7 @@ INSTALLS_SHLIB= yes
NO_FILTER_SHLIBS= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-elf-shlibs --disable-fsck "--with-ldopts=-L${LOCALBASE}/lib"
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ENV+= CPPFLAGS='-I${WRKSRC}/lib -I${LOCALBASE}/include'
.if defined(DISABLE_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB= NLS="@comment "
@@ -37,6 +38,9 @@ PLIST_SUB= NLS="@comment "
MAKE_ARGS+= STATIC_LIBS="../lib/libext2fs.a ../lib/libcom_err.a ../lib/libblkid.a ../lib/libuuid.a ${LOCALBASE}/lib/libintl.a ${LOCALBASE}/lib/libiconv.a"
PLIST_SUB= NLS=""
.endif
+.if ${MACHINE_ARCH} == "alpha"
+CFLAGS+= -mieee
+.endif
CONFLICTS= ossp-uuid-*
@@ -68,13 +72,17 @@ post-patch:
-e 's|group root|group wheel|' \
-e '/Exit status is 0/ N;s/Exit status is 0\n/Exit status is 0/' \
${WRKSRC}/tests/m_*/expect.1
+.if ${MACHINE_ARCH} == "alpha" || ${MACHINE_ARCH} == "sparc64"
+ ${RM} -r ${WRKSRC}/tests/m_large_file
+.endif
-post-configure:
- @${CAT} ${FILESDIR}/pkg-message.in | ${SED} -e "s:%%PREFIX%%:${PREFIX}:" > ${PKGMESSAGE}
+pre-install:
+ ${RM} -f ${PKGMESSAGE}
+ ${SED} -e "s:%%PREFIX%%:${PREFIX}:" ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
post-build:
- cd ${WRKSRC}/tests && ${GMAKE} check
${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} ${LIBS} -o ${WRKSRC}/fsck_ext2fs ${FILESDIR}/fsck_ext2fs.c
+ cd ${WRKSRC}/tests && ${GMAKE} check
post-install:
${RM} ${PREFIX}/sbin/filefrag
diff --git a/sysutils/e2fsprogs/files/pkg-message.in b/sysutils/e2fsprogs/files/pkg-message.in
index 68ee6cc3e291..3b3c841989fb 100644
--- a/sysutils/e2fsprogs/files/pkg-message.in
+++ b/sysutils/e2fsprogs/files/pkg-message.in
@@ -2,5 +2,9 @@ To have your ext2 and ext3 filesystems fsck'ed correctly without explicitly
invoking the fsck_ext2fs utility installed by this port you will need to
create links for the fsck utilities installed by this port in /sbin, e.g.
-ln %%PREFIX%%/sbin/fsck_ext2fs /sbin/
-ln %%PREFIX%%/sbin/e2fsck.static /sbin/e2fsck
+ln -f %%PREFIX%%/sbin/fsck_ext2fs /sbin/ 2>/dev/null \
+ || install -m755 %%PREFIX%%/sbin/fsck_ext2fs /sbin/
+ln -f %%PREFIX%%/sbin/e2fsck.static /sbin/e2fsck 2>/dev/null \
+ || install -m755 %%PREFIX%%/sbin/e2fsck.static /sbin/e2fsck
+
+IMPORTANT: you also need to repeat the above steps after a port upgrade!
diff --git a/sysutils/e2fsprogs/pkg-deinstall b/sysutils/e2fsprogs/pkg-deinstall
new file mode 100644
index 000000000000..813ca04d43f8
--- /dev/null
+++ b/sysutils/e2fsprogs/pkg-deinstall
@@ -0,0 +1,9 @@
+if [ "$2" = "POST-DEINSTALL" ] ; then cat - <<_EOF
+
+If you are deinstalling the e2fsprogs port for good, rather than upgrading it,
+remember to remove the files you have installed into /sbin, example:
+
+rm -f /sbin/fsck_ext2fs /sbin/e2fsck
+
+_EOF
+fi