aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-04-22 12:46:36 +0800
committermarcus <marcus@FreeBSD.org>2003-04-22 12:46:36 +0800
commit7f1f373c25f74ecfbaf9c5bfb4074a95228216f6 (patch)
treea275bb65cb1b83d2d0c4e0c043186a0176c357ce /sysutils
parente19daf26a391b9070456a133fb8dbaf46ca059c8 (diff)
downloadfreebsd-ports-gnome-7f1f373c25f74ecfbaf9c5bfb4074a95228216f6.tar.gz
freebsd-ports-gnome-7f1f373c25f74ecfbaf9c5bfb4074a95228216f6.tar.zst
freebsd-ports-gnome-7f1f373c25f74ecfbaf9c5bfb4074a95228216f6.zip
Convert to new GNOME infrastructure.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/gconf-editor/Makefile5
-rw-r--r--sysutils/gnome-pkgview/Makefile5
-rw-r--r--sysutils/gnome-system-monitor/Makefile7
-rw-r--r--sysutils/gnomesystemmonitor/Makefile7
4 files changed, 6 insertions, 18 deletions
diff --git a/sysutils/gconf-editor/Makefile b/sysutils/gconf-editor/Makefile
index 6453d1c0b4cd..9d33b2cc07a3 100644
--- a/sysutils/gconf-editor/Makefile
+++ b/sysutils/gconf-editor/Makefile
@@ -15,17 +15,14 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A gconf database editor for the GNOME 2.0 environment
-LIB_DEPENDS= gconf-2.5:${PORTSDIR}/devel/gconf2
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack
+USE_GNOME= gnomeprefix gnomehack gconf2
USE_LIBTOOL= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/sysutils/gnome-pkgview/Makefile b/sysutils/gnome-pkgview/Makefile
index 6e1087952239..1b1b816abdd3 100644
--- a/sysutils/gnome-pkgview/Makefile
+++ b/sysutils/gnome-pkgview/Makefile
@@ -13,17 +13,14 @@ MASTER_SITES= http://www.gtnorthern.demon.co.uk/packages/gnome-pkgview/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Displays the version of GNOME 2 components installed
-LIB_DEPENDS= gnomeui-2.200:${PORTSDIR}/x11-toolkits/libgnomeui
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier
+USE_GNOME= gnomeprefix gnomehack gnomehier libgnomeui
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/sysutils/gnome-system-monitor/Makefile b/sysutils/gnome-system-monitor/Makefile
index 3e3331e67a45..c2b7b88af750 100644
--- a/sysutils/gnome-system-monitor/Makefile
+++ b/sysutils/gnome-system-monitor/Makefile
@@ -17,19 +17,16 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME 2.0 system monitor program
-LIB_DEPENDS= gnomeui-2.200:${PORTSDIR}/x11-toolkits/libgnomeui \
- gtop-2.0.2:${PORTSDIR}/devel/libgtop2 \
- wnck-1.9:${PORTSDIR}/x11-toolkits/libwnck
+LIB_DEPENDS= gtop-2.0.2:${PORTSDIR}/devel/libgtop2
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_GNOME= gnomeprefix gnomehack
+USE_GNOME= gnomeprefix gnomehack libgnomeui libwnck
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lutil"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/sysutils/gnomesystemmonitor/Makefile b/sysutils/gnomesystemmonitor/Makefile
index 3e3331e67a45..c2b7b88af750 100644
--- a/sysutils/gnomesystemmonitor/Makefile
+++ b/sysutils/gnomesystemmonitor/Makefile
@@ -17,19 +17,16 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME 2.0 system monitor program
-LIB_DEPENDS= gnomeui-2.200:${PORTSDIR}/x11-toolkits/libgnomeui \
- gtop-2.0.2:${PORTSDIR}/devel/libgtop2 \
- wnck-1.9:${PORTSDIR}/x11-toolkits/libwnck
+LIB_DEPENDS= gtop-2.0.2:${PORTSDIR}/devel/libgtop2
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_GNOME= gnomeprefix gnomehack
+USE_GNOME= gnomeprefix gnomehack libgnomeui libwnck
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lutil"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \