aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2016-11-13 07:40:13 +0800
committerswills <swills@FreeBSD.org>2016-11-13 07:40:13 +0800
commit83238e79b2191e0f6170748c4aeb8e741d6f0b25 (patch)
treeffc691a0eca43bd568b6b665037ce8a5f7ea984a /sysutils
parent6c9c292db2dcab82dbf94e2eacf4a9101fee5085 (diff)
downloadfreebsd-ports-gnome-83238e79b2191e0f6170748c4aeb8e741d6f0b25.tar.gz
freebsd-ports-gnome-83238e79b2191e0f6170748c4aeb8e741d6f0b25.tar.zst
freebsd-ports-gnome-83238e79b2191e0f6170748c4aeb8e741d6f0b25.zip
sysutils/consul: fix version string
While here, remove web ui from distfile Reported by: Douglas Thrift <douglas@douglasthrift.net>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/consul/Makefile4
-rw-r--r--sysutils/consul/distinfo2
-rw-r--r--sysutils/consul/files/patch-version_version.go13
3 files changed, 16 insertions, 3 deletions
diff --git a/sysutils/consul/Makefile b/sysutils/consul/Makefile
index 8c375e2828dd..1ffa5878f390 100644
--- a/sysutils/consul/Makefile
+++ b/sysutils/consul/Makefile
@@ -2,6 +2,7 @@
PORTNAME= consul
PORTVERSION= 0.7.1
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= sysutils
@@ -30,7 +31,8 @@ post-extract:
do-build:
@cd ${WRKSRC}/src/github.com/hashicorp/consul; ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build \
- -ldflags "-X main.GitDescribe=v${PORTVERSION}" -o bin/consul
+ -ldflags "-X github.com/hashicorp/consul/version.GitDescribe=v${PORTVERSION}" \
+ -o bin/consul
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/hashicorp/consul/bin/consul ${STAGEDIR}${PREFIX}/bin/consul
diff --git a/sysutils/consul/distinfo b/sysutils/consul/distinfo
index 9b5326181bff..63fde7d08af1 100644
--- a/sysutils/consul/distinfo
+++ b/sysutils/consul/distinfo
@@ -1,5 +1,3 @@
TIMESTAMP = 1478821632
-SHA256 (consul_0.7.1_web_ui.zip) = 1b793c60e1af24cc470421d0411e13748f451b51d8a6ed5fcabc8d00bfb84264
-SIZE (consul_0.7.1_web_ui.zip) = 255257
SHA256 (hashicorp-consul-v0.7.1_GH0.tar.gz) = d1498c851df8aa150c7b4398fdbb74467af4949d20ce5b4840b88095fce71135
SIZE (hashicorp-consul-v0.7.1_GH0.tar.gz) = 4003354
diff --git a/sysutils/consul/files/patch-version_version.go b/sysutils/consul/files/patch-version_version.go
new file mode 100644
index 000000000000..15feb611b547
--- /dev/null
+++ b/sysutils/consul/files/patch-version_version.go
@@ -0,0 +1,13 @@
+--- version/version.go.orig 2016-11-10 20:33:01 UTC
++++ version/version.go
+@@ -13,8 +13,8 @@ var (
+
+ // Release versions of the build. These will be filled in by one of the
+ // build tag-specific files.
+- Version = "unknown"
+- VersionPrerelease = "unknown"
++ Version = ""
++ VersionPrerelease = ""
+ )
+
+ // GetHumanVersion composes the parts of the version in a way that's suitable