aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorlkoeller <lkoeller@FreeBSD.org>2004-02-09 02:36:40 +0800
committerlkoeller <lkoeller@FreeBSD.org>2004-02-09 02:36:40 +0800
commitac2f34dde78c9193ffa624636234fb1e8c449861 (patch)
treee616f278b3cf69ca27f12177ebe7edac2b1bd036 /sysutils
parent22d201b6f56939c13d39629ec557438b0672a104 (diff)
downloadfreebsd-ports-gnome-ac2f34dde78c9193ffa624636234fb1e8c449861.tar.gz
freebsd-ports-gnome-ac2f34dde78c9193ffa624636234fb1e8c449861.tar.zst
freebsd-ports-gnome-ac2f34dde78c9193ffa624636234fb1e8c449861.zip
o) Support new ports OPTIONS mechanism for persistent build options.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/bacula-server/Makefile9
-rw-r--r--sysutils/bacula/Makefile9
2 files changed, 12 insertions, 6 deletions
diff --git a/sysutils/bacula-server/Makefile b/sysutils/bacula-server/Makefile
index 060be1e89513..f7599efd3bb1 100644
--- a/sysutils/bacula-server/Makefile
+++ b/sysutils/bacula-server/Makefile
@@ -36,6 +36,11 @@ CONFIGURE_ARGS= --with-tcp-wrappers=/usr/lib \
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+OPTIONS= CLIENT_ONLY "Build bacule file daemon only" off
+OPTIONS+= MYSQL "Build for MySQL database instead of SqLite" off
+
+.include <bsd.port.pre.mk>
+
# Default is full build with sqlite
.if defined(WITH_CLIENT_ONLY)
CONFIGURE_ARGS+= --enable-client-only
@@ -54,8 +59,6 @@ PLIST_SUB+= DBTYPE=${DBTYPE}
PLIST_SUB+= SERVER=""
.endif
-.include <bsd.port.pre.mk>
-
PORTDOCS= bacula.pdf html-manual/*
pre-everything::
@@ -65,7 +68,7 @@ pre-everything::
@${ECHO_MSG} "===> of data at the end of an tape. This is corrected in FreeBSD"
@${ECHO_MSG} "===> 4.9-RELEASE and 5.2-RELEASE or use the -stable or -current tree."
@${ECHO_MSG} ""
- @${ECHO_MSG} "You may use the following build options:"
+ @${ECHO_MSG} "You may use the following build options (or make config):"
@${ECHO_MSG} ""
@${ECHO_MSG} " WITH_CLIENT_ONLY=yes if you only want the file daemon."
.if !defined(WITH_MYSQL)
diff --git a/sysutils/bacula/Makefile b/sysutils/bacula/Makefile
index 060be1e89513..f7599efd3bb1 100644
--- a/sysutils/bacula/Makefile
+++ b/sysutils/bacula/Makefile
@@ -36,6 +36,11 @@ CONFIGURE_ARGS= --with-tcp-wrappers=/usr/lib \
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+OPTIONS= CLIENT_ONLY "Build bacule file daemon only" off
+OPTIONS+= MYSQL "Build for MySQL database instead of SqLite" off
+
+.include <bsd.port.pre.mk>
+
# Default is full build with sqlite
.if defined(WITH_CLIENT_ONLY)
CONFIGURE_ARGS+= --enable-client-only
@@ -54,8 +59,6 @@ PLIST_SUB+= DBTYPE=${DBTYPE}
PLIST_SUB+= SERVER=""
.endif
-.include <bsd.port.pre.mk>
-
PORTDOCS= bacula.pdf html-manual/*
pre-everything::
@@ -65,7 +68,7 @@ pre-everything::
@${ECHO_MSG} "===> of data at the end of an tape. This is corrected in FreeBSD"
@${ECHO_MSG} "===> 4.9-RELEASE and 5.2-RELEASE or use the -stable or -current tree."
@${ECHO_MSG} ""
- @${ECHO_MSG} "You may use the following build options:"
+ @${ECHO_MSG} "You may use the following build options (or make config):"
@${ECHO_MSG} ""
@${ECHO_MSG} " WITH_CLIENT_ONLY=yes if you only want the file daemon."
.if !defined(WITH_MYSQL)