aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2017-01-10 06:46:50 +0800
committerfeld <feld@FreeBSD.org>2017-01-10 06:46:50 +0800
commitd68d12e2b36e5cc710b2a1ac52e2ad62b6703ce7 (patch)
tree8465eece69458dcea9d0c27e3f3ab5479e685444 /sysutils
parentf4024f20cff50fe3fab71c41e7783c8d5bf7e0ae (diff)
downloadfreebsd-ports-gnome-d68d12e2b36e5cc710b2a1ac52e2ad62b6703ce7.tar.gz
freebsd-ports-gnome-d68d12e2b36e5cc710b2a1ac52e2ad62b6703ce7.tar.zst
freebsd-ports-gnome-d68d12e2b36e5cc710b2a1ac52e2ad62b6703ce7.zip
fswatch is a file change monitor that receives notifications when the contents
of the specified files or directories are modified. fswatch implements four kinds of monitors: * A monitor based on the File System Events API of Apple OS X. * A monitor based on kqueue, an event notification interface introduced in FreeBSD 4.1 and supported on most *BSD systems (including OS X). * A monitor based on inotify, a Linux kernel subsystem that reports file system changes to applications. * A monitor which periodically stats the file system, saves file modification times in memory and manually calculates file system changes, which can work on any operating system where stat (2) can be used. fswatch should build and work correctly on any system shipping either of the aforementioned APIs. WWW: https://github.com/emcrisostomo/fswatch PR: 200552 Submitted by: Enrico M. Crisostomo <enrico.m.crisostomo@gmail.com>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fswatch-mon/Makefile34
-rw-r--r--sysutils/fswatch-mon/distinfo3
-rw-r--r--sysutils/fswatch-mon/pkg-descr17
-rw-r--r--sysutils/fswatch-mon/pkg-plist53
5 files changed, 108 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 5d02af3d4bb1..3b89ecc1c01b 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -324,6 +324,7 @@
SUBDIR += fsbackup
SUBDIR += fsc
SUBDIR += fstyp
+ SUBDIR += fswatch-mon
SUBDIR += ftwin
SUBDIR += fusefs-afuse
SUBDIR += fusefs-chironfs
diff --git a/sysutils/fswatch-mon/Makefile b/sysutils/fswatch-mon/Makefile
new file mode 100644
index 000000000000..6a26519f1982
--- /dev/null
+++ b/sysutils/fswatch-mon/Makefile
@@ -0,0 +1,34 @@
+# Created by: Enrico M. Crisostomo <enrico.m.crisostomo@gmail.com>
+# $FreeBSD$
+
+PORTNAME= fswatch
+PORTVERSION= 1.9.3
+CATEGORIES= sysutils
+PKGNAMESUFFIX= -mon
+
+MAINTAINER= enrico.m.crisostomo@gmail.com
+COMMENT= Cross-platform file change monitor
+
+LICENSE= GPLv3
+
+USES= autoreconf gettext libtool makeinfo
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+INFO= fswatch
+
+CONFLCICTS_INSTALL= fswatch-[0-9]*
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+USE_GITHUB= yes
+GH_ACCOUNT= emcrisostomo
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libfswatch.so
+
+.include <bsd.port.mk>
diff --git a/sysutils/fswatch-mon/distinfo b/sysutils/fswatch-mon/distinfo
new file mode 100644
index 000000000000..8e9bbef94987
--- /dev/null
+++ b/sysutils/fswatch-mon/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1484000771
+SHA256 (emcrisostomo-fswatch-1.9.3_GH0.tar.gz) = f2ed037dacebf688773f94e474009094dff28bf65faaba8cc4adb16a57435b49
+SIZE (emcrisostomo-fswatch-1.9.3_GH0.tar.gz) = 202937
diff --git a/sysutils/fswatch-mon/pkg-descr b/sysutils/fswatch-mon/pkg-descr
new file mode 100644
index 000000000000..875f70fb4654
--- /dev/null
+++ b/sysutils/fswatch-mon/pkg-descr
@@ -0,0 +1,17 @@
+fswatch is a file change monitor that receives notifications when the contents
+of the specified files or directories are modified. fswatch implements four
+kinds of monitors:
+
+ * A monitor based on the File System Events API of Apple OS X.
+ * A monitor based on kqueue, an event notification interface introduced in
+ FreeBSD 4.1 and supported on most *BSD systems (including OS X).
+ * A monitor based on inotify, a Linux kernel subsystem that reports file
+ system changes to applications.
+ * A monitor which periodically stats the file system, saves file modification
+ times in memory and manually calculates file system changes, which can work
+ on any operating system where stat (2) can be used.
+
+fswatch should build and work correctly on any system shipping either of the
+aforementioned APIs.
+
+WWW: https://github.com/emcrisostomo/fswatch
diff --git a/sysutils/fswatch-mon/pkg-plist b/sysutils/fswatch-mon/pkg-plist
new file mode 100644
index 000000000000..2598b27b3644
--- /dev/null
+++ b/sysutils/fswatch-mon/pkg-plist
@@ -0,0 +1,53 @@
+bin/fswatch
+include/libfswatch/c++/event.hpp
+include/libfswatch/c++/filter.hpp
+include/libfswatch/c++/kqueue_monitor.hpp
+include/libfswatch/c++/libfswatch_exception.hpp
+include/libfswatch/c++/libfswatch_map.hpp
+include/libfswatch/c++/libfswatch_set.hpp
+include/libfswatch/c++/monitor.hpp
+include/libfswatch/c++/path_utils.hpp
+include/libfswatch/c++/poll_monitor.hpp
+include/libfswatch/c++/string_utils.hpp
+include/libfswatch/c/cevent.h
+include/libfswatch/c/cfilter.h
+include/libfswatch/c/cmonitor.h
+include/libfswatch/c/error.h
+include/libfswatch/c/libfswatch.h
+include/libfswatch/c/libfswatch_log.h
+include/libfswatch/c/libfswatch_types.h
+lib/libfswatch.a
+lib/libfswatch.so
+lib/libfswatch.so.6
+lib/libfswatch.so.6.2.0
+man/man7/fswatch.7.gz
+%%PORTDOCS%%%%DOCSDIR%%/ABOUT-NLS
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/CONTRIBUTING.md
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README.bsd
+%%PORTDOCS%%%%DOCSDIR%%/README.codestyle
+%%PORTDOCS%%%%DOCSDIR%%/README.freebsd
+%%PORTDOCS%%%%DOCSDIR%%/README.gnu-build-system
+%%PORTDOCS%%%%DOCSDIR%%/README.illumos
+%%PORTDOCS%%%%DOCSDIR%%/README.linux
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTDOCS%%%%DOCSDIR%%/README.osx
+%%PORTDOCS%%%%DOCSDIR%%/README.smartos
+%%PORTDOCS%%%%DOCSDIR%%/README.solaris
+%%PORTDOCS%%%%DOCSDIR%%/README.windows
+%%PORTDOCS%%share/doc/libfswatch/AUTHORS
+%%PORTDOCS%%share/doc/libfswatch/COPYING
+%%PORTDOCS%%share/doc/libfswatch/LICENSE
+%%PORTDOCS%%share/doc/libfswatch/NEWS
+%%PORTDOCS%%share/doc/libfswatch/README.md
+%%NLS%%share/locale/en@boldquot/LC_MESSAGES/fswatch.mo
+%%NLS%%share/locale/en@boldquot/LC_MESSAGES/libfswatch.mo
+%%NLS%%share/locale/en@quot/LC_MESSAGES/fswatch.mo
+%%NLS%%share/locale/en@quot/LC_MESSAGES/libfswatch.mo
+%%NLS%%share/locale/es/LC_MESSAGES/fswatch.mo
+%%NLS%%share/locale/es/LC_MESSAGES/libfswatch.mo
+%%NLS%%share/locale/it/LC_MESSAGES/fswatch.mo
+%%NLS%%share/locale/it/LC_MESSAGES/libfswatch.mo