aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-02-09 06:52:04 +0800
committerstas <stas@FreeBSD.org>2009-02-09 06:52:04 +0800
commit1a6f242bcc2596cca5d6c208ee58e1021be814e6 (patch)
tree8bf2a5eb524f663739ee6231e00f7cb157d194c7 /sysutils
parentea971ae6071298df02dbd927b9e47fa46819fe03 (diff)
downloadfreebsd-ports-gnome-1a6f242bcc2596cca5d6c208ee58e1021be814e6.tar.gz
freebsd-ports-gnome-1a6f242bcc2596cca5d6c208ee58e1021be814e6.tar.zst
freebsd-ports-gnome-1a6f242bcc2596cca5d6c208ee58e1021be814e6.zip
- Update to 1.24.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/x86info/Makefile2
-rw-r--r--sysutils/x86info/distinfo6
-rw-r--r--sysutils/x86info/files/patch-lsmsr.c13
3 files changed, 9 insertions, 12 deletions
diff --git a/sysutils/x86info/Makefile b/sysutils/x86info/Makefile
index 0a1c5c40c7fb..6655febfafc3 100644
--- a/sysutils/x86info/Makefile
+++ b/sysutils/x86info/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= x86info
-PORTVERSION= 1.23
+PORTVERSION= 1.24
PORTREVISION= 0
CATEGORIES= sysutils
MASTER_SITES= http://www.codemonkey.org.uk/projects/x86info/ \
diff --git a/sysutils/x86info/distinfo b/sysutils/x86info/distinfo
index 0a67396c24ac..f6293e20ff64 100644
--- a/sysutils/x86info/distinfo
+++ b/sysutils/x86info/distinfo
@@ -1,3 +1,3 @@
-MD5 (x86info-1.23.tgz) = 2313f797b605fc46419d8fe08e1ff821
-SHA256 (x86info-1.23.tgz) = 15cf5bb4a6ff90dd1f6486f12684986139ef2b4c98d9a259b5abb39b4655177a
-SIZE (x86info-1.23.tgz) = 77055
+MD5 (x86info-1.24.tgz) = f4476fb55918cf3b20312f858af44334
+SHA256 (x86info-1.24.tgz) = 6cc44be6cabf32d77fde33f994899f7c917580f6595f656d6d1218cea131a575
+SIZE (x86info-1.24.tgz) = 78874
diff --git a/sysutils/x86info/files/patch-lsmsr.c b/sysutils/x86info/files/patch-lsmsr.c
index 228af6e7a73b..122df376dc2b 100644
--- a/sysutils/x86info/files/patch-lsmsr.c
+++ b/sysutils/x86info/files/patch-lsmsr.c
@@ -1,5 +1,5 @@
---- lsmsr.c.orig 2008-12-16 22:09:47.000000000 +0300
-+++ lsmsr.c 2008-12-30 22:35:23.000000000 +0300
+--- lsmsr.c.orig 2009-02-06 20:10:58.000000000 +0300
++++ lsmsr.c 2009-02-09 01:51:49.000000000 +0300
@@ -31,6 +31,18 @@
#include "AMD/fam10h.h"
#include "generic_msr.h"
@@ -19,7 +19,7 @@
/* Todos:
* - add (list and eventually write) support for write-only MSR
* - add decoding support for bit fields
-@@ -120,6 +132,32 @@
+@@ -117,6 +129,29 @@
fprintf(stdout, "%s version %s\n", g.prog, VERSION);
}
@@ -41,18 +41,15 @@
+#endif
+ return 0;
+ }
-+
+ *val = args.data;
+
+ return 0;
+}
-+
+#else /* !__FreeBSD__ */
-+
- int get_msr_val(unsigned int msr, unsigned long long *val)
+ static int get_msr_val(unsigned int msr, unsigned long long *val)
{
off64_t off;
-@@ -145,11 +183,17 @@
+@@ -142,11 +177,17 @@
return 0;
}