aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-05-24 00:36:28 +0800
committerwg <wg@FreeBSD.org>2013-05-24 00:36:28 +0800
commit29f0227fa04be3b05163634550d9e7634178b21e (patch)
treec3e03ba092f0519bc8b00d8f806340ee823360a3 /sysutils
parenta82a2cc6bc0afc894c1cdedadd21380a150f496a (diff)
downloadfreebsd-ports-gnome-29f0227fa04be3b05163634550d9e7634178b21e.tar.gz
freebsd-ports-gnome-29f0227fa04be3b05163634550d9e7634178b21e.tar.zst
freebsd-ports-gnome-29f0227fa04be3b05163634550d9e7634178b21e.zip
- Use shebangfix instead of manual replace
PR: ports/178822 Submitted by: Nikolai Lifanov <lifanov@mail.lifanov.com> (maintainer) Approved by: culot (mentor)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/ansible/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/sysutils/ansible/Makefile b/sysutils/ansible/Makefile
index 607acd917082..e5c849ad5952 100644
--- a/sysutils/ansible/Makefile
+++ b/sysutils/ansible/Makefile
@@ -19,6 +19,9 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PYTHON= -2.7
USE_PYDISTUTILS= yes
+USES= shebangfix
+SHEBANG_FILES= ${WRKSRC}/library/*
+
SUB_FILES= pkg-message
PORTEXAMPLES= *
MAN1= ansible-doc.1 ansible-playbook.1 ansible-pull.1 ansible.1
@@ -40,8 +43,6 @@ post-patch-script:
${WRKSRC}/lib/ansible/constants.py \
${WRKSRC}/lib/ansible/playbook/__init__.py \
${WRKSRC}/lib/ansible/runner/__init__.py
- @${REINPLACE_CMD} -e "s|/usr/bin/python|/usr/bin/env python|" \
- ${WRKSRC}/library/*
pre-install-script:
@(cd ${WRKSRC} && ${FIND} . -type f -name '*.bak' -exec ${RM} {} +)