aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2010-12-16 18:15:06 +0800
committeravilla <avilla@FreeBSD.org>2010-12-16 18:15:06 +0800
commit3160be5302691cca0e030501da4021b4953c2a70 (patch)
tree4079e4178c1c971b66c415a93a0e925822393ebf /sysutils
parentff985a93948083361f87fe95a146e2676efcfb52 (diff)
downloadfreebsd-ports-gnome-3160be5302691cca0e030501da4021b4953c2a70.tar.gz
freebsd-ports-gnome-3160be5302691cca0e030501da4021b4953c2a70.tar.zst
freebsd-ports-gnome-3160be5302691cca0e030501da4021b4953c2a70.zip
- Add user serviceable knobs.
PR: ports/152718 Submitted by: Christopher Shumway <cshumway@titan-project.org> Approved by: Mykola Dzham <i@levsha.me> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/pdsh/Makefile50
-rw-r--r--sysutils/pdsh/pkg-plist18
2 files changed, 60 insertions, 8 deletions
diff --git a/sysutils/pdsh/Makefile b/sysutils/pdsh/Makefile
index e1e46e349641..f25ed4131d9a 100644
--- a/sysutils/pdsh/Makefile
+++ b/sysutils/pdsh/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pdsh
PORTVERSION= 2.23
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= GOOGLE_CODE
@@ -16,11 +16,57 @@ COMMENT= Parallel Distributed Shell
LICENSE= GPLv2
-CONFIGURE_ARGS= --with-ssh
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_PERL5_BUILD=yes
+OPTIONS= SSH "Enable SSH support" On \
+ DSHGROUPS "Enable DSH groups" On \
+ NETGROUP "Enable NIS Netgroup support" Off \
+ READLINE "Enable GNU readline support" Off \
+ RSH "Enable RSH support" Off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_SSH)
+CONFIGURE_ARGS+= --with-ssh
+PLIST_SUB+= SSH=""
+.else
+CONFIGURE_ARGS+= --without-ssh
+PLIST_SUB+= SSH="@comment "
+.endif
+
+.if defined(WITH_DSHGROUPS)
+CONFIGURE_ARGS+= --with-dshgroups
+PLIST_SUB+= DSH=""
+.else
+CONFIGURE_ARGS+= --without-dshgroups
+PLIST_SUB+= DSH="@comment "
+.endif
+
+.if defined(WITH_NETGROUP)
+CONFIGURE_ARGS+= --with-netgroup
+PLIST_SUB+= NETGROUP=""
+.else
+CONFIGURE_ARGS+= --without-netgroup
+PLIST_SUB+= NETGROUP="@comment "
+.endif
+
+.if defined(WITH_READLINE)
+CONFIGURE_ARGS+= --with-readline
+LIB_DEPENDS+= readline:${PORTSDIR}/devel/readline
+.else
+CONFIGURE_ARGS+= --without-readline
+.endif
+
+.if defined(WITH_RSH)
+CONFIGURE_ARGS+= --with-rsh
+PLIST_SUB+= RSH=""
+.else
+CONFIGURE_ARGS+= --without-rsh
+PLIST_SUB+= RSH="@comment "
+.endif
+
MAN1= dshbak.1 pdcp.1 pdsh.1
MLINKS= pdcp.1 rpdcp.1
diff --git a/sysutils/pdsh/pkg-plist b/sysutils/pdsh/pkg-plist
index 59f047c26fa3..162aec8e2605 100644
--- a/sysutils/pdsh/pkg-plist
+++ b/sysutils/pdsh/pkg-plist
@@ -6,10 +6,16 @@ bin/rpdcp
lib/pdsh/execcmd.a
lib/pdsh/execcmd.la
lib/pdsh/execcmd.so
-lib/pdsh/sshcmd.a
-lib/pdsh/sshcmd.la
-lib/pdsh/sshcmd.so
-lib/pdsh/xrcmd.a
-lib/pdsh/xrcmd.la
-lib/pdsh/xrcmd.so
+%%DSH%%lib/pdsh/dshgroup.a
+%%DSH%%lib/pdsh/dshgroup.la
+%%DSH%%lib/pdsh/dshgroup.so
+%%NETGROUP%%lib/pdsh/netgroup.a
+%%NETGROUP%%lib/pdsh/netgroup.la
+%%NETGROUP%%lib/pdsh/netgroup.so
+%%SSH%%lib/pdsh/sshcmd.a
+%%SSH%%lib/pdsh/sshcmd.la
+%%SSH%%lib/pdsh/sshcmd.so
+%%RSH%%lib/pdsh/xrcmd.a
+%%RSH%%lib/pdsh/xrcmd.la
+%%RSH%%lib/pdsh/xrcmd.so
@dirrm lib/pdsh