aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-05 16:15:24 +0800
committerbapt <bapt@FreeBSD.org>2013-05-05 16:15:24 +0800
commit38e0172ba3cbfa642f83d0ef6e5f99006fdf369c (patch)
tree16c9ad7317653827c73b0b8c9982857e12ee4f01 /sysutils
parent52a8fdac71139b91e871909899732a523b7c1182 (diff)
downloadfreebsd-ports-gnome-38e0172ba3cbfa642f83d0ef6e5f99006fdf369c.tar.gz
freebsd-ports-gnome-38e0172ba3cbfa642f83d0ef6e5f99006fdf369c.tar.zst
freebsd-ports-gnome-38e0172ba3cbfa642f83d0ef6e5f99006fdf369c.zip
Partial convert to new options framework
Fix USES+= set after .pre.mk
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/cdrtools-devel/Makefile10
-rw-r--r--sysutils/cdrtools/Makefile15
2 files changed, 11 insertions, 14 deletions
diff --git a/sysutils/cdrtools-devel/Makefile b/sysutils/cdrtools-devel/Makefile
index 7112e1425ba2..338960aad320 100644
--- a/sysutils/cdrtools-devel/Makefile
+++ b/sysutils/cdrtools-devel/Makefile
@@ -1,5 +1,5 @@
# $FreeBSD$
-#
+
###########################################################################
# This makefile was contributed by Marius Strobl.
###########################################################################
@@ -88,10 +88,10 @@ MAKE_ENV= CCOM=cc GMAKE_NOWARN=true INS_BASE=${LOCALBASE} \
INS_RBASE=${LOCALBASE}
CDRTLSTARGET= ${ARCH:S/powerpc64/powerpc/}-freebsd-cc
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if exists(${LOCALBASE}/lib/libiconv.a) || \
- exists(${LOCALBASE}/lib/libintl.a) || !defined(WITHOUT_NLS)
+ exists(${LOCALBASE}/lib/libintl.a) || ${PORT_OPTIONS:MNLS}
MAKE_ENV+= OSDEFS=-I${LOCALBASE}/include
USES+= gettext iconv
.endif
@@ -214,7 +214,7 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/rscsi/rscsi.dfl ${PREFIX}/etc/rscsi
.endif
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
@@ -238,4 +238,4 @@ post-install:
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL; fi
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/cdrtools/Makefile b/sysutils/cdrtools/Makefile
index 9f9e4dbfbc9e..3f907442961c 100644
--- a/sysutils/cdrtools/Makefile
+++ b/sysutils/cdrtools/Makefile
@@ -1,9 +1,6 @@
-# New ports collection makefile for: cdrtools
-# Date created: Wed Jul 25 23:30:19 CEST 2001
-# Whom: Dirk Froemberg <dirk@FreeBSD.org>
-#
+# Created by: Dirk Froemberg <dirk@FreeBSD.org>
# $FreeBSD$
-#
+
###########################################################################
# This makefile was contributed by Marius Strobl.
###########################################################################
@@ -94,10 +91,10 @@ MAKE_ENV+= CCOM=cc GMAKE_NOWARN=true INS_BASE=${LOCALBASE} \
INS_RBASE=${LOCALBASE}
CDRTLSTARGET= ${ARCH:S/powerpc64/powerpc/}-freebsd-cc
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if exists(${LOCALBASE}/lib/libiconv.a) || \
- exists(${LOCALBASE}/lib/libintl.a) || !defined(WITHOUT_NLS)
+ exists(${LOCALBASE}/lib/libintl.a) || ${PORT_OPTIONS:MNLS}
MAKE_ENV+= OSDEFS=-I${LOCALBASE}/include
USES+= gettext iconv
.endif
@@ -222,7 +219,7 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/rscsi/rscsi.dfl ${PREFIX}/etc/rscsi
.endif
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
@@ -246,4 +243,4 @@ post-install:
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL; fi
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>