aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
committerkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
commit39ef19450c2cf8b75e3b20495c6e2331f67e3138 (patch)
tree68e92ca91db8af8e96889640de621794add90af4 /sysutils
parent6a56442427dd00f76ca13093ea38b248d54a7964 (diff)
downloadfreebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.gz
freebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.zst
freebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.zip
Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where needed.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/brasero/Makefile4
-rw-r--r--sysutils/gnome-mount/Makefile8
-rw-r--r--sysutils/gnome-mount/files/patch-src_gnome-mount.c21
-rw-r--r--sysutils/gnome-power-manager/Makefile7
-rw-r--r--sysutils/gnome-power-manager/files/patch-src_gpm-manager.c15
-rw-r--r--sysutils/gnome-settings-daemon/Makefile8
-rw-r--r--sysutils/gnome-settings-daemon/files/patch-libnotify58
-rw-r--r--sysutils/tracker-client/Makefile4
-rw-r--r--sysutils/tracker-client/files/patch-src_tracker-applet_tracker-applet.c28
-rw-r--r--sysutils/tracker-gnome/Makefile2
-rw-r--r--sysutils/xfce4-power-manager/Makefile3
-rw-r--r--sysutils/xfce4-power-manager/files/patch-src__xfpm-notify.c12
-rw-r--r--sysutils/xfce4-settings/Makefile4
13 files changed, 157 insertions, 17 deletions
diff --git a/sysutils/brasero/Makefile b/sysutils/brasero/Makefile
index c8f2546bbdb0..53bf64e1bc36 100644
--- a/sysutils/brasero/Makefile
+++ b/sysutils/brasero/Makefile
@@ -7,7 +7,7 @@
PORTNAME= brasero
PORTVERSION= 2.32.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils audio multimedia gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -15,7 +15,7 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= CD/DVD mastering tool for the GNOME desktop
-LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify \
+LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify \
unique-1.0.2:${PORTSDIR}/x11-toolkits/unique \
totem-plparser.17:${PORTSDIR}/multimedia/totem-pl-parser \
canberra-gtk.0:${PORTSDIR}/audio/libcanberra
diff --git a/sysutils/gnome-mount/Makefile b/sysutils/gnome-mount/Makefile
index 2ac81de1a8bc..603aeaf248c0 100644
--- a/sysutils/gnome-mount/Makefile
+++ b/sysutils/gnome-mount/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/sysutils/gnome-mount/Makefile,v 1.24 2008/02/04 23:18:46 mezz Exp $
+# $MCom: ports/sysutils/gnome-mount/Makefile,v 1.28 2011/03/08 19:25:20 kwm Exp $
#
PORTNAME= gnome-mount
PORTVERSION= 0.8
-PORTREVISION= 7
+PORTREVISION= 9
CATEGORIES= sysutils gnome
MASTER_SITES= http://hal.freedesktop.org/releases/
@@ -16,8 +16,8 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A front-end to mount, umount, and eject using HAL
LIB_DEPENDS= hal.1:${PORTSDIR}/sysutils/hal \
- notify.1:${PORTSDIR}/devel/libnotify \
- gnome-keyring:${PORTSDIR}/security/gnome-keyring
+ notify.4:${PORTSDIR}/devel/libnotify \
+ gnome-keyring:${PORTSDIR}/security/libgnome-keyring
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/polkit-gnome.pc:${PORTSDIR}/sysutils/policykit-gnome
USE_GNOME= gnomeprefix gnomehack intlhack gconf2 gtk20
diff --git a/sysutils/gnome-mount/files/patch-src_gnome-mount.c b/sysutils/gnome-mount/files/patch-src_gnome-mount.c
new file mode 100644
index 000000000000..fb1a6719263d
--- /dev/null
+++ b/sysutils/gnome-mount/files/patch-src_gnome-mount.c
@@ -0,0 +1,21 @@
+--- src/gnome-mount.c.orig 2010-12-26 14:53:42.000000000 +0100
++++ src/gnome-mount.c 2010-12-26 18:19:30.000000000 +0100
+@@ -38,7 +38,7 @@
+
+ #include <glib/gi18n.h>
+ #include <gconf/gconf-client.h>
+-#include <gdk/gdkx.h>
++#include <gtk/gtk.h>
+ #include "copy-paste/gnome-password-dialog.h"
+ #include <gnome-keyring.h>
+ #include <libnotify/notify.h>
+@@ -1577,8 +1577,7 @@
+ message = g_strdup_printf (_("There is data that needs to be written to the device %s before it can be removed. Please do not remove the media or disconnect the drive."), unmount_note_drive_name);
+ unmount_note = notify_notification_new (summary,
+ message,
+- "gnome-dev-harddisk", /* TODO: use appropriate icon */
+- NULL);
++ "gnome-dev-harddisk");
+ if (unmount_note == NULL) {
+ g_warning ("Cannot create note for unmount cache sync");
+ } else {
diff --git a/sysutils/gnome-power-manager/Makefile b/sysutils/gnome-power-manager/Makefile
index fd13bee4c29f..093254d5f728 100644
--- a/sysutils/gnome-power-manager/Makefile
+++ b/sysutils/gnome-power-manager/Makefile
@@ -3,11 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/sysutils/gnome-power-manager/Makefile,v 1.69 2010/09/27 18:49:22 kwm Exp $
+# $MCom: ports/sysutils/gnome-power-manager/Makefile,v 1.73 2011/04/30 20:43:26 mezz Exp $
#
PORTNAME= gnome-power-manager
PORTVERSION= 2.32.0
+PORTREVISION= 1
CATEGORIES= sysutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -17,11 +18,13 @@ COMMENT= Power management system for the GNOME Desktop
LIB_DEPENDS= upower-glib.1:${PORTSDIR}/sysutils/upower \
canberra-gtk.0:${PORTSDIR}/audio/libcanberra \
- notify.1:${PORTSDIR}/devel/libnotify \
+ notify.4:${PORTSDIR}/devel/libnotify \
execinfo:${PORTSDIR}/devel/libexecinfo \
unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
RUN_DEPENDS= pkexec:${PORTSDIR}/sysutils/polkit
+CONFLICTS= gnome-power-manager-3.[0-9]*
+
USE_GETTEXT= yes
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/sysutils/gnome-power-manager/files/patch-src_gpm-manager.c b/sysutils/gnome-power-manager/files/patch-src_gpm-manager.c
new file mode 100644
index 000000000000..a71c447da691
--- /dev/null
+++ b/sysutils/gnome-power-manager/files/patch-src_gpm-manager.c
@@ -0,0 +1,15 @@
+--- src/gpm-manager.c.orig 2011-03-07 12:49:54.000000000 +0100
++++ src/gpm-manager.c 2011-03-07 12:51:08.000000000 +0100
+@@ -481,11 +481,7 @@ gpm_manager_notify (GpmManager *manager,
+ gpm_manager_notify_close (manager, *notification_class);
+
+ /* if the status icon is hidden, don't point at it */
+- if (manager->priv->status_icon != NULL &&
+- gtk_status_icon_is_embedded (manager->priv->status_icon))
+- notification = notify_notification_new_with_status_icon (title, message, icon, manager->priv->status_icon);
+- else
+- notification = notify_notification_new (title, message, icon, NULL);
++ notification = notify_notification_new (title, message, icon);
+ notify_notification_set_timeout (notification, timeout);
+ notify_notification_set_urgency (notification, urgency);
+ g_signal_connect (notification, "closed", G_CALLBACK (gpm_manager_notification_closed_cb), notification_class);
diff --git a/sysutils/gnome-settings-daemon/Makefile b/sysutils/gnome-settings-daemon/Makefile
index 588bb471cf16..82a7702e639e 100644
--- a/sysutils/gnome-settings-daemon/Makefile
+++ b/sysutils/gnome-settings-daemon/Makefile
@@ -3,12 +3,12 @@
# Whom: Koop Mast <kwm@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/sysutils/gnome-settings-daemon/Makefile,v 1.72 2010/11/15 13:50:07 kwm Exp $
+# $MCom: ports/sysutils/gnome-settings-daemon/Makefile,v 1.75 2011/04/25 19:56:57 mezz Exp $
#
PORTNAME= gnome-settings-daemon
PORTVERSION= 2.32.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -17,10 +17,12 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME 2 settings daemon
LIB_DEPENDS= canberra-gtk.0:${PORTSDIR}/audio/libcanberra \
- notify.1:${PORTSDIR}/devel/libnotify \
+ notify.4:${PORTSDIR}/devel/libnotify \
nss3.1:${PORTSDIR}/security/nss
RUN_DEPENDS= xrdb:${PORTSDIR}/x11/xrdb
+CONFLICTS= gnome-settings-daemon-3.[0-9]*
+
USE_XORG= xxf86misc
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/sysutils/gnome-settings-daemon/files/patch-libnotify b/sysutils/gnome-settings-daemon/files/patch-libnotify
new file mode 100644
index 000000000000..1166875bf74b
--- /dev/null
+++ b/sysutils/gnome-settings-daemon/files/patch-libnotify
@@ -0,0 +1,58 @@
+From e1ab570b0dce479ba235e5542ea07d1b5bafc4c9 Mon Sep 17 00:00:00 2001
+From: William Jon McCann <jmccann@redhat.com>
+Date: Tue, 12 Oct 2010 03:35:45 +0000
+Subject: Require libnotify 0.6.0
+
+---
+diff --git a/plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c b/plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c
+index 9ca820a..f5964b9 100644
+--- plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c
++++ plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c
+@@ -608,9 +608,7 @@ ax_slowkeys_warning_post_bubble (GsdA11yKeyboardManager *manager,
+ gsd_a11y_keyboard_manager_ensure_status_icon (manager);
+ manager->priv->notification = notify_notification_new (title,
+ message,
+- "preferences-desktop-accessibility",
+- NULL);
+- notify_notification_attach_to_status_icon (manager->priv->notification, manager->priv->status_icon);
++ "preferences-desktop-accessibility");
+ notify_notification_set_timeout (manager->priv->notification, NOTIFICATION_TIMEOUT * 1000);
+
+ notify_notification_add_action (manager->priv->notification,
+@@ -747,9 +745,7 @@ ax_stickykeys_warning_post_bubble (GsdA11yKeyboardManager *manager,
+ gsd_a11y_keyboard_manager_ensure_status_icon (manager);
+ manager->priv->notification = notify_notification_new (title,
+ message,
+- "preferences-desktop-accessibility",
+- NULL);
+- notify_notification_attach_to_status_icon (manager->priv->notification, manager->priv->status_icon);
++ "preferences-desktop-accessibility");
+ notify_notification_set_timeout (manager->priv->notification, NOTIFICATION_TIMEOUT * 1000);
+
+ notify_notification_add_action (manager->priv->notification,
+diff --git a/plugins/xrandr/gsd-xrandr-manager.c b/plugins/xrandr/gsd-xrandr-manager.c
+index 02536a3..ef57d5b 100644
+--- plugins/xrandr/gsd-xrandr-manager.c
++++ plugins/xrandr/gsd-xrandr-manager.c
+@@ -1084,16 +1084,9 @@ error_message (GsdXrandrManager *mgr, const char *primary_text, GError *error_to
+
+ g_assert (error_to_display == NULL || secondary_text == NULL);
+
+- if (priv->status_icon)
+- notification = notify_notification_new_with_status_icon (primary_text,
+- error_to_display ? error_to_display->message : secondary_text,
+- GSD_XRANDR_ICON_NAME,
+- priv->status_icon);
+- else
+- notification = notify_notification_new (primary_text,
+- error_to_display ? error_to_display->message : secondary_text,
+- GSD_XRANDR_ICON_NAME,
+- NULL);
++ notification = notify_notification_new (primary_text,
++ error_to_display ? error_to_display->message : secondary_text,
++ GSD_XRANDR_ICON_NAME);
+
+ notify_notification_show (notification, NULL); /* NULL-GError */
+ #else
+--
+cgit v0.8.3.4
diff --git a/sysutils/tracker-client/Makefile b/sysutils/tracker-client/Makefile
index e9877fa7676a..6d59314e5962 100644
--- a/sysutils/tracker-client/Makefile
+++ b/sysutils/tracker-client/Makefile
@@ -8,7 +8,7 @@
PORTNAME= tracker
PORTVERSION= 0.6.95
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= sysutils gnome
MASTER_SITES= GNOME
PKGNAMESUFFIX?= -client
@@ -18,7 +18,7 @@ COMMENT= Object database, tag/metadata database, search tool and indexer
LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3 \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- poppler-glib.5:${PORTSDIR}/graphics/poppler-gtk \
+ poppler-glib.6:${PORTSDIR}/graphics/poppler-gtk \
exif.12:${PORTSDIR}/graphics/libexif \
wv-1.2.4:${PORTSDIR}/textproc/wv \
gmime-2.0.4:${PORTSDIR}/mail/gmime2 \
diff --git a/sysutils/tracker-client/files/patch-src_tracker-applet_tracker-applet.c b/sysutils/tracker-client/files/patch-src_tracker-applet_tracker-applet.c
new file mode 100644
index 000000000000..7bd62bb23bf1
--- /dev/null
+++ b/sysutils/tracker-client/files/patch-src_tracker-applet_tracker-applet.c
@@ -0,0 +1,28 @@
+--- src/tracker-applet/tracker-applet.c.orig 2011-08-16 14:59:30.000000000 +0200
++++ src/tracker-applet/tracker-applet.c 2011-08-16 15:00:25.000000000 +0200
+@@ -2074,10 +2074,9 @@ tray_icon_show_message (TrayIcon *ico
+ }
+
+ notification =
+- notify_notification_new_with_status_icon ("Tracker",
++ notify_notification_new ("Tracker",
+ msg,
+- NULL,
+- priv->icon);
++ NULL);
+
+ notify_notification_set_urgency (notification, NOTIFY_URGENCY_NORMAL);
+ notify_notification_show (notification, NULL);
+@@ -2125,10 +2124,9 @@ tray_icon_show_error (TrayIcon *icon,
+ va_end (args);
+
+ error_notification =
+- notify_notification_new_with_status_icon ("Tracker",
++ notify_notification_new ("Tracker",
+ msg,
+- NULL,
+- priv->icon);
++ NULL);
+
+ notify_notification_set_timeout (error_notification, NOTIFY_EXPIRES_NEVER);
+ notify_notification_set_urgency (error_notification, NOTIFY_URGENCY_CRITICAL);
diff --git a/sysutils/tracker-gnome/Makefile b/sysutils/tracker-gnome/Makefile
index 81e51d8ddf37..6b05f23391db 100644
--- a/sysutils/tracker-gnome/Makefile
+++ b/sysutils/tracker-gnome/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
# $MCom: ports/sysutils/tracker-gnome/Makefile,v 1.4 2009/08/08 18:46:42 ahze Exp $
-PORTREVISION= 2
+PORTREVISION= 3
COMMENT= Tracker GNOME applet, search tool, and preference programs
diff --git a/sysutils/xfce4-power-manager/Makefile b/sysutils/xfce4-power-manager/Makefile
index b709e25df996..d76b5054ecc9 100644
--- a/sysutils/xfce4-power-manager/Makefile
+++ b/sysutils/xfce4-power-manager/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xfce4-power-manager
PORTVERSION= 1.0.10
+PORTREVISION= 1
CATEGORIES= sysutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/xfce/${PORTNAME}/${PORTVERSION:R}
@@ -15,7 +16,7 @@ DIST_SUBDIR= xfce4
MAINTAINER= ports@FreeBSD.org
COMMENT= XFce4 power manager
-LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify
GNU_CONFIGURE= yes
USE_BZIP2= yes
diff --git a/sysutils/xfce4-power-manager/files/patch-src__xfpm-notify.c b/sysutils/xfce4-power-manager/files/patch-src__xfpm-notify.c
new file mode 100644
index 000000000000..07191d7eff4a
--- /dev/null
+++ b/sysutils/xfce4-power-manager/files/patch-src__xfpm-notify.c
@@ -0,0 +1,12 @@
+--- src/xfpm-notify.c.orig 2011-02-15 21:52:35.000000000 +0100
++++ src/xfpm-notify.c 2011-08-14 10:44:28.000000000 +0200
+@@ -233,9 +233,6 @@ xfpm_notify_new_notification_internal (c
+ #if !NOTIFY_CHECK_VERSION (0, 7, 0)
+ if ( icon )
+ notify_notification_attach_to_status_icon (n, icon);
+-#else
+- if ( icon )
+- notify_notification_attach_to_status_icon (n, icon);
+ #endif
+ #endif
+
diff --git a/sysutils/xfce4-settings/Makefile b/sysutils/xfce4-settings/Makefile
index 9399a392728a..5e0a0bbb1808 100644
--- a/sysutils/xfce4-settings/Makefile
+++ b/sysutils/xfce4-settings/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xfce4-settings
PORTVERSION= 4.8.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/xfce/${PORTNAME}/${PORTVERSION:R}
@@ -63,7 +63,7 @@ PLIST_SUB+= XRANDR="@comment "
.endif
.if defined(WITH_NOTIFY)
-LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+=--enable-libnotify
.else
CONFIGURE_ARGS+=--disable-libnotify