aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2015-05-13 22:28:42 +0800
committerfeld <feld@FreeBSD.org>2015-05-13 22:28:42 +0800
commit5e7b8ccca5944c6adf9d6c83fe1436ab06171649 (patch)
tree45ab114a2c711734c971cdc8b464d3c16dff3063 /sysutils
parentea3cf7f5ba162f5de53613b566fec2c637a77d10 (diff)
downloadfreebsd-ports-gnome-5e7b8ccca5944c6adf9d6c83fe1436ab06171649.tar.gz
freebsd-ports-gnome-5e7b8ccca5944c6adf9d6c83fe1436ab06171649.tar.zst
freebsd-ports-gnome-5e7b8ccca5944c6adf9d6c83fe1436ab06171649.zip
Welcome acts to the ports tree
acts is a utility for managing Tarsnap backups which is written in plain sh(1). This utility was praised in mwl's Tarsnap Mastery book, but was somehow missing from our dear ports tree. Now it's here so I can better manage my backups, and you should too!
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/acts/Makefile20
-rw-r--r--sysutils/acts/distinfo2
-rw-r--r--sysutils/acts/pkg-descr11
-rw-r--r--sysutils/acts/pkg-plist2
5 files changed, 36 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index a58a4e61c417..f93e97b4e71c 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -15,6 +15,7 @@
SUBDIR += accountsservice
SUBDIR += acpi_call
SUBDIR += acpica-tools
+ SUBDIR += acts
SUBDIR += adtool
SUBDIR += afbinit
SUBDIR += afflib
diff --git a/sysutils/acts/Makefile b/sysutils/acts/Makefile
new file mode 100644
index 000000000000..eded3293dc88
--- /dev/null
+++ b/sysutils/acts/Makefile
@@ -0,0 +1,20 @@
+# Created by: Mark Felder <feld@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= acts
+PORTVERSION= 1.0
+CATEGORIES= sysutils archivers
+
+MAINTAINER= feld@FreeBSD.org
+COMMENT= Another Calendar-based Tarsnap Script
+
+USE_GITHUB= yes
+GH_ACCOUNT= alexjurkiewicz
+
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/acts ${STAGEDIR}/${PREFIX}/bin/acts
+ ${INSTALL_DATA} ${WRKSRC}/acts.conf ${STAGEDIR}/${PREFIX}/etc/acts.conf.sample
+
+.include <bsd.port.mk>
diff --git a/sysutils/acts/distinfo b/sysutils/acts/distinfo
new file mode 100644
index 000000000000..2bf7848734fd
--- /dev/null
+++ b/sysutils/acts/distinfo
@@ -0,0 +1,2 @@
+SHA256 (alexjurkiewicz-acts-1.0_GH0.tar.gz) = 60541d245d9e1c11c2bd34784f45f7e89010d453c4132e6af62f83f1c115f59d
+SIZE (alexjurkiewicz-acts-1.0_GH0.tar.gz) = 3330
diff --git a/sysutils/acts/pkg-descr b/sysutils/acts/pkg-descr
new file mode 100644
index 000000000000..b969560dc6ed
--- /dev/null
+++ b/sysutils/acts/pkg-descr
@@ -0,0 +1,11 @@
+acts is a minimal shell script that creates backups with Tarsnap.
+Some design goals:
+
+ Just backup, no restore.
+ Calendar-based (daily, monthly, yearly) backup schedule
+ Portable, small code footprint.
+
+One Tarsnap archive is created per-target per-run. 31 daily, 12 monthly,
+and indefinite yearly backups are kept.
+
+WWW: https://github.com/alexjurkiewicz/acts
diff --git a/sysutils/acts/pkg-plist b/sysutils/acts/pkg-plist
new file mode 100644
index 000000000000..cbb28306dfef
--- /dev/null
+++ b/sysutils/acts/pkg-plist
@@ -0,0 +1,2 @@
+bin/acts
+@sample etc/acts.conf.sample