aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2001-03-21 15:26:21 +0800
committerdinoex <dinoex@FreeBSD.org>2001-03-21 15:26:21 +0800
commitde7df125c95184a7e452e4f81d725ef0ea1dfa6d (patch)
treee198f43f94a7f0e18e15f0385b13ed5a62dd6123 /sysutils
parent30f2204630ca2c54b9805b4b7a8fcb082a91b9ad (diff)
downloadfreebsd-ports-gnome-de7df125c95184a7e452e4f81d725ef0ea1dfa6d.tar.gz
freebsd-ports-gnome-de7df125c95184a7e452e4f81d725ef0ea1dfa6d.tar.zst
freebsd-ports-gnome-de7df125c95184a7e452e4f81d725ef0ea1dfa6d.zip
The samefile program finds files with identical contents (independent of
file name). Typical usage would be find / -print | samefile turning up megabytes of wasted disk space due to duplicates. Try it, you'll be baffled. Jens Schweikhardt samefile@schweikhardt.net PR: 25857 Submitted by: schweikh@schweikhardt.net
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/samefile/Makefile29
-rw-r--r--sysutils/samefile/distinfo1
-rw-r--r--sysutils/samefile/pkg-comment1
-rw-r--r--sysutils/samefile/pkg-descr10
-rw-r--r--sysutils/samefile/pkg-plist1
6 files changed, 43 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 6b146dc1f301..6668fae6b6f8 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -103,6 +103,7 @@
SUBDIR += roottail
SUBDIR += ruby-syslog
SUBDIR += safecat
+ SUBDIR += samefile
SUBDIR += sarah
SUBDIR += sdd
SUBDIR += setcdboot
diff --git a/sysutils/samefile/Makefile b/sysutils/samefile/Makefile
new file mode 100644
index 000000000000..451b681a875e
--- /dev/null
+++ b/sysutils/samefile/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: samefile
+# Date created: 15 March 2001
+# Whom: schweikh
+#
+# $FreeBSD$
+#
+
+PORTNAME= samefile
+PORTVERSION= 2.9
+CATEGORIES= sysutils
+MASTER_SITES= http://www.schweikhardt.net/
+
+MAINTAINER= samefile@schweikhardt.net
+
+MAN1= samefile.1
+GNU_CONFIGURE= yes
+
+CFLAGS+= -ansi -pedantic -Wall -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wconversion -Wsign-compare -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wmissing-noreturn -Wredundant-decls -Wnested-externs -Winline
+
+post-build:
+ @echo " >>>> <<<<"
+ @echo " >>>> Running the test suite <<<<"
+ @echo " >>>> <<<<"
+ cd ${WRKSRC}; ${MAKE} test
+
+post-install:
+ strip ${PREFIX}/bin/samefile
+
+.include <bsd.port.mk>
diff --git a/sysutils/samefile/distinfo b/sysutils/samefile/distinfo
new file mode 100644
index 000000000000..73f40bc12b3f
--- /dev/null
+++ b/sysutils/samefile/distinfo
@@ -0,0 +1 @@
+MD5 (samefile-2.9.tar.gz) = cac055b174882e4ecc4db7b7cee78c94
diff --git a/sysutils/samefile/pkg-comment b/sysutils/samefile/pkg-comment
new file mode 100644
index 000000000000..61c9a0146464
--- /dev/null
+++ b/sysutils/samefile/pkg-comment
@@ -0,0 +1 @@
+Find files with identical contents
diff --git a/sysutils/samefile/pkg-descr b/sysutils/samefile/pkg-descr
new file mode 100644
index 000000000000..ef52f7ffe5ae
--- /dev/null
+++ b/sysutils/samefile/pkg-descr
@@ -0,0 +1,10 @@
+The samefile program finds files with identical contents (independent of
+file name). Typical usage would be
+
+ find / -print | samefile
+
+turning up megabytes of wasted disk space due to duplicates. Try it,
+you'll be baffled.
+
+Jens Schweikhardt
+samefile@schweikhardt.net
diff --git a/sysutils/samefile/pkg-plist b/sysutils/samefile/pkg-plist
new file mode 100644
index 000000000000..0505fb100f93
--- /dev/null
+++ b/sysutils/samefile/pkg-plist
@@ -0,0 +1 @@
+bin/samefile