aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>1998-11-20 05:59:54 +0800
committerandreas <andreas@FreeBSD.org>1998-11-20 05:59:54 +0800
commiteafbcefbc95827a6ad9285bd4e2e4d024b199b16 (patch)
tree0adbe85eb5d3e7a3d78d79c5aa4ff149a9350d23 /sysutils
parent06d878d3dd1581dbc32a22af67247ff995ad7445 (diff)
downloadfreebsd-ports-gnome-eafbcefbc95827a6ad9285bd4e2e4d024b199b16.tar.gz
freebsd-ports-gnome-eafbcefbc95827a6ad9285bd4e2e4d024b199b16.tar.zst
freebsd-ports-gnome-eafbcefbc95827a6ad9285bd4e2e4d024b199b16.zip
Check if webserver is installed
Warn user if no webserver is installed Recommend apache13-php or apache13-modssl. the php version can be configured to use the modssl module as well ...
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/webmin/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
index c428b2d24d38..f89bd4ed20db 100644
--- a/sysutils/webmin/Makefile
+++ b/sysutils/webmin/Makefile
@@ -3,7 +3,7 @@
# Date created: Do 19 Nov 1998 21:13:55 CET
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
-# $Id: Makefile,v 1.1.1.1 1998/11/19 21:38:24 andreas Exp $
+# $Id: Makefile,v 1.2 1998/11/19 21:41:15 andreas Exp $
#
DISTNAME= webmin-0.64
@@ -16,6 +16,16 @@ NO_BUILD= yes
IS_INTERACTIVE= yes
USE_PERL5= yes
+pre-extract:
+ @if [ -x ${PREFIX}/sbin/httpd ]; then \
+ echo Good ! You seem to have apache webserver installed ...; \
+ else \
+ echo You need to install one of the different apache webservers; \
+ echo Best would be apache13-modssl or apache13-php3 that can be; \
+ echo configured to use modssl for better security as well; \
+ exit 1; \
+ fi
+
do-install:
${MKDIR} ${PREFIX}/lib/webmin
${CP} -r ${WRKSRC}/* ${PREFIX}/lib/webmin