aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-04-16 21:44:38 +0800
committermiwi <miwi@FreeBSD.org>2009-04-16 21:44:38 +0800
commitff0bac39d5b16903e236fb9e0b6b2371c0dd4020 (patch)
tree7f715686c798736a78ae6c5528ac0687f63b512a /sysutils
parentf557489da21a704558d0b782b2f0cad1efb70bfa (diff)
downloadfreebsd-ports-gnome-ff0bac39d5b16903e236fb9e0b6b2371c0dd4020.tar.gz
freebsd-ports-gnome-ff0bac39d5b16903e236fb9e0b6b2371c0dd4020.tar.zst
freebsd-ports-gnome-ff0bac39d5b16903e236fb9e0b6b2371c0dd4020.zip
- Fix build with GCC 4.2
- Pass maintainership to submitter PR: 133661 Submitted by: Thomas Sandford <freebsduser@paradisegreen.co.uk> Approved by: portmgr (erwin)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/upsdaemon/Makefile10
-rw-r--r--sysutils/upsdaemon/files/patch-upsdaemon.c26
2 files changed, 28 insertions, 8 deletions
diff --git a/sysutils/upsdaemon/Makefile b/sysutils/upsdaemon/Makefile
index 244370a35652..8a3c623e9315 100644
--- a/sysutils/upsdaemon/Makefile
+++ b/sysutils/upsdaemon/Makefile
@@ -11,7 +11,7 @@ CATEGORIES= sysutils
MASTER_SITES= http://www.ederbs.org/pub/ \
ftp://ederbs.org/pub/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsduser@paradisegreen.co.uk
COMMENT= Simple APC UPS Daemon
MAN8= upsdaemon.8
@@ -22,10 +22,4 @@ USE_RC_SUBR= upsdaemon
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/upsdaemon/files/patch-upsdaemon.c b/sysutils/upsdaemon/files/patch-upsdaemon.c
new file mode 100644
index 000000000000..005167245b0f
--- /dev/null
+++ b/sysutils/upsdaemon/files/patch-upsdaemon.c
@@ -0,0 +1,26 @@
+--- src/upsdaemon.c.orig 2006-06-20 01:50:23.000000000 +0100
++++ src/upsdaemon.c 2009-04-12 15:48:34.000000000 +0100
+@@ -32,6 +32,7 @@
+ #include <errno.h> /* Error number definitions */
+ #include <termios.h> /* POSIX terminal control definitions */
+ #include <syslog.h> /* Definitions for system error logging */
++#include <stdlib.h> /* exit() definition */
+
+ #define PROG " UpsDaemon"
+ #define VERSION " 1.0"
+@@ -50,6 +51,7 @@
+ #define SH_RECOVERY "/usr/local/libexec/upsdaemon/upsdaemon-alerts -recovery"
+
+ int makepid(char *s);
++static void runcommand();
+
+ int main(int argc, char **argv)
+ {
+@@ -71,7 +73,6 @@
+ char *failed = SH_FAILED;
+ char *recovery = SH_RECOVERY;
+
+- static void runcommand();
+
+ if(argc > 2) {
+ errx(1,"Usage: upsdaemon <port serial open>: %s\n", strerror(errno));