aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2012-09-21 07:52:30 +0800
committerflo <flo@FreeBSD.org>2012-09-21 07:52:30 +0800
commit001a6b2c890d70ba7188c1d8b905921fbe828c1d (patch)
treea8a48b549638cc76a24364d47ec1cabf31ba59ff /sysutils
parent01333d4eb1c009c48d1d138e6602933608ffae2d (diff)
downloadfreebsd-ports-gnome-001a6b2c890d70ba7188c1d8b905921fbe828c1d.tar.gz
freebsd-ports-gnome-001a6b2c890d70ba7188c1d8b905921fbe828c1d.tar.zst
freebsd-ports-gnome-001a6b2c890d70ba7188c1d8b905921fbe828c1d.zip
- update sysutils/fusefs-libs to 2.9.1
- add a patch to sysutils/fusefs-kmod to make it compile with new fusefs-libs Tested by: pho, Kevin Oberman <kob6558@gmail.com>, Gustau Perez Querol <gperez@entel.upc.edu>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/fusefs-kmod/Makefile2
-rw-r--r--sysutils/fusefs-kmod/files/patch-fuse_module__fuse_vnops.c13
-rw-r--r--sysutils/fusefs-libs/Makefile8
-rw-r--r--sysutils/fusefs-libs/distinfo4
-rw-r--r--sysutils/fusefs-libs/files/patch-configure17
-rw-r--r--sysutils/fusefs-libs/files/patch-lib_helper.c38
-rw-r--r--sysutils/fusefs-libs/pkg-plist1
7 files changed, 49 insertions, 34 deletions
diff --git a/sysutils/fusefs-kmod/Makefile b/sysutils/fusefs-kmod/Makefile
index 20ac97bdd893..ffb988fc18ca 100644
--- a/sysutils/fusefs-kmod/Makefile
+++ b/sysutils/fusefs-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fusefs
DISTVERSION= 0.3.9-pre1.20080208
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= sysutils kld
MASTER_SITES= http://mercurial.creo.hu/repos/fuse4bsd-hg/index.cgi/archive/
PKGNAMESUFFIX= -kmod
diff --git a/sysutils/fusefs-kmod/files/patch-fuse_module__fuse_vnops.c b/sysutils/fusefs-kmod/files/patch-fuse_module__fuse_vnops.c
index 3f6654095dc7..9db4ced01e82 100644
--- a/sysutils/fusefs-kmod/files/patch-fuse_module__fuse_vnops.c
+++ b/sysutils/fusefs-kmod/files/patch-fuse_module__fuse_vnops.c
@@ -1,5 +1,5 @@
---- fuse_module/fuse_vnops.c.orig 2008-02-05 00:25:57.000000000 -0500
-+++ fuse_module/fuse_vnops.c 2008-10-29 19:21:51.000000000 -0400
+--- ./fuse_module/fuse_vnops.c.orig 2012-09-19 06:04:10.512413490 +0200
++++ ./fuse_module/fuse_vnops.c 2012-09-19 06:20:44.949613892 +0200
@@ -799,8 +799,11 @@
struct vnode *vp = ap->a_vp;
struct vattr *vap = ap->a_vap;
@@ -53,6 +53,15 @@
if (err)
return (err);
facp->facc_flags |= FACCESS_VA_VALID;
+@@ -1544,7 +1561,7 @@
+ struct fuse_vnode_data *fvdat = VTOFUD(vp);
+ uint64_t parentid = fvdat->parent_nid;
+ struct componentname *cnp = fvdat->germcnp;
+- struct fuse_open_in *foi;
++ struct fuse_create_in *foi;
+ struct fuse_entry_out *feo;
+ struct fuse_mknod_in fmni;
+ int err;
@@ -1929,7 +1946,11 @@
* It will not invalidate pages which are dirty, locked, under
* writeback or mapped into pagetables.")
diff --git a/sysutils/fusefs-libs/Makefile b/sysutils/fusefs-libs/Makefile
index 65c2a84e1762..8372224b0332 100644
--- a/sysutils/fusefs-libs/Makefile
+++ b/sysutils/fusefs-libs/Makefile
@@ -5,7 +5,7 @@
#
PORTNAME= fusefs
-PORTVERSION= 2.7.4
+PORTVERSION= 2.9.1
CATEGORIES= sysutils
MASTER_SITES= SF/fuse/fuse-2.X/${PORTVERSION}
PKGNAMESUFFIX= -libs
@@ -20,7 +20,7 @@ CFLAGS+= ${PTHREAD_CFLAGS}
USE_LDCONFIG= yes
USE_PKGCONFIG= yes
USE_ICONV= yes
-CONFIGURE_ARGS= --disable-kernel-module --prefix=${PREFIX} \
+CONFIGURE_ARGS= --prefix=${PREFIX} \
--with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
TXT_DOCS= how-fuse-works \
kernel.txt
@@ -43,4 +43,8 @@ post-install:
.endfor
.endif
+MAN1= fusermount.1 \
+ ulockmgr_server.1
+MAN8= mount.fuse.8
+
.include <bsd.port.mk>
diff --git a/sysutils/fusefs-libs/distinfo b/sysutils/fusefs-libs/distinfo
index a8edce1bfd0a..c7309ee980ba 100644
--- a/sysutils/fusefs-libs/distinfo
+++ b/sysutils/fusefs-libs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fuse-2.7.4.tar.gz) = c8b070ece5d4e09bd06eea6c28818c718f803d93a4b85bacb9982deb8ded49e6
-SIZE (fuse-2.7.4.tar.gz) = 506658
+SHA256 (fuse-2.9.1.tar.gz) = 51803d8224bf6adab052b340614980b28861f317c261eab1f1e9c6cf17b3dd75
+SIZE (fuse-2.9.1.tar.gz) = 559705
diff --git a/sysutils/fusefs-libs/files/patch-configure b/sysutils/fusefs-libs/files/patch-configure
index d35406f06134..a9613124c9a6 100644
--- a/sysutils/fusefs-libs/files/patch-configure
+++ b/sysutils/fusefs-libs/files/patch-configure
@@ -1,10 +1,11 @@
---- configure.orig 2008-06-05 13:58:44.000000000 -0700
-+++ configure 2008-06-05 14:00:32.000000000 -0700
-@@ -12201,6 +12201,7 @@
- _ACEOF
+--- configure.orig 2012-08-08 11:08:24.244322974 +0200
++++ configure 2012-08-08 11:08:42.304569338 +0200
+@@ -13237,7 +13237,7 @@
fi
-+ LIBICONV=$LTLIBICONV
- if test "$am_cv_lib_iconv" = yes; then
- { echo "$as_me:$LINENO: checking how to link with libiconv" >&5
- echo $ECHO_N "checking how to link with libiconv... $ECHO_C" >&6; }
+
+-libfuse_libs=$libfuse_libs $LTLIBICONV
++libfuse_libs="$libfuse_libs $LTLIBICONV"
+ if test "$am_cv_func_iconv" = yes; then
+ ICONV_TRUE=
+ ICONV_FALSE='#'
diff --git a/sysutils/fusefs-libs/files/patch-lib_helper.c b/sysutils/fusefs-libs/files/patch-lib_helper.c
index 89f46a4595aa..c8b88076b132 100644
--- a/sysutils/fusefs-libs/files/patch-lib_helper.c
+++ b/sysutils/fusefs-libs/files/patch-lib_helper.c
@@ -1,6 +1,6 @@
---- lib/helper.c.orig 2007-12-12 09:33:35.000000000 -0500
-+++ lib/helper.c 2008-02-04 00:22:51.000000000 -0500
-@@ -30,7 +30,7 @@
+--- lib/helper.c.orig 2012-04-10 15:28:55.000000000 +0200
++++ lib/helper.c 2012-07-31 00:06:11.384938678 +0200
+@@ -31,7 +31,7 @@
struct helper_opts {
int singlethread;
int foreground;
@@ -9,25 +9,25 @@
char *mountpoint;
};
-@@ -41,8 +41,7 @@
- FUSE_HELPER_OPT("debug", foreground),
- FUSE_HELPER_OPT("-f", foreground),
- FUSE_HELPER_OPT("-s", singlethread),
-- FUSE_HELPER_OPT("fsname=", nodefault_subtype),
-- FUSE_HELPER_OPT("subtype=", nodefault_subtype),
-+ FUSE_HELPER_OPT("fsname=", fsname),
+@@ -42,8 +42,7 @@
+ FUSE_HELPER_OPT("debug", foreground),
+ FUSE_HELPER_OPT("-f", foreground),
+ FUSE_HELPER_OPT("-s", singlethread),
+- FUSE_HELPER_OPT("fsname=", nodefault_subtype),
+- FUSE_HELPER_OPT("subtype=", nodefault_subtype),
++ FUSE_HELPER_OPT("fsname=", fsname),
- FUSE_OPT_KEY("-h", KEY_HELP),
- FUSE_OPT_KEY("--help", KEY_HELP),
-@@ -52,7 +51,6 @@
- FUSE_OPT_KEY("-d", FUSE_OPT_KEY_KEEP),
- FUSE_OPT_KEY("debug", FUSE_OPT_KEY_KEEP),
- FUSE_OPT_KEY("fsname=", FUSE_OPT_KEY_KEEP),
-- FUSE_OPT_KEY("subtype=", FUSE_OPT_KEY_KEEP),
+ FUSE_OPT_KEY("-h", KEY_HELP),
+ FUSE_OPT_KEY("--help", KEY_HELP),
+@@ -53,7 +52,6 @@
+ FUSE_OPT_KEY("-d", FUSE_OPT_KEY_KEEP),
+ FUSE_OPT_KEY("debug", FUSE_OPT_KEY_KEEP),
+ FUSE_OPT_KEY("fsname=", FUSE_OPT_KEY_KEEP),
+- FUSE_OPT_KEY("subtype=", FUSE_OPT_KEY_KEEP),
FUSE_OPT_END
};
-@@ -122,24 +120,24 @@
+@@ -123,24 +121,24 @@
}
}
@@ -59,7 +59,7 @@
return res;
}
-@@ -155,8 +153,8 @@
+@@ -156,8 +154,8 @@
if (res == -1)
return -1;
diff --git a/sysutils/fusefs-libs/pkg-plist b/sysutils/fusefs-libs/pkg-plist
index 05a8cb8e23a1..1d260633c887 100644
--- a/sysutils/fusefs-libs/pkg-plist
+++ b/sysutils/fusefs-libs/pkg-plist
@@ -1,3 +1,4 @@
+include/fuse/cuse_lowlevel.h
include/fuse/fuse.h
include/fuse/fuse_compat.h
include/fuse/fuse_common.h