aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-07-06 00:53:05 +0800
committertijl <tijl@FreeBSD.org>2014-07-06 00:53:05 +0800
commit00b2cb27b072b6f9d976eac8ec76fd6531f2d25c (patch)
tree75a61fbd1df3ecd54e752af85741aa520e0ae903 /sysutils
parentff490bf8cc6e286756b5204c0656c6d16547009c (diff)
downloadfreebsd-ports-gnome-00b2cb27b072b6f9d976eac8ec76fd6531f2d25c.tar.gz
freebsd-ports-gnome-00b2cb27b072b6f9d976eac8ec76fd6531f2d25c.tar.zst
freebsd-ports-gnome-00b2cb27b072b6f9d976eac8ec76fd6531f2d25c.zip
- Convert to USES=libtool
- Add kde_cv_prog_cxx_fno_check_new=no to CONFIGURE_ARGS because -fno-check-new is not supported by Clang and that causes the -fPIC configure test to fail.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/lineak-defaultplugin/Makefile17
-rw-r--r--sysutils/lineak-xosdplugin/Makefile12
-rw-r--r--sysutils/lineakd/Makefile11
-rw-r--r--sysutils/lineakd/pkg-plist4
4 files changed, 18 insertions, 26 deletions
diff --git a/sysutils/lineak-defaultplugin/Makefile b/sysutils/lineak-defaultplugin/Makefile
index 6010440deef8..8680489ec379 100644
--- a/sysutils/lineak-defaultplugin/Makefile
+++ b/sysutils/lineak-defaultplugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lineak-defaultplugin
PORTVERSION= 0.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils deskutils
MASTER_SITES= SF/lineak/lineak_defaultplugin/${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= lineak
@@ -13,21 +13,16 @@ COMMENT= Default plugins for lineakd
LICENSE= GPLv2
-LIB_DEPENDS= lineak:${PORTSDIR}/sysutils/lineakd
+LIB_DEPENDS= liblineak.so:${PORTSDIR}/sysutils/lineakd
-USE_AUTOTOOLS= libtool
-GNU_CONFIGURE= yes
+USES= gmake libtool
USE_XORG= x11 xext xt xtst xfixes
-USES= gmake
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= kde_cv_prog_cxx_fno_check_new=no
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+= --program-prefix=''
-PLIST_FILES= lib/lineakd/plugins/defaultplugin.a \
- lib/lineakd/plugins/defaultplugin.la \
- lib/lineakd/plugins/defaultplugin.so \
- lib/lineakd/plugins/mediadetectplugin.a \
- lib/lineakd/plugins/mediadetectplugin.la \
+PLIST_FILES= lib/lineakd/plugins/defaultplugin.so \
lib/lineakd/plugins/mediadetectplugin.so \
man/man1/lineak_defaultplugin.1.gz \
etc/media-detect.conf
diff --git a/sysutils/lineak-xosdplugin/Makefile b/sysutils/lineak-xosdplugin/Makefile
index b6dd6cb04c84..8c987d059c84 100644
--- a/sysutils/lineak-xosdplugin/Makefile
+++ b/sysutils/lineak-xosdplugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lineak-xosdplugin
PORTVERSION= 0.9
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= sysutils deskutils
MASTER_SITES= SF/lineak/lineak_xosdplugin/${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= lineak
@@ -16,13 +16,12 @@ LICENSE= GPLv2
LIB_DEPENDS= libxosd.so:${PORTSDIR}/misc/xosd \
liblineak.so:${PORTSDIR}/sysutils/lineakd
-USE_XORG= x11 xext xt
USES= gmake libtool
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= ac_cv_path_xosd_config_script="${TRUE}"
USE_LDCONFIG= yes
-
-CFLAGS+= -fPIC
+USE_XORG= x11 xext xt
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= ac_cv_path_xosd_config_script="${TRUE}" \
+ kde_cv_prog_cxx_fno_check_new=no
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -32,7 +31,6 @@ PLIST_FILES= lib/lineakd/plugins/xosdplugin.so \
post-patch:
@${REINPLACE_CMD} -e \
's|"-O2 $$CXXFLAGS"|"$$CXXFLAGS"| ; \
- s|echo aout|echo elf| ; \
/LDFLAGS/s|-ldl||' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/sysutils/lineakd/Makefile b/sysutils/lineakd/Makefile
index d20ee886c75b..037db7bd2011 100644
--- a/sysutils/lineakd/Makefile
+++ b/sysutils/lineakd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lineakd
PORTVERSION= 0.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= SF/lineak/${PORTNAME}/${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= lineak
@@ -11,14 +11,13 @@ DIST_SUBDIR= lineak
MAINTAINER= ports@FreeBSD.org
COMMENT= Lineakd is a daemon which enables special keys on internet keyboards
-USES= gmake
+USES= gmake libtool
+USE_LDCONFIG= yes
USE_XORG= x11 xext xt
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= kde_cv_prog_cxx_fno_check_new=no
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_LDCONFIG= yes
-
-CONFIGURE_ARGS+=--program-prefix=''
DOCS= README TODO AUTHORS
diff --git a/sysutils/lineakd/pkg-plist b/sysutils/lineakd/pkg-plist
index 529cf3ca2e63..4d1209af12ab 100644
--- a/sysutils/lineakd/pkg-plist
+++ b/sysutils/lineakd/pkg-plist
@@ -25,9 +25,9 @@ include/lineak/pluginmanager.h
include/lineak/saver.h
include/lineak/xmgr.h
lib/liblineak.a
-lib/liblineak.la
lib/liblineak.so
-lib/liblineak.so.8
+lib/liblineak.so.0
+lib/liblineak.so.0.8.0
man/man1/lineakd.1.gz
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/README