aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-16 20:06:25 +0800
committermiwi <miwi@FreeBSD.org>2006-12-16 20:06:25 +0800
commit0b0a622023b4c067e4d97d05000f22bc748ab4b4 (patch)
treed10e74b39cec2bf5e750e5cf735bf615df163e9e /sysutils
parent397cbda38c5a649196a513e9e9e26fc2a3a4a63a (diff)
downloadfreebsd-ports-gnome-0b0a622023b4c067e4d97d05000f22bc748ab4b4.tar.gz
freebsd-ports-gnome-0b0a622023b4c067e4d97d05000f22bc748ab4b4.tar.zst
freebsd-ports-gnome-0b0a622023b4c067e4d97d05000f22bc748ab4b4.zip
- Fix build with gcc 4
- Make portlint happy about INSTALLS_SHLIBS - Fix portdocs dir in pkg-plist - Add a backup master_site PR: ports/106784 Submitted by: Nicolas Jombart <ecu@ipv42.net> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/ccze/Makefile7
-rw-r--r--sysutils/ccze/files/patch-Makefile.in11
-rw-r--r--sysutils/ccze/pkg-plist2
3 files changed, 16 insertions, 4 deletions
diff --git a/sysutils/ccze/Makefile b/sysutils/ccze/Makefile
index 360fef16b810..23474b423f6d 100644
--- a/sysutils/ccze/Makefile
+++ b/sysutils/ccze/Makefile
@@ -3,13 +3,14 @@
# Whom: Nicolas Jombart <ecu@ipv42.net>
#
# $FreeBSD$
-#
+# ex:ts=8
PORTNAME= ccze
PORTVERSION= 0.2.1
PORTREVISION= 2
CATEGORIES= sysutils
-MASTER_SITES= ftp://bonehunter.rulez.org/pub/ccze/stable/
+MASTER_SITES= ftp://bonehunter.rulez.org/pub/ccze/stable/ \
+ http://ipv42.net/distfiles/ccze/
MAINTAINER= ecu@ipv42.net
COMMENT= Fast log colorizer
@@ -18,7 +19,7 @@ LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
GNU_CONFIGURE= yes
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN1= ccze.1 ccze-cssdump.1
MAN7= ccze-plugin.7
diff --git a/sysutils/ccze/files/patch-Makefile.in b/sysutils/ccze/files/patch-Makefile.in
new file mode 100644
index 000000000000..fc39505382fe
--- /dev/null
+++ b/sysutils/ccze/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Fri Dec 15 11:06:49 2006
++++ src/Makefile.in Fri Dec 15 11:07:04 2006
+@@ -22,7 +22,7 @@
+ -Wbad-function-cast -Wsign-compare -Wchar-subscripts \
+ -Wcomment -Wformat -Wformat-nonliteral -Wformat-security \
+ -Wimplicit -Wmain -Wmissing-braces -Wparentheses \
+- -Wreturn-type -Wswitch -Wmulticharacter \
++ -Wreturn-type -Wswitch \
+ -Wmissing-noreturn -Wmissing-declarations @WFLAGS_3X@
+ WFLAGS_ICC = -Wall -wd193,279,810,869,1418,1419
+ WFLAGS_3X = -Wsequence-point -Wdiv-by-zero -W -Wunused \
diff --git a/sysutils/ccze/pkg-plist b/sysutils/ccze/pkg-plist
index 5f51e7205f6c..aa678474ea12 100644
--- a/sysutils/ccze/pkg-plist
+++ b/sysutils/ccze/pkg-plist
@@ -23,4 +23,4 @@ lib/ccze/vsftpd.so
lib/ccze/xferlog.so
@dirrmtry lib/ccze
%%PORTDOCS%%%%DOCSDIR%%/FAQ
-%%PORTDOCS%%@dirrm share/doc/ccze
+%%PORTDOCS%%@dirrm %%DOCSDIR%%