aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormjacob <mjacob@FreeBSD.org>2001-11-16 10:46:18 +0800
committermjacob <mjacob@FreeBSD.org>2001-11-16 10:46:18 +0800
commit14f6ca7fcff6f3d96fceab101c8756759cbcc687 (patch)
tree586d7993cc3b57d053ae46c59566b7570c5382ac /sysutils
parent015a6c288215865dfbb8905eb658a21046c12954 (diff)
downloadfreebsd-ports-gnome-14f6ca7fcff6f3d96fceab101c8756759cbcc687.tar.gz
freebsd-ports-gnome-14f6ca7fcff6f3d96fceab101c8756759cbcc687.tar.zst
freebsd-ports-gnome-14f6ca7fcff6f3d96fceab101c8756759cbcc687.zip
Add NetWorker client based on 6.0.2 NetWorker release. Corrects some problems
and bugs seen in other port. Because we don't really test as much as we would like, this gets entered as a new port so the old software is still easily available.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/nwclient602/Makefile50
-rw-r--r--sysutils/nwclient602/distinfo2
-rw-r--r--sysutils/nwclient602/pkg-comment1
-rw-r--r--sysutils/nwclient602/pkg-descr8
-rw-r--r--sysutils/nwclient602/pkg-message32
-rw-r--r--sysutils/nwclient602/pkg-plist185
6 files changed, 278 insertions, 0 deletions
diff --git a/sysutils/nwclient602/Makefile b/sysutils/nwclient602/Makefile
new file mode 100644
index 000000000000..e7b61f250d0e
--- /dev/null
+++ b/sysutils/nwclient602/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: networker-client602
+# Date created: Sat Oct 27 09:48:19 PDT 2001
+# Whom: Matthew Jacob <mjacob@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nwclient
+PORTVERSION= 6.0.2
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.feral.com/pub/networker/freebsd/freebsd_40/
+ARCH!= uname -m
+DISTNAME= nwclient-${PORTVERSION}-freebsd-${ARCH}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= networker-bugs@freebsd.org
+
+NO_BUILD= yes
+
+post-patch:
+ @sed -e "s,^ROOTDIR.*$$,ROOTDIR=${PREFIX}," ${WRKSRC}/networker.sh >\
+ ${WRKDIR}/NWCTMP && chmod +w ${WRKSRC}/networker.sh && \
+ cp ${WRKDIR}/NWCTMP ${WRKSRC}/networker.sh && \
+ chmod -w ${WRKSRC}/networker.sh
+
+do-install:
+ @mkdir -p /usr/local/nsr/bin /usr/local/man/man8 /usr/local/etc/rc.d
+ @cd ${WRKSRC} && tar cf - gls | \
+ (cd /usr/local/nsr && tar --unlink -xpf -)
+ @cd ${WRKSRC}/${ARCH} && tar cf - . | \
+ (cd /usr/local/nsr/bin && tar --unlink -xpf -)
+ @cd ${WRKSRC} && tar cf - networker.sh | \
+ (cd /usr/local/etc/rc.d && tar --unlink -xpf -)
+ @cd ${WRKSRC}/catman && tar cf - *.1 | \
+ (cd /usr/local/man/cat1 && tar --unlink -xpf -)
+ @cd ${WRKSRC}/catman && tar cf - *.3 | \
+ (cd /usr/local/man/cat3 && tar --unlink -xpf -)
+ @cd ${WRKSRC}/catman && tar cf - *.5 | \
+ (cd /usr/local/man/cat5 && tar --unlink -xpf -)
+ @cd ${WRKSRC}/catman && tar cf - *.8 | \
+ (cd /usr/local/man/cat8 && tar --unlink -xpf -)
+
+post-install:
+ @sed -e "s,ROOTDIR,${PREFIX}," < ${PKGMESSAGE}
+ @cd / && rm -f nsr && ln -s ${PREFIX}/nsr
+
+pre-deinstall:
+ rm -f /nsr
+
+.include <bsd.port.mk>
diff --git a/sysutils/nwclient602/distinfo b/sysutils/nwclient602/distinfo
new file mode 100644
index 000000000000..e067aaa3135c
--- /dev/null
+++ b/sysutils/nwclient602/distinfo
@@ -0,0 +1,2 @@
+MD5 (nwclient-6.0.2-freebsd-alpha.tgz) = cd07a07ed4cdcceb3ec6e586e1bbfcf9
+MD5 (nwclient-6.0.2-freebsd-i386.tgz) = 77e3df581315f88a5a4c0ef35e0696cd
diff --git a/sysutils/nwclient602/pkg-comment b/sysutils/nwclient602/pkg-comment
new file mode 100644
index 000000000000..2ea725a0a1b3
--- /dev/null
+++ b/sysutils/nwclient602/pkg-comment
@@ -0,0 +1 @@
+network backup client to NetWorker servers
diff --git a/sysutils/nwclient602/pkg-descr b/sysutils/nwclient602/pkg-descr
new file mode 100644
index 000000000000..fbbff4771e93
--- /dev/null
+++ b/sysutils/nwclient602/pkg-descr
@@ -0,0 +1,8 @@
+WWW: http://www.feral.com/NetWorker/networker.html
+
+This is the NetWorker client for FreeBSD. It is based on NetWorker 6.0.2.
+
+BUGS for the FreeBSD client may be entered at
+http://www.feral.com/bugzilla. Do not contact
+Legato for support- it is not supported by them
+at all.
diff --git a/sysutils/nwclient602/pkg-message b/sysutils/nwclient602/pkg-message
new file mode 100644
index 000000000000..0df3272fbfce
--- /dev/null
+++ b/sysutils/nwclient602/pkg-message
@@ -0,0 +1,32 @@
+--------------------- Networker Configuration Information --------------------
+
+The networker clients need to have a Networker server somewhere on
+the network that will agree to take these clients on. Please consult
+Networker documentation from Legato about this.
+
+As of NetWorker Release 5.5, the more stringent client licencing
+is now being enforced. This means that Linux and *BSD clients that
+have identified themselves to the server as being such are now part
+of the 'Unix Workstation' group of clients. Legato requires some
+additional licences installed on the server in addition to normal
+client resource limits. You have to purchase this from Legato if
+you haven't already.
+
+This version of the client places all binaries in the director
+
+ ROOTDIR/nsr/bin
+
+Adjust your PATH environment variable to reflect this.
+
+Also- very important- please remember to edit the file
+
+ ROOTDIR/etc/rc.d/networker.sh
+
+to restrict the access rights to servers you want to have access
+to this machine.
+
+This release is known to work under FreeBSD 4.4. It should work
+under FreeBSD-4.3. It should also work under under FreeBSD-5.0,
+but please be sure to install the 4.X compat libraries.
+
+-------------------------------------------------------------------------------
diff --git a/sysutils/nwclient602/pkg-plist b/sysutils/nwclient602/pkg-plist
new file mode 100644
index 000000000000..f0de9a5b0307
--- /dev/null
+++ b/sysutils/nwclient602/pkg-plist
@@ -0,0 +1,185 @@
+etc/rc.d/networker.sh
+nsr/bin/backint
+nsr/bin/lsm_backint
+nsr/bin/mminfo
+nsr/bin/mmlocate
+nsr/bin/mmpool
+nsr/bin/mmrecov
+nsr/bin/nsradmin
+nsr/bin/nsralist
+nsr/bin/nsrarchive
+nsr/bin/nsrclone
+nsr/bin/nsrexec
+nsr/bin/nsrexecd
+nsr/bin/nsrfile
+nsr/bin/nsrifmx
+nsr/bin/nsrmm
+nsr/bin/nsrmon
+nsr/bin/nsrports
+nsr/bin/nsrretrieve
+nsr/bin/nsrssc
+nsr/bin/nsrstage
+nsr/bin/nsrwatch
+nsr/bin/preclntsave
+nsr/bin/pstclntsave
+nsr/bin/recover
+nsr/bin/sapclone
+nsr/bin/save
+nsr/bin/savefs
+nsr/bin/savegrp
+nsr/bin/savepnpc
+nsr/bin/uasm
+nsr/gls/cm/registry
+nsr/gls/lc/os/portable/C
+man/cat8/ansrd.8
+man/cat8/changers.8
+man/cat8/dasadmin.8
+man/cat8/EMASS_silo.8
+man/cat8/emcdiscover.8
+man/cat8/erase.8
+man/cat8/hpflip.8
+man/cat8/IBM_silo.8
+man/cat8/ielem.8
+man/cat8/inquire.8
+man/cat8/jbconfig.8
+man/cat8/jbexercise.8
+man/cat8/jbinfo.8
+man/cat8/ldunld.8
+man/cat8/lgtolic.8
+man/cat8/lgtolmd.8
+man/cat8/libscsi.8
+man/cat8/libsji.8
+man/cat8/libstlemass.8
+man/cat8/libstlibm.8
+man/cat8/libstlstk.8
+man/cat8/lrescan.8
+man/cat8/lreset.8
+man/cat8/lusbinfo.8
+man/cat8/lusdebug.8
+man/cat8/lusmode.8
+man/cat8/mini_el.8
+man/cat8/mminfo.8
+man/cat8/mmlocate.8
+man/cat8/mmpool.8
+man/cat8/mmrecov.8
+man/cat8/msense.8
+man/cat8/networker.8
+man/cat8/nmi_config.8
+man/cat8/nsr.8
+man/cat8/nsr_crash.8
+man/cat8/nsr_ize.8
+man/cat8/nsr_shutdown.8
+man/cat8/nsradmin.8
+man/cat8/nsralist.8
+man/cat8/nsrarchive.8
+man/cat8/nsrcap.8
+man/cat8/nsrcat.8
+man/cat8/nsrck.8
+man/cat8/nsrclone.8
+man/cat8/nsrd.8
+man/cat8/nsrdb2.8
+man/cat8/nsrdbmi.8
+man/cat8/nsrdocrc.8
+man/cat8/nsrexec.8
+man/cat8/nsrexecd.8
+man/cat8/nsrhsmck.8
+man/cat8/nsrhsmls.8
+man/cat8/nsrib.8
+man/cat8/nsriba.8
+man/cat8/nsrim.8
+man/cat8/nsrindexasm.8
+man/cat8/nsrindexd.8
+man/cat8/nsrinfo.8
+man/cat8/nsrjb.8
+man/cat8/nsrlic.8
+man/cat8/nsrls.8
+man/cat8/nsrmig.8
+man/cat8/nsrmm.8
+man/cat8/nsrmmd.8
+man/cat8/nsrmmdbasm.8
+man/cat8/nsrmmdbd.8
+man/cat8/nsrmon.8
+man/cat8/nsrndmp_recover.8
+man/cat8/nsrndmp_save.8
+man/cat8/nsrnmo.8
+man/cat8/nsrnotesrc.8
+man/cat8/nsrnotesv.8
+man/cat8/nsrpmig.8
+man/cat8/nsrports.8
+man/cat8/nsrretrieve.8
+man/cat8/nsrssc.8
+man/cat8/nsrstage.8
+man/cat8/nsrsyb.8
+man/cat8/nsrsybcc.8
+man/cat8/nsrsybrc.8
+man/cat8/nsrsybsv.8
+man/cat8/nsrtrap.8
+man/cat8/nsrwatch.8
+man/cat8/nwadmin.8
+man/cat8/nwarchive.8
+man/cat8/nwbackup.8
+man/cat8/nwrecover.8
+man/cat8/nwretrieve.8
+man/cat8/oraemcasm.8
+man/cat8/oraemcmap.8
+man/cat8/pmode.8
+man/cat8/preclntsave.8
+man/cat8/pstclntsave.8
+man/cat8/rap.8
+man/cat8/rapcheck.8
+man/cat8/rapd.8
+man/cat8/rapxfer.8
+man/cat8/recover.8
+man/cat8/relem.8
+man/cat8/sapclone.8
+man/cat8/save.8
+man/cat8/savefs.8
+man/cat8/savegrp.8
+man/cat8/savepnpc.8
+man/cat8/scanner.8
+man/cat8/sjidopen.8
+man/cat8/sjiielm.8
+man/cat8/sjiinq.8
+man/cat8/sjirdp.8
+man/cat8/sjirdtag.8
+man/cat8/sjirelem.8
+man/cat8/sjirjc.8
+man/cat8/ssi.8
+man/cat8/stk_eject.8
+man/cat8/STK_silo.8
+man/cat8/stli.8
+man/cat8/tapeexercise.8
+man/cat8/tur.8
+man/cat8/uasm.8
+man/cat8/writebuf.8
+man/cat5/mm_data.5
+man/cat5/nsr.5
+man/cat5/nsr_archive_request.5
+man/cat5/nsr_client.5
+man/cat5/nsr_data.5
+man/cat5/nsr_device.5
+man/cat5/nsr_directive.5
+man/cat5/nsr_group.5
+man/cat5/nsr_jukebox.5
+man/cat5/nsr_label.5
+man/cat5/nsr_layout.5
+man/cat5/nsr_license.5
+man/cat5/nsr_migration.5
+man/cat5/nsr_notification.5
+man/cat5/nsr_policy.5
+man/cat5/nsr_pool.5
+man/cat5/nsr_regexp.5
+man/cat5/nsr_resource.5
+man/cat5/nsr_schedule.5
+man/cat5/nsr_service.5
+man/cat5/nsr_stage.5
+man/cat5/nsr_storage_node.5
+man/cat5/resource.5
+man/cat1/rapgen.1
+man/cat3/nsr_getdate.3
+@dirrm nsr/bin
+@dirrm nsr/gls/cm
+@dirrm nsr/gls/lc/os/portable
+@dirrm nsr/gls/lc/os
+@dirrm nsr/gls/lc
+@dirrm nsr/gls