aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-05-27 00:14:45 +0800
committerbsam <bsam@FreeBSD.org>2013-05-27 00:14:45 +0800
commit2027e7b983cc2544cfe971e540d7292b196e5e98 (patch)
treeb3e4834742b64de0013be401e990fcf9cd30dffd /sysutils
parenteca949d199b38dde12992676a4ebd4e43134fc0d (diff)
downloadfreebsd-ports-gnome-2027e7b983cc2544cfe971e540d7292b196e5e98.tar.gz
freebsd-ports-gnome-2027e7b983cc2544cfe971e540d7292b196e5e98.tar.zst
freebsd-ports-gnome-2027e7b983cc2544cfe971e540d7292b196e5e98.zip
Use CFLAGS and LDFLAGS at the port's Makefile instead of
patching the makefile at sources.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/mapchan/Makefile2
-rw-r--r--sysutils/mapchan/files/patch-Makefile10
2 files changed, 6 insertions, 6 deletions
diff --git a/sysutils/mapchan/Makefile b/sysutils/mapchan/Makefile
index b43586bb5188..e389b0e4278b 100644
--- a/sysutils/mapchan/Makefile
+++ b/sysutils/mapchan/Makefile
@@ -13,6 +13,8 @@ COMMENT= Transform the input and output of a terminal (SCO Unix alike)
USES= iconv
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_ENV= MAPDIR=${PREFIX}/etc/${PORTNAME}
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -liconv
ETCDAT= *.map default.sample
MAN8= mapchan.8
PORTDOCS= README
diff --git a/sysutils/mapchan/files/patch-Makefile b/sysutils/mapchan/files/patch-Makefile
index c14b3d24ca3f..e7380b671c4f 100644
--- a/sysutils/mapchan/files/patch-Makefile
+++ b/sysutils/mapchan/files/patch-Makefile
@@ -1,5 +1,5 @@
--- Makefile.orig 2008-09-11 20:28:12.000000000 +0500
-+++ Makefile 2013-05-26 13:56:49.000000000 +0400
++++ Makefile 2013-05-26 20:10:47.000000000 +0400
@@ -1,6 +1,6 @@
#
#
@@ -8,18 +8,16 @@
#CFLAGS ?= -g
#
# Defines:
-@@ -29,10 +29,10 @@ DEFS+=-DMAP_ONOFF
+@@ -29,9 +29,9 @@
DEFS+=-DESC_C_TBL
DESTDIR ?= /
-BINDIR ?= $(DESTDIR)/bin
-MAPDIR ?= $(DESTDIR)/etc/mapchan
-LDFLAGS ?= -s
--LOADLIBES = -lutil
+BINDIR?=$(PREFIX)/bin
+MAPDIR?=$(PREFIX)/mapchan
-+LDFLAGS=-s -lutil -liconv -I /usr/local/include -L /usr/local/lib
-+LOADLIBES = -lutil -liconv
++LDFLAGS+=-s -lutil
+ LOADLIBES = -lutil
#--------------------------------------------------------------
CFLAGS += $(DEFS)
-