aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2009-03-24 23:08:17 +0800
committerarved <arved@FreeBSD.org>2009-03-24 23:08:17 +0800
commit31c4b5e104c72e8cbdec8ec712648c0a8800ce52 (patch)
tree84ed9950639bb2dff29ceb106c2e8fd686dd3f57 /sysutils
parent6729dd4256cd6ff5d7b20adba2b4be67155fe0c7 (diff)
downloadfreebsd-ports-gnome-31c4b5e104c72e8cbdec8ec712648c0a8800ce52.tar.gz
freebsd-ports-gnome-31c4b5e104c72e8cbdec8ec712648c0a8800ce52.tar.zst
freebsd-ports-gnome-31c4b5e104c72e8cbdec8ec712648c0a8800ce52.zip
fix make -j
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/asmon/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/sysutils/asmon/Makefile b/sysutils/asmon/Makefile
index 188e277a8bf2..9c25df414d66 100644
--- a/sysutils/asmon/Makefile
+++ b/sysutils/asmon/Makefile
@@ -20,7 +20,7 @@ USE_XORG= xpm x11
BUILD_WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/asmon
CFLAGS+= -I${LOCALBASE}/include
USE_GMAKE= yes
-ALL_TARGET= clean asmon
+ALL_TARGET= asmon
MAKE_ARGS+= LIBDIR="-L${LOCALBASE}/lib" \
SOLARIS_LIBS=-lkvm
@@ -28,6 +28,7 @@ PLIST_FILES= bin/asmon
post-patch:
${REINPLACE_CMD} -e 's:gcc:${CC} ${CFLAGS}:' ${BUILD_WRKSRC}/Makefile
+ ${RM} ${WRKSRC}/wmgeneral/*.o $(BUILD_WRKSRC}/asmon
do-install:
${INSTALL} ${COPY} ${STRIP} -o ${BINOWN} -g kmem -m 2755 ${WRKSRC}/asmon/asmon ${PREFIX}/bin