aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2012-02-18 05:31:06 +0800
committermandree <mandree@FreeBSD.org>2012-02-18 05:31:06 +0800
commit335ae942b11cc9fed4345eaecb26e37b351a7172 (patch)
tree8f6c6e08d95c2c61e798bd1274ecf2f90e1f4bdb /sysutils
parent43574ceb018c636bceb2f1edb3eb101b2e1ad159 (diff)
downloadfreebsd-ports-gnome-335ae942b11cc9fed4345eaecb26e37b351a7172.tar.gz
freebsd-ports-gnome-335ae942b11cc9fed4345eaecb26e37b351a7172.tar.zst
freebsd-ports-gnome-335ae942b11cc9fed4345eaecb26e37b351a7172.zip
Fix missing return value in lib/quota/quotaio.c.
Fixes compilation with clang. Submitted by: Zhihao Yuan PR: ports/165218
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/e2fsprogs/Makefile2
-rw-r--r--sysutils/e2fsprogs/files/patch-lib_quota_quotaio.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index f8011578c3c1..d40ca8d39f24 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= e2fsprogs
PORTVERSION= 1.42
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
diff --git a/sysutils/e2fsprogs/files/patch-lib_quota_quotaio.c b/sysutils/e2fsprogs/files/patch-lib_quota_quotaio.c
new file mode 100644
index 000000000000..a8c429a35abb
--- /dev/null
+++ b/sysutils/e2fsprogs/files/patch-lib_quota_quotaio.c
@@ -0,0 +1,11 @@
+--- ./lib/quota/quotaio.c~ 2011-11-27 19:22:10.000000000 -0600
++++ ./lib/quota/quotaio.c 2012-02-16 15:08:31.757648919 -0600
+@@ -143,7 +143,7 @@ errcode_t quota_inode_truncate(ext2_fils
+
+ inode.i_dtime = fs->now ? fs->now : time(0);
+ if (!ext2fs_inode_has_valid_blocks2(fs, &inode))
+- return;
++ return err;
+
+ ext2fs_block_iterate3(fs, ino, BLOCK_FLAG_READ_ONLY, NULL,
+ release_blocks_proc, NULL);--- ./usr/ports/sysutils/e2fsprogs/files/patch-lib_quota_quotaio.c.orig 2012-02-17 22:18:01.000000000 +0100