aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2009-02-24 05:48:35 +0800
committercy <cy@FreeBSD.org>2009-02-24 05:48:35 +0800
commit37088a4eb6bffd9b68862b2a63935d7f5ed93442 (patch)
treeeacb6a5efa06fc952123aa0227a01882669e9e25 /sysutils
parent6f64ab589dc0acc0495a8e6f3d97774dac8b57b1 (diff)
downloadfreebsd-ports-gnome-37088a4eb6bffd9b68862b2a63935d7f5ed93442.tar.gz
freebsd-ports-gnome-37088a4eb6bffd9b68862b2a63935d7f5ed93442.tar.zst
freebsd-ports-gnome-37088a4eb6bffd9b68862b2a63935d7f5ed93442.zip
Set termios' VERASE to DEL, for vte's autodetect feature.
PR: 131858 Submitted by: Szalai Andras <szalai.bandi@gmail.com> Obtained from: screen.git commit 01fbf99748f536519605087d5937761790fc6ded by Micah Cowan <micah@cowan.name> see: http://git.savannah.gnu.org/cgit/screen.git/commit/?id=01fbf99748f536519605087d5937761790fc6ded
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/screen/Makefile2
-rw-r--r--sysutils/screen/files/patch-tty.sh23
2 files changed, 24 insertions, 1 deletions
diff --git a/sysutils/screen/Makefile b/sysutils/screen/Makefile
index d79a5f3608e8..fa57d1c475ae 100644
--- a/sysutils/screen/Makefile
+++ b/sysutils/screen/Makefile
@@ -7,7 +7,7 @@
PORTNAME= screen
PORTVERSION= 4.0.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.uni-erlangen.de/pub/utilities/screen/ \
http://komquats.com/distfiles/ \
diff --git a/sysutils/screen/files/patch-tty.sh b/sysutils/screen/files/patch-tty.sh
new file mode 100644
index 000000000000..766a75c87ca3
--- /dev/null
+++ b/sysutils/screen/files/patch-tty.sh
@@ -0,0 +1,23 @@
+From 01fbf99748f536519605087d5937761790fc6ded Mon Sep 17 00:00:00 2001
+From: Micah Cowan <micah@cowan.name>
+Date: Thu, 07 Aug 2008 08:27:12 +0000
+Subject: Set termios' VERASE to DEL, for vte's autodetect feature.
+
+---
+diff --git a/src/tty.sh b/src/tty.sh
+index b16ff03..374bb97 100644
+--- tty.sh
++++ tty.sh
+@@ -562,7 +562,9 @@ XIF{VDISCARD} np->tio.c_cc[VDISCARD] = VDISABLE;
+ XIF{VLNEXT} np->tio.c_cc[VLNEXT] = VDISABLE;
+ XIF{VSTATUS} np->tio.c_cc[VSTATUS] = VDISABLE;
+ XIF{VSUSP} np->tio.c_cc[VSUSP] = VDISABLE;
+-XIF{VERASE} np->tio.c_cc[VERASE] = VDISABLE;
++ /* Set VERASE to DEL, rather than VDISABLE, to avoid libvte
++ "autodetect" issues. */
++XIF{VERASE} np->tio.c_cc[VERASE] = 0x7f;
+ XIF{VKILL} np->tio.c_cc[VKILL] = VDISABLE;
+ # ifdef HPUX_LTCHARS_HACK
+ np->m_ltchars.t_suspc = VDISABLE;
+--
+cgit v0.8.2