aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2005-12-12 10:25:38 +0800
committerume <ume@FreeBSD.org>2005-12-12 10:25:38 +0800
commit4424198987263c5d9217d06dfec45897964be3c9 (patch)
tree95e85c7605c0c0234ebc3176f0e4e9a831a5f0a8 /sysutils
parent1721d3cc887a16f8e26543488f98df1dbb1e24c9 (diff)
downloadfreebsd-ports-gnome-4424198987263c5d9217d06dfec45897964be3c9.tar.gz
freebsd-ports-gnome-4424198987263c5d9217d06dfec45897964be3c9.tar.zst
freebsd-ports-gnome-4424198987263c5d9217d06dfec45897964be3c9.zip
Fix build on 4.x actually. We need to pass CPPFLAGS and LDFLAGS
to use USE_GETOPT_LONG.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/radeontool/Makefile2
-rw-r--r--sysutils/radeontool/files/patch-Makefile11
2 files changed, 9 insertions, 4 deletions
diff --git a/sysutils/radeontool/Makefile b/sysutils/radeontool/Makefile
index 5a39c1cca930..4c20df0fb043 100644
--- a/sysutils/radeontool/Makefile
+++ b/sysutils/radeontool/Makefile
@@ -15,4 +15,6 @@ COMMENT= ATI Radeon video card contoroling tool useful for laptops
USE_GETOPT_LONG=YES
+MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
.include <bsd.port.mk>
diff --git a/sysutils/radeontool/files/patch-Makefile b/sysutils/radeontool/files/patch-Makefile
index 3dc9adc11da0..b75f158e3e53 100644
--- a/sysutils/radeontool/files/patch-Makefile
+++ b/sysutils/radeontool/files/patch-Makefile
@@ -1,12 +1,15 @@
+Index: Makefile
+diff -u Makefile.orig Makefile
--- Makefile.orig Sun Jun 23 14:28:15 2002
-+++ Makefile Fri Aug 19 00:34:31 2005
-@@ -1,8 +1,9 @@
++++ Makefile Mon Dec 12 11:21:21 2005
+@@ -1,8 +1,10 @@
-
+all:radeontool
radeontool: radeontool.c
- gcc -Wall -O2 radeontool.c -o radeontool
--
+- gcc -Wall -O2 radeontool.c -o radeontool
++ ${CC} -Wall ${CFLAGS} ${CPPFLAGS} radeontool.c -o radeontool ${LDFLAGS}
+
+install:
+ install -C -s radeontool ${PREFIX}/bin/