aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-01-21 07:24:35 +0800
committerpav <pav@FreeBSD.org>2005-01-21 07:24:35 +0800
commit581c1af65670b20e90069990a775551e9f62bca5 (patch)
tree8cae8fda428fa031441d63ce6b7a7ad20e76acb6 /sysutils
parent18006a0b3fd0488ff380e18018d03572e12c27a0 (diff)
downloadfreebsd-ports-gnome-581c1af65670b20e90069990a775551e9f62bca5.tar.gz
freebsd-ports-gnome-581c1af65670b20e90069990a775551e9f62bca5.tar.zst
freebsd-ports-gnome-581c1af65670b20e90069990a775551e9f62bca5.zip
- Fix build when older e2fsprogs is installed
- Drop USE_GCC - Rename DISABLE_NLS to WITHOUT_NLS PR: ports/76488 Submitted by: Matthias Andree <matthias.andree@gmx.de> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/e2fsprogs/Makefile16
-rw-r--r--sysutils/e2fsprogs/files/patch-MCONFIG--I-order34
2 files changed, 40 insertions, 10 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index 26a704b54e3d..4473ef738b0a 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= e2fsprogs
PORTVERSION= 1.35
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= matthias.andree@gmx.de
COMMENT= Utilities and library to manipulate an ext2 or ext3 filesystem
-.if !defined(DISABLE_NLS)
+.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
.endif
@@ -29,7 +29,7 @@ NO_FILTER_SHLIBS= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-elf-shlibs --disable-fsck "--with-ldopts=-L${LOCALBASE}/lib"
CONFIGURE_ENV+= CPPFLAGS='-I${WRKSRC}/lib -I${LOCALBASE}/include'
-.if defined(DISABLE_NLS)
+.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB= NLS="@comment "
.else
@@ -53,10 +53,10 @@ MAN8= badblocks.8 debugfs.8 dumpe2fs.8 e2fsck.8 e2image.8 e2label.8 \
pre-everything::
@${ECHO_CMD} "-------------------------------------------------------------"
-.if defined(DISABLE_NLS)
- @${ECHO_CMD} "National language support disabled, -DDISABLE_NLS in effect. "
+.if defined(WITHOUT_NLS)
+ @${ECHO_CMD} "National language support disabled, -DWITHOUT_NLS in effect. "
.else
- @${ECHO_CMD} "Use -DDISABLE_NLS to build without national language support."
+ @${ECHO_CMD} "Use -DWITHOUT_NLS to build without national language support."
.endif
@${ECHO_CMD} "-------------------------------------------------------------"
@@ -66,10 +66,6 @@ post-extract:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 491000
-USE_GCC= 3.4
-.endif
-
post-patch:
${REINPLACE_CMD} -e 's|-DRESOURCE_TRACK||' ${WRKSRC}/e2fsck/Makefile.in
${GUNZIP_CMD} ${WRKSRC}/tests/m_*/expect*.gz
diff --git a/sysutils/e2fsprogs/files/patch-MCONFIG--I-order b/sysutils/e2fsprogs/files/patch-MCONFIG--I-order
new file mode 100644
index 000000000000..8a4f55687db0
--- /dev/null
+++ b/sysutils/e2fsprogs/files/patch-MCONFIG--I-order
@@ -0,0 +1,34 @@
+# This is a BitKeeper generated diff -Nru style patch.
+#
+# ChangeSet
+# 2005/01/20 03:17:31+01:00 matthias.andree@gmx.de
+# MCONFIG.in:
+# Rearrange -I options to give local includes precedence over
+# /usr/local/include, to unbreak the build when an older
+# e2fsprogs version (with includes) is installed under
+# /usr/local (for instance, on FreeBSD).
+#
+# MCONFIG.in
+# 2005/01/20 03:16:52+01:00 matthias.andree@gmx.de +2 -3
+# Rearrange -I options to give local includes precedence over
+# /usr/local/include, to unbreak the build when an older
+# e2fsprogs version (with includes) is installed under
+# /usr/local (for instance, on FreeBSD).
+#
+diff -Nru a/MCONFIG.in b/MCONFIG.in
+--- a/MCONFIG.in 2005-01-20 03:43:02 +01:00
++++ b/MCONFIG.in 2005-01-20 03:43:02 +01:00
+@@ -34,11 +34,10 @@
+ BUILD_CC = @BUILD_CC@
+ DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
+ CFLAGS = @CFLAGS@
+-CPPFLAGS = @CPPFLAGS@
++CPPFLAGS = -I$(top_builddir)/lib -I$(top_srcdir)/lib @CPPFLAGS@
+ INTL_FLAGS = @INTL_FLAGS@
+ ALL_CFLAGS = $(CPPFLAGS) $(DEFS) $(USE_WFLAGS) $(CFLAGS) $(XTRA_CFLAGS) \
+- $(INTL_FLAGS) -I$(top_builddir)/lib -I$(top_srcdir)/lib \
+- $(LINUX_INCLUDE)
++ $(INTL_FLAGS) $(LINUX_INCLUDE)
+ LDFLAGS = @LDFLAGS@
+ ALL_LDFLAGS = $(LDFLAGS)
+ RM = @RM@