aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2018-01-11 07:17:07 +0800
committermatthew <matthew@FreeBSD.org>2018-01-11 07:17:07 +0800
commit5e27725cce14d16d978c1c7697f92dbf93e4f229 (patch)
tree435af2fc0178090dcbb73d35819fc6379a9876f1 /sysutils
parentde6302cc2226f808ae41e65a877d75e87513446d (diff)
downloadfreebsd-ports-gnome-5e27725cce14d16d978c1c7697f92dbf93e4f229.tar.gz
freebsd-ports-gnome-5e27725cce14d16d978c1c7697f92dbf93e4f229.tar.zst
freebsd-ports-gnome-5e27725cce14d16d978c1c7697f92dbf93e4f229.zip
Update to 8.32.0
ChangeLog: https://github.com/rsyslog/rsyslog/blob/master/ChangeLog
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/rsyslog8/Makefile6
-rw-r--r--sysutils/rsyslog8/distinfo6
-rw-r--r--sysutils/rsyslog8/files/patch-runtime_nsd__ptcp.c38
3 files changed, 6 insertions, 44 deletions
diff --git a/sysutils/rsyslog8/Makefile b/sysutils/rsyslog8/Makefile
index 8e8de606f407..8cb09bb2860b 100644
--- a/sysutils/rsyslog8/Makefile
+++ b/sysutils/rsyslog8/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= rsyslog
-PORTVERSION= 8.31.0
+PORTVERSION= 8.32.0
CATEGORIES= sysutils
MASTER_SITES= http://www.rsyslog.com/files/download/rsyslog/
@@ -15,7 +15,8 @@ LIB_DEPENDS= libee.so:devel/libee \
libestr.so:devel/libestr \
libfastjson.so:devel/libfastjson \
liblogging-stdlog.so:devel/liblogging \
- libuuid.so:misc/e2fsprogs-libuuid
+ libuuid.so:misc/e2fsprogs-libuuid \
+ libcurl.so:ftp/curl
BUILD_DEPENDS= rst2man:textproc/py-docutils
PORTSCOUT= limit:^8\.
@@ -38,7 +39,6 @@ DBI_PLIST_FILES= lib/rsyslog/omlibdbi.so
ELASTIC_DESC= Elasticsearch module for rsyslog
ELASTIC_CONFIGURE_ENABLE= elasticsearch
-ELASTIC_LIB_DEPENDS= libcurl.so:ftp/curl
ELASTIC_PLIST_FILES= lib/rsyslog/omelasticsearch.so
GCRYPT_DESC= Enable support for encrypted logfiles
diff --git a/sysutils/rsyslog8/distinfo b/sysutils/rsyslog8/distinfo
index f9e54609816f..02cccea71e3a 100644
--- a/sysutils/rsyslog8/distinfo
+++ b/sysutils/rsyslog8/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1511983511
-SHA256 (rsyslog-8.31.0.tar.gz) = eee6318f8127f56500c1e1f672fac6207eeb87bbf0985f5af964f881a96601b2
-SIZE (rsyslog-8.31.0.tar.gz) = 2498675
+TIMESTAMP = 1515623023
+SHA256 (rsyslog-8.32.0.tar.gz) = 9646fdc33a6314464cba68323716010a8a55c3deb523cd798ba8b41a0efa40b8
+SIZE (rsyslog-8.32.0.tar.gz) = 2478990
diff --git a/sysutils/rsyslog8/files/patch-runtime_nsd__ptcp.c b/sysutils/rsyslog8/files/patch-runtime_nsd__ptcp.c
deleted file mode 100644
index 4bcb1acaa904..000000000000
--- a/sysutils/rsyslog8/files/patch-runtime_nsd__ptcp.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- runtime/nsd_ptcp.c.orig 2017-04-28 07:04:53 UTC
-+++ runtime/nsd_ptcp.c
-@@ -665,7 +665,11 @@ EnableKeepAlive(nsd_t *pNsd)
- if(pThis->iKeepAliveProbes > 0) {
- optval = pThis->iKeepAliveProbes;
- optlen = sizeof(optval);
-+#if defined(SOL_TCP)
- ret = setsockopt(pThis->sock, SOL_TCP, TCP_KEEPCNT, &optval, optlen);
-+#else
-+ ret = setsockopt(pThis->sock, SOL_SOCKET, TCP_KEEPCNT, &optval, optlen);
-+#endif
- } else {
- ret = 0;
- }
-@@ -680,7 +684,11 @@ EnableKeepAlive(nsd_t *pNsd)
- if(pThis->iKeepAliveTime > 0) {
- optval = pThis->iKeepAliveTime;
- optlen = sizeof(optval);
-+#if defined(SOL_TCP)
- ret = setsockopt(pThis->sock, SOL_TCP, TCP_KEEPIDLE, &optval, optlen);
-+#else
-+ ret = setsockopt(pThis->sock, SOL_SOCKET, TCP_KEEPIDLE, &optval, optlen);
-+#endif
- } else {
- ret = 0;
- }
-@@ -695,7 +703,11 @@ EnableKeepAlive(nsd_t *pNsd)
- if(pThis->iKeepAliveIntvl > 0) {
- optval = pThis->iKeepAliveIntvl;
- optlen = sizeof(optval);
-+#if defined(SOL_TCP)
- ret = setsockopt(pThis->sock, SOL_TCP, TCP_KEEPINTVL, &optval, optlen);
-+#else
-+ ret = setsockopt(pThis->sock, SOL_SOCKET, TCP_KEEPINTVL, &optval, optlen);
-+#endif
- } else {
- ret = 0;
- }