aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2003-12-04 14:37:09 +0800
committerlinimon <linimon@FreeBSD.org>2003-12-04 14:37:09 +0800
commit681c674d0edef4386d045e7586c45db7d4d67df9 (patch)
treeaad49768dd059a00e6fa700d1e90092a38dcfc02 /sysutils
parent4152828131131c30bf2d8e3d98dfc26c4ab1c79e (diff)
downloadfreebsd-ports-gnome-681c674d0edef4386d045e7586c45db7d4d67df9.tar.gz
freebsd-ports-gnome-681c674d0edef4386d045e7586c45db7d4d67df9.tar.zst
freebsd-ports-gnome-681c674d0edef4386d045e7586c45db7d4d67df9.zip
Add sysutils/portdowngrade, a utility to help downgrade FreeBSD ports by
analyzing the history of commits to the port and presenting the user the list of changes. By selecting one, the port can be set back to a previous version easily. WWW: http://sourceforge.net/projects/portdowngrade/ PR: ports/48257 Submitted by: Heiner Eichmann <h.eichmann@gmx.de>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/portdowngrade/Makefile31
-rw-r--r--sysutils/portdowngrade/distinfo1
-rw-r--r--sysutils/portdowngrade/files/patch-portdowngrade.cpp12
-rw-r--r--sysutils/portdowngrade/pkg-descr8
-rw-r--r--sysutils/portdowngrade/pkg-plist1
5 files changed, 53 insertions, 0 deletions
diff --git a/sysutils/portdowngrade/Makefile b/sysutils/portdowngrade/Makefile
new file mode 100644
index 000000000000..68ef5df436f5
--- /dev/null
+++ b/sysutils/portdowngrade/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: portdowngrade
+# Date created: 2003/02/13
+# Whom: Heiner <h.eichmann@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= portdowngrade
+PORTVERSION= 0.1
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= h.eichmann@gmx.de
+COMMENT=Sets a port back to a previous version
+
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+
+POPT_INCLUDE= `pkg_info -xL ^popt | ${GREP} popt.h | ${SED} -e 's?/popt.h??'`
+POPT_LIB= `pkg_info -xL ^popt | ${GREP} libpopt.a | ${SED} -e 's?/libpopt.a??'`
+CONFIGURE_ENV= CPPFLAGS="-I${POPT_INCLUDE}" \
+ LIBS="-lpopt -L${POPT_LIB}"
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+USE_BZIP2= yes
+
+MAN1= portdowngrade.1
+
+.include <bsd.port.mk>
diff --git a/sysutils/portdowngrade/distinfo b/sysutils/portdowngrade/distinfo
new file mode 100644
index 000000000000..b4a2aa577dbc
--- /dev/null
+++ b/sysutils/portdowngrade/distinfo
@@ -0,0 +1 @@
+MD5 (portdowngrade-0.1.tar.bz2) = f0576e4836033bbe6740f660ee61b010
diff --git a/sysutils/portdowngrade/files/patch-portdowngrade.cpp b/sysutils/portdowngrade/files/patch-portdowngrade.cpp
new file mode 100644
index 000000000000..45a73d54eccb
--- /dev/null
+++ b/sysutils/portdowngrade/files/patch-portdowngrade.cpp
@@ -0,0 +1,12 @@
+--- portdowngrade/portdowngrade.cpp.orig Mon Nov 17 20:35:46 2003
++++ portdowngrade/portdowngrade.cpp Sun Nov 23 09:59:53 2003
+@@ -36,7 +36,8 @@
+ #include <popt.h>
+ #include <string>
+ #include <fstream>
+-#include <slist>
++#include <slist.h>
++#include <iostream>
+ #include <vector>
+ #include <algorithm>
+
diff --git a/sysutils/portdowngrade/pkg-descr b/sysutils/portdowngrade/pkg-descr
new file mode 100644
index 000000000000..94e505406b16
--- /dev/null
+++ b/sysutils/portdowngrade/pkg-descr
@@ -0,0 +1,8 @@
+Portdowngrade helps to downgrade FreeBSD ports by analyzing the history
+of commits to the port and presenting the user the list of changes. By
+selecting one, the port can be set back to a previous version easily.
+
+WWW: http://sourceforge.net/projects/portdowngrade/
+
+--
+h.eichmann@gmx.de
diff --git a/sysutils/portdowngrade/pkg-plist b/sysutils/portdowngrade/pkg-plist
new file mode 100644
index 000000000000..34f9fd1972a5
--- /dev/null
+++ b/sysutils/portdowngrade/pkg-plist
@@ -0,0 +1 @@
+sbin/portdowngrade