aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-09-04 05:07:17 +0800
committerantoine <antoine@FreeBSD.org>2014-09-04 05:07:17 +0800
commita3893ca7b7a6dbe27d71538a7272894a041a57cb (patch)
treecdbc504d12ee8db825712bef5ec2e47a54174d4a /sysutils
parentd716fe9348500252fa2e618cf65ef2ce05630fba (diff)
downloadfreebsd-ports-gnome-a3893ca7b7a6dbe27d71538a7272894a041a57cb.tar.gz
freebsd-ports-gnome-a3893ca7b7a6dbe27d71538a7272894a041a57cb.tar.zst
freebsd-ports-gnome-a3893ca7b7a6dbe27d71538a7272894a041a57cb.zip
Allow staging as a regular user
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/ascpu/Makefile4
-rw-r--r--sysutils/asmon/Makefile5
-rw-r--r--sysutils/bsdmoted/Makefile1
-rw-r--r--sysutils/consolehm/Makefile1
4 files changed, 6 insertions, 5 deletions
diff --git a/sysutils/ascpu/Makefile b/sysutils/ascpu/Makefile
index ffcde968be55..23b3b3c97ce4 100644
--- a/sysutils/ascpu/Makefile
+++ b/sysutils/ascpu/Makefile
@@ -18,10 +18,10 @@ CONFIGURE_ARGS= --with-xpm-includes=${LOCALBASE}/include --with-xpm-library=${LO
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV= EXTRA_LIBRARIES="-L${LOCALBASE}/lib"
-PLIST_FILES= bin/ascpu man/man1/ascpu.1.gz
+PLIST_FILES= "@(,kmem,2555) bin/ascpu" man/man1/ascpu.1.gz
do-install:
${INSTALL_MAN} ${WRKSRC}/ascpu.man ${STAGEDIR}${PREFIX}/man/man1/ascpu.1
- ${INSTALL} ${STRIP} -o ${BINOWN} -g kmem -m 2755 ${WRKSRC}/ascpu ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/ascpu ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/sysutils/asmon/Makefile b/sysutils/asmon/Makefile
index 296fe1a34f55..6aaac78aee2a 100644
--- a/sysutils/asmon/Makefile
+++ b/sysutils/asmon/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
USE_XORG= xpm x11
-BUILD_WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/asmon
+BUILD_WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/asmon
CFLAGS+= -I${LOCALBASE}/include
USES= gmake
USE_CSTD= gnu89
@@ -23,13 +23,12 @@ ALL_TARGET= asmon
MAKE_ARGS+= LIBDIR="-L${LOCALBASE}/lib" \
SOLARIS_LIBS=-lkvm
-PLIST_FILES= bin/asmon
+PLIST_FILES= "@(,kmem,) bin/asmon"
post-patch:
${REINPLACE_CMD} -e 's:gcc:${CC} ${CFLAGS}:' ${BUILD_WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/asmon/asmon ${STAGEDIR}${PREFIX}/bin
- ${CHGRP} kmem ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>
diff --git a/sysutils/bsdmoted/Makefile b/sysutils/bsdmoted/Makefile
index ceafd80bbff6..5ff4bff91d85 100644
--- a/sysutils/bsdmoted/Makefile
+++ b/sysutils/bsdmoted/Makefile
@@ -9,6 +9,7 @@ MASTER_SITES= SF
MAINTAINER= sahne@0x90.at
COMMENT= Use Wii remote as mouse
+USES= uidfix
PLIST_FILES= sbin/bsdmoted
.include <bsd.port.mk>
diff --git a/sysutils/consolehm/Makefile b/sysutils/consolehm/Makefile
index 71e0ee777baf..324500da626e 100644
--- a/sysutils/consolehm/Makefile
+++ b/sysutils/consolehm/Makefile
@@ -13,6 +13,7 @@ COMMENT= Console based hardware monitor for FreeBSD
WRKSRC= ${WRKDIR}/consolehm/consolehm
+USES= uidfix
GNU_CONFIGURE= yes
PLIST_FILES= bin/chm man/man8/chm.8.gz