aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-08-04 05:08:11 +0800
committermarino <marino@FreeBSD.org>2014-08-04 05:08:11 +0800
commita6e79d64930ab1d17ee6c82775259c8f84935655 (patch)
tree4c943b58fda42d7aa46a124e97d8a34de3d218cd /sysutils
parentb147186631121c3b6df6cb6fb2a23d9b171319bc (diff)
downloadfreebsd-ports-gnome-a6e79d64930ab1d17ee6c82775259c8f84935655.tar.gz
freebsd-ports-gnome-a6e79d64930ab1d17ee6c82775259c8f84935655.tar.zst
freebsd-ports-gnome-a6e79d64930ab1d17ee6c82775259c8f84935655.zip
Add new port: sysutils/daemontools-encore
PR: 181765 Submitted by: uffe ================================================================= daemontools-encore is a collection of tools for managing UNIX services. It is derived from the public-domain release of daemontools by D. J. Bernstein. daemontools-encore adds numerous enhancements above what daemontools could do while maintaining backwards compatibility with daemontools. See the CHANGES file for more details on what features have been added.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/daemontools-encore/Makefile76
-rw-r--r--sysutils/daemontools-encore/distinfo2
-rw-r--r--sysutils/daemontools-encore/files/patch-Makefile.diff11
-rw-r--r--sysutils/daemontools-encore/files/patch-conf-cc.diff7
-rw-r--r--sysutils/daemontools-encore/files/patch-conf-ld.diff7
-rw-r--r--sysutils/daemontools-encore/files/patch-sleeper-c.diff33
-rw-r--r--sysutils/daemontools-encore/pkg-descr8
8 files changed, 145 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 4a6f32783274..22a54a563a11 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -158,6 +158,7 @@
SUBDIR += dae
SUBDIR += daedalus
SUBDIR += daemontools
+ SUBDIR += daemontools-encore
SUBDIR += dar
SUBDIR += dateutils
SUBDIR += dc3dd
diff --git a/sysutils/daemontools-encore/Makefile b/sysutils/daemontools-encore/Makefile
new file mode 100644
index 000000000000..eb89f3185fd1
--- /dev/null
+++ b/sysutils/daemontools-encore/Makefile
@@ -0,0 +1,76 @@
+# Created by: Uffe Jakobsen <uffe@uffe.org>
+# $FreeBSD$
+
+PORTNAME= daemontools-encore
+PORTVERSION= 1.10
+CATEGORIES= sysutils
+MASTER_SITES= http://untroubled.org/daemontools-encore/
+
+MAINTAINER= uffe@uffe.org
+COMMENT= Daemontools-encore is a collection of tools for managing UNIX services
+
+USES= gmake
+
+ALL_TARGET= default
+
+MANFILES= \
+ envdir.8 \
+ envuidgid.8 \
+ fghack.8 \
+ multilog.8 \
+ pgrphack.8 \
+ readproctitle.8 \
+ setlock.8 \
+ setuidgid.8 \
+ softlimit.8 \
+ supervise.8 \
+ svc.8 \
+ svok.8 \
+ svscan.8 \
+ svscanboot.8 \
+ svstat.8 \
+ svup.8 \
+ tai64n.8 \
+ tai64nlocal.8
+
+PLIST_FILES= \
+ bin/envdir \
+ bin/envuidgid \
+ bin/fghack \
+ bin/multilog \
+ bin/pgrphack \
+ bin/readproctitle \
+ bin/setlock \
+ bin/setuidgid \
+ bin/softlimit \
+ bin/supervise \
+ bin/svc \
+ bin/svok \
+ bin/svscan \
+ bin/svscanboot \
+ bin/svstat \
+ bin/svup \
+ bin/tai64n \
+ bin/tai64nlocal \
+ %%DOCSDIR%%/README \
+ %%DOCSDIR%%/LICENSE \
+ %%DOCSDIR%%/CHANGES \
+ %%DOCSDIR%%/CHANGES.djb \
+ ${MANFILES:S,^,man/man8/,:S,$,.gz,}
+
+PLIST_DIRSTRY= %%DOCSDIR%%
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/svscanboot.sh ${STAGEDIR}${PREFIX}/bin/svscanboot
+.for binfile in envdir envuidgid fghack multilog pgrphack readproctitle setlock setuidgid softlimit supervise svc svok svscan svstat svup tai64n tai64nlocal
+ ${INSTALL_PROGRAM} ${WRKSRC}/${binfile} ${STAGEDIR}${PREFIX}/bin/
+.endfor
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for docfile in README LICENSE CHANGES CHANGES.djb
+ ${INSTALL_DATA} ${WRKSRC}/${docfile} ${STAGEDIR}${DOCSDIR}
+.endfor
+.for manfile in ${MANFILES}
+ ${INSTALL_MAN} ${WRKSRC}/${manfile} ${STAGEDIR}${MAN1PREFIX}/man/man8/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/sysutils/daemontools-encore/distinfo b/sysutils/daemontools-encore/distinfo
new file mode 100644
index 000000000000..d872cc320aea
--- /dev/null
+++ b/sysutils/daemontools-encore/distinfo
@@ -0,0 +1,2 @@
+SHA256 (daemontools-encore-1.10.tar.gz) = 9f48f3c6cdd3f2b0202532e87f9ff46ea86777ca31ebda3a96bed618104bbd31
+SIZE (daemontools-encore-1.10.tar.gz) = 87096
diff --git a/sysutils/daemontools-encore/files/patch-Makefile.diff b/sysutils/daemontools-encore/files/patch-Makefile.diff
new file mode 100644
index 000000000000..d69223f765dd
--- /dev/null
+++ b/sysutils/daemontools-encore/files/patch-Makefile.diff
@@ -0,0 +1,11 @@
+--- Makefile.orig 2014-04-02 00:58:19.000000000 +0200
++++ Makefile 2014-07-27 23:29:50.000000000 +0200
+@@ -239,7 +239,7 @@
+ ./compile iopause.c
+
+ it: \
+-rts sysdeps man
++programs sysdeps man
+
+ load: \
+ conf-ld print-ld.sh systype warn-auto.sh
diff --git a/sysutils/daemontools-encore/files/patch-conf-cc.diff b/sysutils/daemontools-encore/files/patch-conf-cc.diff
new file mode 100644
index 000000000000..bfa934fa343e
--- /dev/null
+++ b/sysutils/daemontools-encore/files/patch-conf-cc.diff
@@ -0,0 +1,7 @@
+--- conf-cc.orig 2014-07-27 23:11:57.000000000 +0200
++++ conf-cc 2014-07-27 23:12:04.000000000 +0200
+@@ -1,3 +1,3 @@
+-gcc -O2 -Wall -Wshadow -Wcast-align -Wwrite-strings
++cc -O2 -Wall -Wshadow -Wcast-align -Wwrite-strings
+
+ This will be used to compile .c files.
diff --git a/sysutils/daemontools-encore/files/patch-conf-ld.diff b/sysutils/daemontools-encore/files/patch-conf-ld.diff
new file mode 100644
index 000000000000..36a3a33e8479
--- /dev/null
+++ b/sysutils/daemontools-encore/files/patch-conf-ld.diff
@@ -0,0 +1,7 @@
+--- conf-ld.orig 2014-07-27 23:12:53.000000000 +0200
++++ conf-ld 2014-07-27 23:13:03.000000000 +0200
+@@ -1,3 +1,3 @@
+-gcc -s
++cc -s
+
+ This will be used to link .o files into an executable.
diff --git a/sysutils/daemontools-encore/files/patch-sleeper-c.diff b/sysutils/daemontools-encore/files/patch-sleeper-c.diff
new file mode 100644
index 000000000000..d04aa4292d01
--- /dev/null
+++ b/sysutils/daemontools-encore/files/patch-sleeper-c.diff
@@ -0,0 +1,33 @@
+--- sleeper.c.orig 2014-07-27 23:16:55.000000000 +0200
++++ sleeper.c 2014-07-27 23:18:11.000000000 +0200
+@@ -8,20 +8,18 @@
+ const char *name;
+ int ignored;
+ switch (sig) {
+- case SIGALRM: name = "ALRM"; break;
+- case SIGCONT: name = "CONT"; break;
+- case SIGHUP: name = "HUP"; break;
+- case SIGINT: name = "INT"; break;
+- case SIGQUIT: name = "QUIT"; break;
+- case SIGTERM: name = "TERM"; break;
+- case SIGUSR1: name = "USR1"; break;
+- case SIGUSR2: name = "USR2"; break;
+- case SIGWINCH: name = "WINCH"; break;
+- default: name = "unknown signal";
++ case SIGALRM: name = "Caught ALRM\n"; break;
++ case SIGCONT: name = "Caught CONT\n"; break;
++ case SIGHUP: name = "Caught HUP\n"; break;
++ case SIGINT: name = "Caught INT\n"; break;
++ case SIGQUIT: name = "Caught QUIT\n"; break;
++ case SIGTERM: name = "Caught TERM\n"; break;
++ case SIGUSR1: name = "Caught USR1\n"; break;
++ case SIGUSR2: name = "Caught USR2\n"; break;
++ case SIGWINCH: name = "Caught WINCH\n"; break;
++ default: name = "unknown signal\n";
+ }
+- ignored = write(1, "Caught ", 7);
+ ignored = write(1, name, str_len(name));
+- ignored = write(1, "\n", 1);
+ if (sig != SIGCONT)
+ _exit(1);
+ }
diff --git a/sysutils/daemontools-encore/pkg-descr b/sysutils/daemontools-encore/pkg-descr
new file mode 100644
index 000000000000..d8aa0b98558e
--- /dev/null
+++ b/sysutils/daemontools-encore/pkg-descr
@@ -0,0 +1,8 @@
+daemontools-encore is a collection of tools for managing UNIX services.
+It is derived from the public-domain release of daemontools by D. J.
+Bernstein. daemontools-encore adds numerous enhancements above what
+daemontools could do while maintaining backwards compatibility with
+daemontools. See the CHANGES file for more details on what features
+have been added.
+
+WWW: http://untroubled.org/daemontools-encore/