aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-01-16 04:26:59 +0800
committerpav <pav@FreeBSD.org>2005-01-16 04:26:59 +0800
commitaed9070b968186fee195995dd8075226f026fd7f (patch)
tree568ecc6967f4b69a81c44621d2ed47f706b9f435 /sysutils
parent1452777acb28fa07bb6261328db8664f1e1f1525 (diff)
downloadfreebsd-ports-gnome-aed9070b968186fee195995dd8075226f026fd7f.tar.gz
freebsd-ports-gnome-aed9070b968186fee195995dd8075226f026fd7f.tar.zst
freebsd-ports-gnome-aed9070b968186fee195995dd8075226f026fd7f.zip
- Fix X11 detection
- Add option for "Flicker-free operation support" PR: ports/76256 Submitted by: Roman Bogorodskiy <bogorodskiy@gmail.com> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/torsmo/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/sysutils/torsmo/Makefile b/sysutils/torsmo/Makefile
index 74dc46df091f..f1e42c94ed64 100644
--- a/sysutils/torsmo/Makefile
+++ b/sysutils/torsmo/Makefile
@@ -7,7 +7,7 @@
PORTNAME= torsmo
PORTVERSION= 0.18
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,6 +16,7 @@ MAINTAINER= bogorodskiy@inbox.ru
COMMENT= System monitor that renders text on desktop
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include"
USE_X_PREFIX= yes
MAN1= torsmo.1
@@ -24,15 +25,20 @@ PLIST_FILES= bin/torsmo \
PLIST_DIRS= %%EXAMPLESDIR%%
PORTDOCS= AUTHORS ChangeLog NEWS README
-OPTIONS= XFT "Enable XFT support" on
+OPTIONS= XFT "XFT support" on \
+ DOUBLE_BUFFER "Flicker-free operation support" on
.include <bsd.port.pre.mk>
-.if defined(WITH_XFT)
+.if !defined(WITHOUT_XFT)
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
CONFIGURE_ARGS+= --enable-xft
.endif
+.if defined(WITHOUT_DOUBLE_BUFFER)
+CONFIGURE_ARGS+= --disable-double-buffer
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}