aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-10-26 05:42:01 +0800
committerpav <pav@FreeBSD.org>2004-10-26 05:42:01 +0800
commitc00af9aab3f48251f5b29d73fde9c192f44ea87e (patch)
tree60c8d8186f832788cc83464a1c9f38755d2ba6e7 /sysutils
parent06f1caa554e31a995d5325a0e58422c714168071 (diff)
downloadfreebsd-ports-gnome-c00af9aab3f48251f5b29d73fde9c192f44ea87e.tar.gz
freebsd-ports-gnome-c00af9aab3f48251f5b29d73fde9c192f44ea87e.tar.zst
freebsd-ports-gnome-c00af9aab3f48251f5b29d73fde9c192f44ea87e.zip
- Fix acpitemp function by changing type from double to int (we get temp
in kelvins (int) and then convert it in celsius (double)). Reported by: Aurel Bodenmann PR: ports/73087 Submitted by: Roman Bogorodskiy <bogorodskiy@inbox.ru> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/torsmo/Makefile2
-rw-r--r--sysutils/torsmo/files/freebsd.c4
2 files changed, 3 insertions, 3 deletions
diff --git a/sysutils/torsmo/Makefile b/sysutils/torsmo/Makefile
index 930938e1a2d5..b9281dc2944b 100644
--- a/sysutils/torsmo/Makefile
+++ b/sysutils/torsmo/Makefile
@@ -7,7 +7,7 @@
PORTNAME= torsmo
PORTVERSION= 0.17
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/sysutils/torsmo/files/freebsd.c b/sysutils/torsmo/files/freebsd.c
index cd5e9b00d8c2..19916df13dab 100644
--- a/sysutils/torsmo/files/freebsd.c
+++ b/sysutils/torsmo/files/freebsd.c
@@ -295,8 +295,8 @@ void get_load_average(double v[3]) {
}
double get_acpi_temperature(int fd) {
- double temp;
-
+ int temp;
+
if (GETSYSCTL("hw.acpi.thermal.tz0.temperature", temp)) {
(void)fprintf(stderr, "Cannot read sysctl \"hw.acpi.thermal.tz0.temperature\"\n");
temp = -1.0;