aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2012-01-22 01:40:15 +0800
committereadler <eadler@FreeBSD.org>2012-01-22 01:40:15 +0800
commite9db6e5787c03eac4b5310b1b5abeee5eea88e8c (patch)
tree403e868e6517b550ecdf81ff503e5975785ab7d7 /sysutils
parent0c9cbf4cb27b7ccab5b886919dea648ef53e8a6b (diff)
downloadfreebsd-ports-gnome-e9db6e5787c03eac4b5310b1b5abeee5eea88e8c.tar.gz
freebsd-ports-gnome-e9db6e5787c03eac4b5310b1b5abeee5eea88e8c.tar.zst
freebsd-ports-gnome-e9db6e5787c03eac4b5310b1b5abeee5eea88e8c.zip
At the moment 1385 ports use BUILD_DEPENDS= ${RUN_DEPENDS} and 450
ports use BUILD_DEPENDS:= ${RUN_DEPENDS}. This patch fixes ports that are currently broken. This is a temporary measure until we organically stop using := or someone(s) spend a lot of time changing all the ports over. Explicit duplication > := > = and this just moves ports one step to the left Approved by: portmgr
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/apt/Makefile2
-rw-r--r--sysutils/farbot/Makefile2
-rw-r--r--sysutils/graphicboot/Makefile2
-rw-r--r--sysutils/grok/Makefile2
-rw-r--r--sysutils/heirloom/Makefile2
-rw-r--r--sysutils/hploscripts/Makefile2
-rw-r--r--sysutils/jps/Makefile2
-rw-r--r--sysutils/jtop/Makefile2
-rw-r--r--sysutils/mcron/Makefile2
-rw-r--r--sysutils/pear-Cache/Makefile2
-rw-r--r--sysutils/pear-File/Makefile2
-rw-r--r--sysutils/pear-File_Find/Makefile2
-rw-r--r--sysutils/pear-File_Fstab/Makefile2
-rw-r--r--sysutils/pear-File_Gettext/Makefile2
-rw-r--r--sysutils/pear-I18Nv2/Makefile2
-rw-r--r--sysutils/pear-Translation2/Makefile2
-rw-r--r--sysutils/psgconf/Makefile2
-rw-r--r--sysutils/sysgather/Makefile2
-rw-r--r--sysutils/vils/Makefile2
19 files changed, 19 insertions, 19 deletions
diff --git a/sysutils/apt/Makefile b/sysutils/apt/Makefile
index 0beec8744860..e2ae8d6c21fb 100644
--- a/sysutils/apt/Makefile
+++ b/sysutils/apt/Makefile
@@ -16,7 +16,7 @@ COMMENT= Advanced front-end for dpkg
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
${LOCALBASE}/lib/libpub.a:${PORTSDIR}/devel/publib
-RUN_DEPENDS= ${BUILD_DEPENDS} \
+RUN_DEPENDS:= ${BUILD_DEPENDS} \
dpkg:${PORTSDIR}/archivers/dpkg \
gpg:${PORTSDIR}/security/gnupg1
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
diff --git a/sysutils/farbot/Makefile b/sysutils/farbot/Makefile
index de727fb4a81d..f7f5f0965a2e 100644
--- a/sysutils/farbot/Makefile
+++ b/sysutils/farbot/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= snb@FreeBSD.org
COMMENT= FreeBSD Automated Release Bot
BUILD_DEPENDS= ${LOCALBASE}/bin/zconfig:${PORTSDIR}/devel/py-zconfig
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
WRKSRC= ${WRKDIR}/${DISTNAME}
diff --git a/sysutils/graphicboot/Makefile b/sysutils/graphicboot/Makefile
index f818e1758d46..ac12cb8786f8 100644
--- a/sysutils/graphicboot/Makefile
+++ b/sysutils/graphicboot/Makefile
@@ -17,7 +17,7 @@ COMMENT= Provides graphical X Window startup to FreeBSD during 'rc'
BUILD_DEPENDS= xloadimage:${PORTSDIR}/x11/xloadimage \
xrdb:${PORTSDIR}/x11/xrdb \
xsetroot:${PORTSDIR}/x11/xsetroot
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_MOTIF= yes
USE_BZIP2= yes
diff --git a/sysutils/grok/Makefile b/sysutils/grok/Makefile
index 35a3268b4b29..77f6279b2cdb 100644
--- a/sysutils/grok/Makefile
+++ b/sysutils/grok/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= gperf>=3.0.3:${PORTSDIR}/devel/gperf \
libevent>=1.3:${PORTSDIR}/devel/libevent \
pcre>=7.6:${PORTSDIR}/devel/pcre \
tokyocabinet>=1.4.9:${PORTSDIR}/databases/tokyocabinet
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAKE_ENV+= GPERF=${LOCALBASE}/bin/gperf \
EXTRA_CFLAGS=-I${LOCALBASE}/include \
diff --git a/sysutils/heirloom/Makefile b/sysutils/heirloom/Makefile
index b60041a3d54c..c993f4a63936 100644
--- a/sysutils/heirloom/Makefile
+++ b/sysutils/heirloom/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= gahr@FreeBSD.org
COMMENT= The Heirloom Toolchest is a collection of standard Unix utilities
BUILD_DEPENDS= ksh:${PORTSDIR}/shells/pdksh
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/sysutils/hploscripts/Makefile b/sysutils/hploscripts/Makefile
index 471421100c96..68e870a93ddf 100644
--- a/sysutils/hploscripts/Makefile
+++ b/sysutils/hploscripts/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT= HP Lights-Out management perl scripts
BUILD_DEPENDS= p5-IO-Socket-SSL>=1.19:${PORTSDIR}/security/p5-IO-Socket-SSL
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= 5.8.0+
NO_BUILD= yes
diff --git a/sysutils/jps/Makefile b/sysutils/jps/Makefile
index a9cb54cf2074..e3eae515546b 100644
--- a/sysutils/jps/Makefile
+++ b/sysutils/jps/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= pavel@ext.by
COMMENT= Wrapper to ps(1) that maps pids to jails
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN1= jps.1
MANCOMPRESSED= yes
diff --git a/sysutils/jtop/Makefile b/sysutils/jtop/Makefile
index 9add4b278bb2..363f6d1efef7 100644
--- a/sysutils/jtop/Makefile
+++ b/sysutils/jtop/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= pavel@ext.by
COMMENT= Wrapper to top(1) that maps pids to jails
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN1= jtop.1
MANCOMPRESSED= yes
diff --git a/sysutils/mcron/Makefile b/sysutils/mcron/Makefile
index 449e92d87cda..860b20a80cd9 100644
--- a/sysutils/mcron/Makefile
+++ b/sysutils/mcron/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= stefan@fh-mainz.de
COMMENT= A 100% compatible replacement for Vixie cron
BUILD_DEPENDS= guile>=1.8.6:${PORTSDIR}/lang/guile
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
MAKEFILE= makefile
diff --git a/sysutils/pear-Cache/Makefile b/sysutils/pear-Cache/Makefile
index 867542a78e8e..ebc51ceec344 100644
--- a/sysutils/pear-Cache/Makefile
+++ b/sysutils/pear-Cache/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR framework for caching of arbitrary data
BUILD_DEPENDS= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
FILES= Cache.php Cache/Application.php Cache/Container.php \
Cache/Container/db.php Cache/Container/dbx.php \
diff --git a/sysutils/pear-File/Makefile b/sysutils/pear-File/Makefile
index 2b3e88dd480f..04c009f141ef 100644
--- a/sysutils/pear-File/Makefile
+++ b/sysutils/pear-File/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR common file and directory routines
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PHP= pcre
diff --git a/sysutils/pear-File_Find/Makefile b/sysutils/pear-File_Find/Makefile
index 713f08a9c72b..85f81244f3da 100644
--- a/sysutils/pear-File_Find/Makefile
+++ b/sysutils/pear-File_Find/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class that facillitates the search of filesystems
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PEAR_CATSRC= yes
CATEGORY= File
diff --git a/sysutils/pear-File_Fstab/Makefile b/sysutils/pear-File_Fstab/Makefile
index 967e5f514b25..8cd854846715 100644
--- a/sysutils/pear-File_Fstab/Makefile
+++ b/sysutils/pear-File_Fstab/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= wen@FreeBSD.org
COMMENT= PEAR class to read and write fstab files
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PEAR_CATSRC= yes
diff --git a/sysutils/pear-File_Gettext/Makefile b/sysutils/pear-File_Gettext/Makefile
index cbca9cd55ac5..86387dd98291 100644
--- a/sysutils/pear-File_Gettext/Makefile
+++ b/sysutils/pear-File_Gettext/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR GNU Gettext file parser
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PHP= yes
diff --git a/sysutils/pear-I18Nv2/Makefile b/sysutils/pear-I18Nv2/Makefile
index 9ec305c08583..a8f255814073 100644
--- a/sysutils/pear-I18Nv2/Makefile
+++ b/sysutils/pear-I18Nv2/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR Internationalization
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PHP= iconv
diff --git a/sysutils/pear-Translation2/Makefile b/sysutils/pear-Translation2/Makefile
index ff45ffb35a68..1ad6086e1fc0 100644
--- a/sysutils/pear-Translation2/Makefile
+++ b/sysutils/pear-Translation2/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class for multilingual applications management
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PHP= yes
PEAR_CATSRC= yes
diff --git a/sysutils/psgconf/Makefile b/sysutils/psgconf/Makefile
index 6dff019b4202..c848984f75b9 100644
--- a/sysutils/psgconf/Makefile
+++ b/sysutils/psgconf/Makefile
@@ -22,7 +22,7 @@ BUILD_DEPENDS= ${SITE_PERL}/Config/Objective.pm:${PORTSDIR}/devel/p5-Config-Obje
${SITE_PERL}/${PERL_ARCH}/Unix/Syslog.pm:${PORTSDIR}/sysutils/p5-Unix-Syslog \
${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
${SITE_PERL}/Text/Diff.pm:${PORTSDIR}/textproc/p5-Text-Diff
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/sysutils/sysgather/Makefile b/sysutils/sysgather/Makefile
index 2557f4673de8..70df08b89758 100644
--- a/sysutils/sysgather/Makefile
+++ b/sysutils/sysgather/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= roam@FreeBSD.org
COMMENT= Keep configuration files under version control
BUILD_DEPENDS= ${SITE_PERL}/Config/IniFiles.pm:${PORTSDIR}/devel/p5-Config-IniFiles
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= yes
diff --git a/sysutils/vils/Makefile b/sysutils/vils/Makefile
index 410c4f41bb04..a2d4ea4143e1 100644
--- a/sysutils/vils/Makefile
+++ b/sysutils/vils/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Use your favorite editor to rename files
BUILD_DEPENDS= zsh:${PORTSDIR}/shells/zsh
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PLIST_FILES= bin/vils