aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2012-03-14 00:15:36 +0800
committerpgollucci <pgollucci@FreeBSD.org>2012-03-14 00:15:36 +0800
commitf42856eba9fb3ca5404f63c69672a520d85efc2d (patch)
tree8244b1263e2d907c44d922bb1d05d258b43d1809 /sysutils
parentc779f342d2b34e828d96953ef0a0ce32861128c1 (diff)
downloadfreebsd-ports-gnome-f42856eba9fb3ca5404f63c69672a520d85efc2d.tar.gz
freebsd-ports-gnome-f42856eba9fb3ca5404f63c69672a520d85efc2d.tar.zst
freebsd-ports-gnome-f42856eba9fb3ca5404f63c69672a520d85efc2d.zip
- Revert ports/165605 as requested by portmgr@
Note: devel/p5-B-Size and devel/p5-Devel-Arena where intentionally not restored. PR: ports/165605 Approved by: portmgr (bapt) Feature safe: yes (I sure hope so)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/p5-Brackup/Makefile12
-rw-r--r--sysutils/p5-MogileFS-Utils/Makefile11
-rw-r--r--sysutils/p5-Monitor-Simple/Makefile9
-rw-r--r--sysutils/p5-arclog/Makefile10
-rw-r--r--sysutils/p5-reslog/Makefile10
5 files changed, 44 insertions, 8 deletions
diff --git a/sysutils/p5-Brackup/Makefile b/sysutils/p5-Brackup/Makefile
index 8f8ef18872b7..750742a483ab 100644
--- a/sysutils/p5-Brackup/Makefile
+++ b/sysutils/p5-Brackup/Makefile
@@ -54,4 +54,14 @@ MAN3= Brackup.3 \
Brackup::Target::Riak.3 \
Brackup::Target::Sftp.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500905
+RUN_DEPENDS+= p5-File-Temp>=0.17:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-ExtUtils-Manifest>=1.52:${PORTSDIR}/devel/p5-ExtUtils-Manifest
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/p5-MogileFS-Utils/Makefile b/sysutils/p5-MogileFS-Utils/Makefile
index 19709acbbd50..48b3b1fe58b4 100644
--- a/sysutils/p5-MogileFS-Utils/Makefile
+++ b/sysutils/p5-MogileFS-Utils/Makefile
@@ -17,7 +17,8 @@ COMMENT= MogileFS tools
BUILD_DEPENDS= p5-MogileFS-Client>=1.14:${PORTSDIR}/sysutils/p5-MogileFS-Client \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-MogileFS-Client>=1.14:${PORTSDIR}/sysutils/p5-MogileFS-Client \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
PERL_CONFIGURE= yes
@@ -34,7 +35,13 @@ MAN1= mogadm.1 \
mogupload.1
MAN3= MogileFS::Utils.3
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/NAME/ s|MogileFS-Utils|MogileFS::Utils|' ${WRKSRC}/Makefile.PL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/p5-Monitor-Simple/Makefile b/sysutils/p5-Monitor-Simple/Makefile
index 2878ea816456..44cab802662f 100644
--- a/sysutils/p5-Monitor-Simple/Makefile
+++ b/sysutils/p5-Monitor-Simple/Makefile
@@ -38,4 +38,11 @@ MAN3= Monitor::Simple.3 \
Monitor::Simple::UserAgent.3 \
Monitor::Simple::Utils.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-Getopt-Long>=2.38:${PORTSDIR}/devel/p5-Getopt-Long
+RUN_DEPENDS+= p5-Getopt-Long>=2.38:${PORTSDIR}/devel/p5-Getopt-Long
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/p5-arclog/Makefile b/sysutils/p5-arclog/Makefile
index 41ecdf6f630c..324ec87f1f1e 100644
--- a/sysutils/p5-arclog/Makefile
+++ b/sysutils/p5-arclog/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
p5-Compress-Bzip2>=0:${PORTSDIR}/archivers/p5-Compress-Bzip2 \
p5-File-MMagic>=0:${PORTSDIR}/devel/p5-File-MMagic \
p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN1= arclog.1
@@ -29,4 +29,10 @@ PLIST_FILES= bin/arclog \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/arclog/.packlist
PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/arclog
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/p5-reslog/Makefile b/sysutils/p5-reslog/Makefile
index 362ce03faf00..18d922e207dd 100644
--- a/sysutils/p5-reslog/Makefile
+++ b/sysutils/p5-reslog/Makefile
@@ -19,7 +19,7 @@ COMMENT= Reverse-resolve IP in Apache log files
RUN_DEPENDS= p5-Compress-Bzip2>=0:${PORTSDIR}/archivers/p5-Compress-Bzip2 \
p5-File-MMagic>=0:${PORTSDIR}/devel/p5-File-MMagic \
p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN1= reslog.1
@@ -28,4 +28,10 @@ PLIST_FILES= bin/reslog \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/reslog/.packlist
PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/reslog
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>