aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormanu <manu@FreeBSD.org>2017-11-12 01:08:49 +0800
committermanu <manu@FreeBSD.org>2017-11-12 01:08:49 +0800
commit448c7e3cb3a1451883d102f3b1b6370c5bf0a4ac (patch)
tree7c375874b9f6e711af45795374332d784c9a0d95 /sysutils
parent3108e3301a792953ecbb19c68ce3aff2bd31cdbe (diff)
downloadfreebsd-ports-gnome-448c7e3cb3a1451883d102f3b1b6370c5bf0a4ac.tar.gz
freebsd-ports-gnome-448c7e3cb3a1451883d102f3b1b6370c5bf0a4ac.tar.zst
freebsd-ports-gnome-448c7e3cb3a1451883d102f3b1b6370c5bf0a4ac.zip
Add u-boot port for Sopine/Pine64-LTS
Reviewed by: imp (earlier version) Approved by: imp Differential Revision: https://reviews.freebsd.org/D13022
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/u-boot-sopine/Makefile16
-rw-r--r--sysutils/u-boot-sopine/pkg-descr9
3 files changed, 26 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 0d806a531a53..9bd4094a3727 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1222,6 +1222,7 @@
SUBDIR += u-boot-rpi2
SUBDIR += u-boot-rpi3
SUBDIR += u-boot-sinovoip-bpi-m3
+ SUBDIR += u-boot-sopine
SUBDIR += u-boot-utilite
SUBDIR += u-boot-wandboard
SUBDIR += u-boot-zedboard
diff --git a/sysutils/u-boot-sopine/Makefile b/sysutils/u-boot-sopine/Makefile
new file mode 100644
index 000000000000..6cded540f906
--- /dev/null
+++ b/sysutils/u-boot-sopine/Makefile
@@ -0,0 +1,16 @@
+# $FreeBSD$
+
+MAINTAINER= manu@FreeBSD.org
+MASTERDIR= ${.CURDIR}/../u-boot-master
+
+MODEL= sopine
+BOARD_CONFIG= sopine_baseboard_defconfig
+FAMILY= allwinner64
+
+BUILD_DEPENDS= ${LOCALBASE}/share/atf-allwinner/bl31.bin:sysutils/atf-allwinner
+MAKE_ENV+= BL31=${LOCALBASE}/share/atf-allwinner/bl31.bin
+
+post-build:
+ ${CAT} ${WRKSRC}/spl/sunxi-spl.bin ${WRKSRC}/u-boot.itb > ${WRKSRC}/u-boot-sunxi-with-spl.bin
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/u-boot-sopine/pkg-descr b/sysutils/u-boot-sopine/pkg-descr
new file mode 100644
index 000000000000..5de5f3bd1fd4
--- /dev/null
+++ b/sysutils/u-boot-sopine/pkg-descr
@@ -0,0 +1,9 @@
+U-Boot loader and related files for the Sopine/Pine64-LTS.
+
+To install this bootloader on an sdcard just do:
+dd if=/usr/local/share/u-boot/u-boot-pine64/u-boot-sunxi-with-spl.bin of=/path/to/sdcarddevice bs=1k seek=8 conv=sync
+
+For information about running FreeBSD on Allwinner boards, see
+ https://wiki.freebsd.org/FreeBSD/arm/Allwinner
+
+WWW: http://www.denx.de/wiki/U-Boot