aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2017-06-08 10:03:55 +0800
committerrene <rene@FreeBSD.org>2017-06-08 10:03:55 +0800
commit7c4fa205e6bf8bc9759325c7f317a03cad9528d3 (patch)
treeb0b2960e10b8f491e64c0f2e0df2cdd569718846 /sysutils
parentdd7ed5e96924a857d0db409231e5209166ef372c (diff)
downloadfreebsd-ports-gnome-7c4fa205e6bf8bc9759325c7f317a03cad9528d3.tar.gz
freebsd-ports-gnome-7c4fa205e6bf8bc9759325c7f317a03cad9528d3.tar.zst
freebsd-ports-gnome-7c4fa205e6bf8bc9759325c7f317a03cad9528d3.zip
sysutils/ohmu: fix port by relaxing runtime dependencies in setup.py
Before, this port depended on future==0.15.2 but we have future 0.16 in Ports. Also relax the dependency on scandir. The port ran fine locally after these changes. Approved by: fix-it
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/ohmu/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/sysutils/ohmu/Makefile b/sysutils/ohmu/Makefile
index d379c81b4a63..5ac88461bcc0 100644
--- a/sysutils/ohmu/Makefile
+++ b/sysutils/ohmu/Makefile
@@ -21,4 +21,9 @@ USES= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
+pre-configure:
+ ${REINPLACE_CMD} -e 's/scandir==1.3/scandir>=1.3/' \
+ -e 's/future==0.15.2/future>=0.15.2/' \
+ ${WRKSRC}/setup.py
+
.include <bsd.port.mk>