aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2017-06-12 21:48:36 +0800
committercy <cy@FreeBSD.org>2017-06-12 21:48:36 +0800
commitd0ca963b3c0f77207860dc581807019a8a6b50d8 (patch)
tree94bca90d5feaedff80d1301e54a5ed3d927dfa46 /sysutils
parentb178482503b00c1b5d7e27bd11e75a4a12e0ef15 (diff)
downloadfreebsd-ports-gnome-d0ca963b3c0f77207860dc581807019a8a6b50d8.tar.gz
freebsd-ports-gnome-d0ca963b3c0f77207860dc581807019a8a6b50d8.tar.zst
freebsd-ports-gnome-d0ca963b3c0f77207860dc581807019a8a6b50d8.zip
Shut down upsmon gracefully.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/nut/Makefile2
-rw-r--r--sysutils/nut/files/nut_upsmon.in7
2 files changed, 8 insertions, 1 deletions
diff --git a/sysutils/nut/Makefile b/sysutils/nut/Makefile
index 17bc851a987e..e9a194f475e4 100644
--- a/sysutils/nut/Makefile
+++ b/sysutils/nut/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nut
PORTVERSION= 2.7.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://www.networkupstools.org/source/${PORTVERSION:R}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
diff --git a/sysutils/nut/files/nut_upsmon.in b/sysutils/nut/files/nut_upsmon.in
index 6aee6a46c900..8cf393a5b799 100644
--- a/sysutils/nut/files/nut_upsmon.in
+++ b/sysutils/nut/files/nut_upsmon.in
@@ -32,9 +32,16 @@ pidfile="%%STATEDIR%%/upsmon.pid"
nut_upsmon_flags=${nut_upsmon_flags-"localhost"}
extra_commands=reload
+stop_cmd="upsmon_stop"
+
reload()
{
${command} -c reload
}
+upsmon_stop()
+{
+ ${command} -c stop
+}
+
run_rc_command "$1"