aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-01-20 18:40:54 +0800
committerpav <pav@FreeBSD.org>2005-01-20 18:40:54 +0800
commitd2a3151265ce8d742ea20a257d9785d8cd768bc8 (patch)
tree11765deac4fc69a1a4fd4f1666c2e7572621f4f4 /sysutils
parent460fe472ea4990d677987e5e94089f5ac279870c (diff)
downloadfreebsd-ports-gnome-d2a3151265ce8d742ea20a257d9785d8cd768bc8.tar.gz
freebsd-ports-gnome-d2a3151265ce8d742ea20a257d9785d8cd768bc8.tar.zst
freebsd-ports-gnome-d2a3151265ce8d742ea20a257d9785d8cd768bc8.zip
- Update to 1.4.0
PR: ports/76471 Submitted by: Paul Dlug <paul@aps.org> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/radmind/Makefile2
-rw-r--r--sysutils/radmind/distinfo4
-rw-r--r--sysutils/radmind/files/patch-tls.c19
3 files changed, 22 insertions, 3 deletions
diff --git a/sysutils/radmind/Makefile b/sysutils/radmind/Makefile
index 24c82eca056e..2e0ad0b02a68 100644
--- a/sysutils/radmind/Makefile
+++ b/sysutils/radmind/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= radmind
-PORTVERSION= 1.3.2
+PORTVERSION= 1.4.0
CATEGORIES= sysutils
MASTER_SITES= http://rsug.itd.umich.edu/software/radmind/files/
EXTRACT_SUFX= .tgz
diff --git a/sysutils/radmind/distinfo b/sysutils/radmind/distinfo
index d9414a79e3da..e76177438feb 100644
--- a/sysutils/radmind/distinfo
+++ b/sysutils/radmind/distinfo
@@ -1,2 +1,2 @@
-MD5 (radmind-1.3.2.tgz) = d94620d0808fd85e71112ce4caec798f
-SIZE (radmind-1.3.2.tgz) = 516271
+MD5 (radmind-1.4.0.tgz) = 9e2eb883e5c4cfc6495f169594f4d180
+SIZE (radmind-1.4.0.tgz) = 342647
diff --git a/sysutils/radmind/files/patch-tls.c b/sysutils/radmind/files/patch-tls.c
new file mode 100644
index 000000000000..1f7c99e89e67
--- /dev/null
+++ b/sysutils/radmind/files/patch-tls.c
@@ -0,0 +1,19 @@
+--- tls.c.orig Tue Dec 14 16:23:14 2004
++++ tls.c Thu Jan 20 11:35:58 2005
+@@ -194,6 +194,7 @@
+ char *line;
+ int ntype;
+ struct in_addr addr;
++ int alt_ext;
+
+ if ( inet_aton( host, &addr )) {
+ ntype = IS_IP4;
+@@ -239,7 +240,7 @@
+ /* This code gratiously borrowed from openldap-2.2.17,
+ * it allows the use of aliases in the certificate.
+ */
+- int alt_ext = X509_get_ext_by_NID( peer, NID_subject_alt_name, -1);
++ alt_ext = X509_get_ext_by_NID( peer, NID_subject_alt_name, -1);
+
+ if ( alt_ext >= 0 ) {
+ X509_EXTENSION *ex;