aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/apache-solr
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2014-10-20 04:18:04 +0800
committerpi <pi@FreeBSD.org>2014-10-20 04:18:04 +0800
commit23acc08ab3b0237a7b8f4835ff4d432cb9663126 (patch)
tree96ae2a0e9cc1d196579d7ff13e7b7127c55bb832 /textproc/apache-solr
parented21aa24dc59b3bb8067c525c8ec80ec0bc339b2 (diff)
downloadfreebsd-ports-gnome-23acc08ab3b0237a7b8f4835ff4d432cb9663126.tar.gz
freebsd-ports-gnome-23acc08ab3b0237a7b8f4835ff4d432cb9663126.tar.zst
freebsd-ports-gnome-23acc08ab3b0237a7b8f4835ff4d432cb9663126.zip
textproc/apache-solr: 4.8.1 -> 4.10.1
Changes see: http://lucene.apache.org/solr/4_10_1/changes/Changes.html PR: 193290 Submitted by: Radim Kolar <hsn@sendmail.cz> Approved by: gaod@hychen.org (maintainer timeout)
Diffstat (limited to 'textproc/apache-solr')
-rw-r--r--textproc/apache-solr/Makefile4
-rw-r--r--textproc/apache-solr/distinfo4
-rw-r--r--textproc/apache-solr/files/solr.in50
-rw-r--r--textproc/apache-solr/pkg-deinstall7
-rw-r--r--textproc/apache-solr/pkg-plist14
5 files changed, 65 insertions, 14 deletions
diff --git a/textproc/apache-solr/Makefile b/textproc/apache-solr/Makefile
index a751b3a6e460..1ab15dc68bdc 100644
--- a/textproc/apache-solr/Makefile
+++ b/textproc/apache-solr/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= apache-solr
-PORTVERSION= 4.8.1
+PORTVERSION= 4.10.1
CATEGORIES= textproc java
MASTER_SITES= APACHE
MASTER_SITE_SUBDIR= lucene/solr/${PORTVERSION}
@@ -19,10 +19,12 @@ USES= shebangfix tar:tgz
SHEBANG_FILES= example/etc/create-solrtest.keystore.sh
JAVA_VERSION= 1.7+
NO_BUILD= yes
+NO_ARCH= yes
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
USE_JAVA= yes
PORTEXAMPLES= *
LATEST_LINK= apache-solr
+USE_RC_SUBR= solr
do-install:
cd ${WRKSRC}/dist && ${COPYTREE_SHARE} . ${STAGEDIR}${JAVAJARDIR}
diff --git a/textproc/apache-solr/distinfo b/textproc/apache-solr/distinfo
index 462c3065e02f..bd9d2bec8fdf 100644
--- a/textproc/apache-solr/distinfo
+++ b/textproc/apache-solr/distinfo
@@ -1,2 +1,2 @@
-SHA256 (solr-4.8.1.tgz) = ac814affbe4f7270cf98a5d4d70eb65579bff7c008ee96d74b4146b1060bf947
-SIZE (solr-4.8.1.tgz) = 152451311
+SHA256 (solr-4.10.1.tgz) = 3e6359f4227f17cda7dc280bc32572a514f330dada80539b0b47dba107672563
+SIZE (solr-4.10.1.tgz) = 149941189
diff --git a/textproc/apache-solr/files/solr.in b/textproc/apache-solr/files/solr.in
new file mode 100644
index 000000000000..7afe7aa5d220
--- /dev/null
+++ b/textproc/apache-solr/files/solr.in
@@ -0,0 +1,50 @@
+#!/bin/sh
+#
+# Copyright (c) 2014, Radim Kolar
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+#
+# * Redistributions of source code must retain the above copyright notice,
+# this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the distribution.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND ANY
+# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY
+# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+# CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+# LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+# OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
+# DAMAGE.
+
+# $FreeBSD$
+#
+# PROVIDE: solr
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+
+. /etc/rc.subr
+
+name=solr
+rcvar=solr_enable
+load_rc_config $name
+
+: ${solr_enable:=NO}
+: ${solr_instance:=/var/db/solr}
+
+required_files=${solr_instance}/solr.xml
+pidfile=/var/run/solr.pid
+command=/usr/sbin/daemon
+procname=%%LOCALBASE%%/openjdk7/bin/java
+start_precmd="cd %%EXAMPLESDIR%%"
+
+command_args="-f -p ${pidfile} ${procname} ${solr_flags} -Dsolr.solr.home=${solr_instance} -Dsolr.log=/var/log -jar %%EXAMPLESDIR%%/start.jar"
+
+run_rc_command "$1"
diff --git a/textproc/apache-solr/pkg-deinstall b/textproc/apache-solr/pkg-deinstall
new file mode 100644
index 000000000000..4f6e6ba6d654
--- /dev/null
+++ b/textproc/apache-solr/pkg-deinstall
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# Removes jetty war cache
+#
+if [ "$2" = "DEINSTALL" ]; then
+ rm -rf $PKG_PREFIX/share/examples/apache-solr/solr-webapp/*
+fi
diff --git a/textproc/apache-solr/pkg-plist b/textproc/apache-solr/pkg-plist
index 9f427081c3e5..974a77eec454 100644
--- a/textproc/apache-solr/pkg-plist
+++ b/textproc/apache-solr/pkg-plist
@@ -13,25 +13,17 @@
%%JAVAJARDIR%%/solr-test-framework-%%PORTVERSION%%.jar
%%JAVAJARDIR%%/solr-uima-%%PORTVERSION%%.jar
%%JAVAJARDIR%%/solr-velocity-%%PORTVERSION%%.jar
-%%JAVAJARDIR%%/solrj-lib/commons-io-2.1.jar
+%%JAVAJARDIR%%/solrj-lib/commons-io-2.3.jar
%%JAVAJARDIR%%/solrj-lib/httpclient-4.3.1.jar
%%JAVAJARDIR%%/solrj-lib/httpcore-4.3.jar
%%JAVAJARDIR%%/solrj-lib/httpmime-4.3.1.jar
-%%JAVAJARDIR%%/solrj-lib/jcl-over-slf4j-1.7.6.jar
-%%JAVAJARDIR%%/solrj-lib/jul-to-slf4j-1.7.6.jar
-%%JAVAJARDIR%%/solrj-lib/log4j-1.2.16.jar
%%JAVAJARDIR%%/solrj-lib/noggit-0.5.jar
%%JAVAJARDIR%%/solrj-lib/slf4j-api-1.7.6.jar
-%%JAVAJARDIR%%/solrj-lib/slf4j-log4j12-1.7.6.jar
%%JAVAJARDIR%%/solrj-lib/wstx-asl-3.2.7.jar
%%JAVAJARDIR%%/solrj-lib/zookeeper-3.4.6.jar
%%JAVAJARDIR%%/test-framework/README.txt
%%JAVAJARDIR%%/test-framework/lib/ant-1.8.2.jar
%%JAVAJARDIR%%/test-framework/lib/junit-4.10.jar
-%%JAVAJARDIR%%/test-framework/lib/junit4-ant-2.1.3.jar
-%%JAVAJARDIR%%/test-framework/lib/randomizedtesting-runner-2.1.3.jar
+%%JAVAJARDIR%%/test-framework/lib/junit4-ant-2.1.6.jar
+%%JAVAJARDIR%%/test-framework/lib/randomizedtesting-runner-2.1.6.jar
%%JAVAJARDIR%%/test-framework/lucene-libs/lucene-test-framework-%%PORTVERSION%%.jar
-@dirrmtry %%JAVAJARDIR%%/solrj-lib
-@dirrmtry %%JAVAJARDIR%%/test-framework/lib
-@dirrmtry %%JAVAJARDIR%%/test-framework/lucene-libs
-@dirrmtry %%JAVAJARDIR%%/test-framework