aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/apertium/Makefile
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2014-08-31 19:01:04 +0800
committerpi <pi@FreeBSD.org>2014-08-31 19:01:04 +0800
commit075b4bd1e449be52f20fc34bfe58fb48177b94a0 (patch)
tree91cf81b7e9f1055b199f0a59960fd771cdfde5ad /textproc/apertium/Makefile
parent98892af3bca304b54d3d6786b7425577a53ee716 (diff)
downloadfreebsd-ports-gnome-075b4bd1e449be52f20fc34bfe58fb48177b94a0.tar.gz
freebsd-ports-gnome-075b4bd1e449be52f20fc34bfe58fb48177b94a0.tar.zst
freebsd-ports-gnome-075b4bd1e449be52f20fc34bfe58fb48177b94a0.zip
textproc/lttoolbox, textproc/apertium: 3.2.0 -> 3.3.0
- lttoolbox -has two new tools: lt-trim and lt-print - apertium has a new deformatter: apertium-deslatex - lextor is deprecated, the code is still there but is not built - apertium has a new m4 macro that supports using language packages from /languages/ PR: 192886
Diffstat (limited to 'textproc/apertium/Makefile')
-rw-r--r--textproc/apertium/Makefile22
1 files changed, 6 insertions, 16 deletions
diff --git a/textproc/apertium/Makefile b/textproc/apertium/Makefile
index 8cd70a5fc4a3..533b38b15637 100644
--- a/textproc/apertium/Makefile
+++ b/textproc/apertium/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= apertium
-PORTVERSION= 3.2.0
-PORTREVISION= 4
+PORTVERSION= 3.3.0
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
@@ -13,11 +12,11 @@ COMMENT= Toolbox to build shallow-transfer machine translation systems
LICENSE= GPLv2 # (or later)
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
- liblttoolbox3.so:${PORTSDIR}/textproc/lttoolbox
+LIB_DEPENDS= liblttoolbox3.so:${PORTSDIR}/textproc/lttoolbox \
+ libpcre.so:${PORTSDIR}/devel/pcre
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-USES= libtool pathfix pkgconfig
+USES= pathfix pkgconfig libtool
USE_GNOME= libxml2 libxslt
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -30,16 +29,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= APVER="${PORTVERSION:R}"
post-patch:
- @${REINPLACE_CMD} -e \
- 's| -ansi | | ; \
- s| -march=.* | | ; \
- s| -mtune=.* | | ; \
- s| -O3 | | ; \
- s|pcre_info|pcre_fullinfo|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
- 's|\([[:blank:]]\)\($$(modesdir)\)|\1$$(DESTDIR)\2|' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e \
- 's|_C_|_H_|' ${WRKSRC}/apertium/tmx_aligner_tool.h
+
+ @${REINPLACE_CMD} -e 's/pcre_info/pcre_fullinfo/g' ${WRKSRC}/configure
.include <bsd.port.mk>