aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/archmage/Makefile
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-07-18 21:20:44 +0800
committersat <sat@FreeBSD.org>2007-07-18 21:20:44 +0800
commit27efb736f1d6e7a2c76023992658618f7d7a1131 (patch)
tree8d8e96d23a79af1142c9c037e7fed51e7b366a5b /textproc/archmage/Makefile
parent71a9bddf6f866c3b9a71c218006cea7359e63316 (diff)
downloadfreebsd-ports-gnome-27efb736f1d6e7a2c76023992658618f7d7a1131.tar.gz
freebsd-ports-gnome-27efb736f1d6e7a2c76023992658618f7d7a1131.tar.zst
freebsd-ports-gnome-27efb736f1d6e7a2c76023992658618f7d7a1131.zip
- Update to 0.1.9
Diffstat (limited to 'textproc/archmage/Makefile')
-rw-r--r--textproc/archmage/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/textproc/archmage/Makefile b/textproc/archmage/Makefile
index a1fce9aebfb2..82cd59186bfe 100644
--- a/textproc/archmage/Makefile
+++ b/textproc/archmage/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= archmage
-PORTVERSION= 0.0.8
+PORTVERSION= 0.1.9
CATEGORIES= textproc python
MASTER_SITES= SF
-DIST_SUBDIR= rerolled
MAINTAINER= infofarmer@FreeBSD.org
COMMENT= Extensible reader/decompiler of files in CHM format
@@ -17,12 +16,20 @@ COMMENT= Extensible reader/decompiler of files in CHM format
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/chm/chm.py:${PORTSDIR}/textproc/pychm
NO_BUILD= yes
+USE_BZIP2= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+MAN1= ${PORTNAME}.1
+
+post-extract:
+ @${GUNZIP_CMD} ${WRKSRC}/${PORTNAME}.1.gz
post-patch:
- @${REINPLACE_CMD} -e "s,/usr/share,${PREFIX}/share," ${WRKSRC}/arch.conf
+ @${REINPLACE_CMD} -e "s,/usr/share/archmage,${DATADIR}," ${WRKSRC}/arch.conf
@${REINPLACE_CMD} -e "s,/etc,${PREFIX}/etc," ${WRKSRC}/archmod/CHM.py
- @${REINPLACE_CMD} -e "s,/etc,etc," ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e "s,/etc,etc,;/archmage.1/d" ${WRKSRC}/setup.py
+
+post-install:
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
.include <bsd.port.mk>