aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/artha
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2011-07-25 09:44:59 +0800
committerzi <zi@FreeBSD.org>2011-07-25 09:44:59 +0800
commit7f45230785f433756fc5ede9d01aff408332a3ff (patch)
treed308b154f8810f520c6e1b6f8dbc67310c6fa830 /textproc/artha
parenta668259be7aecf8cbd816528e2337d3291e4877c (diff)
downloadfreebsd-ports-gnome-7f45230785f433756fc5ede9d01aff408332a3ff.tar.gz
freebsd-ports-gnome-7f45230785f433756fc5ede9d01aff408332a3ff.tar.zst
freebsd-ports-gnome-7f45230785f433756fc5ede9d01aff408332a3ff.zip
New port: textproc/artha
Artha is a free cross-platform English thesaurus that works completely off-line and is based on WordNet. Stable releases for download are currently available for GNU/Linux and Microsoft Windows; it is tested on major Desktop Environments like GNOME, KDE, Xfce, etc and on Microsoft Windows XP, Vista and 7. Artha is released under the GNU General Public Licence version 2; hence you are free to copy/redistribute it. WWW: http://artha.sourceforge.net/wiki/index.php/Home PR: ports/155573 Submitted by: Zhihao Yuan <lichray@gmail.com> Approved by: wxs (mentor)
Diffstat (limited to 'textproc/artha')
-rw-r--r--textproc/artha/Makefile41
-rw-r--r--textproc/artha/distinfo2
-rw-r--r--textproc/artha/pkg-descr8
-rw-r--r--textproc/artha/pkg-plist6
4 files changed, 57 insertions, 0 deletions
diff --git a/textproc/artha/Makefile b/textproc/artha/Makefile
new file mode 100644
index 000000000000..ab6b8433867b
--- /dev/null
+++ b/textproc/artha/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: artha
+# Date created: 2011-03-15
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= artha
+PORTVERSION= 1.0.2
+CATEGORIES= textproc
+MASTER_SITES= SF
+
+MAINTAINER= lichray@gmail.com
+COMMENT= A free cross-platform English thesaurus
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
+ WN.2:${PORTSDIR}/textproc/wordnet
+
+MAN1= artha.1
+
+USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20 intltool pkgconfig
+
+CONFIGURE_ARGS= --enable-static=no --x-includes=${LOCALBASE}/include \
+ --x-libraries=${LOCALBASE}/lib
+CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib
+CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/WordNet
+
+OPTIONS= NOTIFY "Popup word definition as notification" On
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_NOTIFY)
+LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/artha/distinfo b/textproc/artha/distinfo
new file mode 100644
index 000000000000..bcc3a4526955
--- /dev/null
+++ b/textproc/artha/distinfo
@@ -0,0 +1,2 @@
+SHA256 (artha-1.0.2.tar.gz) = ed35903d37cbf364998ea58900fac01a7cfbab9f0ddb9f2c5bc0acb228c7952c
+SIZE (artha-1.0.2.tar.gz) = 408922
diff --git a/textproc/artha/pkg-descr b/textproc/artha/pkg-descr
new file mode 100644
index 000000000000..84ca1f2e42ae
--- /dev/null
+++ b/textproc/artha/pkg-descr
@@ -0,0 +1,8 @@
+Artha is a free cross-platform English thesaurus that works completely
+off-line and is based on WordNet. Stable releases for download are
+currently available for GNU/Linux and Microsoft Windows; it is tested
+on major Desktop Environments like GNOME, KDE, Xfce, etc and on Microsoft
+Windows XP, Vista and 7. Artha is released under the GNU General Public
+Licence version 2; hence you are free to copy/redistribute it.
+
+WWW: http://artha.sourceforge.net/wiki/index.php/Home
diff --git a/textproc/artha/pkg-plist b/textproc/artha/pkg-plist
new file mode 100644
index 000000000000..2d2454b76ddd
--- /dev/null
+++ b/textproc/artha/pkg-plist
@@ -0,0 +1,6 @@
+bin/artha
+share/applications/artha.desktop
+share/pixmaps/artha.png
+%%DATADIR%%/gui.glade
+@dirrmtry share/applications
+@dirrm %%DATADIR%%