aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/aspell
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-08-31 06:25:46 +0800
committerthierry <thierry@FreeBSD.org>2004-08-31 06:25:46 +0800
commit3793db910828df091f052c796f3eeee1b47e3d1c (patch)
treedeabcb4807bde26c71072fe7dea541af4da1139b /textproc/aspell
parent32fd7afe37ceabd98a9dae0b990c80da688360e0 (diff)
downloadfreebsd-ports-gnome-3793db910828df091f052c796f3eeee1b47e3d1c.tar.gz
freebsd-ports-gnome-3793db910828df091f052c796f3eeee1b47e3d1c.tar.zst
freebsd-ports-gnome-3793db910828df091f052c796f3eeee1b47e3d1c.zip
Explicitly disable threading:
- on FreeBSD 4.x, it links with -pthread, but no link is retained in the resulting library; - on FreeBSD 5.x and 6, it works, but since libaspell is used by un-threaded programs, this is not a good choice. Reviewed by: marcus.
Diffstat (limited to 'textproc/aspell')
-rw-r--r--textproc/aspell/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index c0c48d23dcbc..0d68cbafbe2b 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= aspell
PORTVERSION= 0.60
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES+= textproc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= aspell
@@ -26,6 +26,8 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-dict-dir=${DATADIR} \
--enable-docdir=${DOCSDIR} \
--enable-static
+PTHREAD_CFLAGS= # Disable threading
+PTHREAD_LIBS= # libaspell may be used by unthreaded apps.
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${LDFLAGS} ${PTHREAD_LIBS}"
USE_GMAKE= yes