aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/augeas
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2010-07-06 10:17:30 +0800
committerlwhsu <lwhsu@FreeBSD.org>2010-07-06 10:17:30 +0800
commit60784a081aa90c9cba6f334efb6f47f9f456d237 (patch)
tree27538dbdd0b0b36196a1c6f7b688e6b8b5681f45 /textproc/augeas
parent0efe9a9ddf6b4b5cd6c37bdb6bca71b5a8860419 (diff)
downloadfreebsd-ports-gnome-60784a081aa90c9cba6f334efb6f47f9f456d237.tar.gz
freebsd-ports-gnome-60784a081aa90c9cba6f334efb6f47f9f456d237.tar.zst
freebsd-ports-gnome-60784a081aa90c9cba6f334efb6f47f9f456d237.zip
- Fix problem parsing /boot/loader.conf
- Bump PORTREVISION PR: ports/148386 Submitted by: Russell Jackson <raj AT csub.edu> Feature safe: yes
Diffstat (limited to 'textproc/augeas')
-rw-r--r--textproc/augeas/Makefile2
-rw-r--r--textproc/augeas/files/rcconf.aug2
2 files changed, 3 insertions, 1 deletions
diff --git a/textproc/augeas/Makefile b/textproc/augeas/Makefile
index dd6ac8936ddd..f414384ba68f 100644
--- a/textproc/augeas/Makefile
+++ b/textproc/augeas/Makefile
@@ -1,3 +1,4 @@
+# vim: ts=8 sw=8
# Ports collection makefile for: textproc/augeas
# Date created: 19 May 2010
# Whom: Russell Jackson <raj@csub.edu>
@@ -7,6 +8,7 @@
PORTNAME= augeas
PORTVERSION= 0.7.1
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://augeas.net/download/
diff --git a/textproc/augeas/files/rcconf.aug b/textproc/augeas/files/rcconf.aug
index 1ab86b678dd5..b91219f771a2 100644
--- a/textproc/augeas/files/rcconf.aug
+++ b/textproc/augeas/files/rcconf.aug
@@ -7,7 +7,7 @@ module RcConf =
let eq = Util.del_str "="
let dquot = Util.del_str "\""
let char = /[^\n]/
- let var_name = /[A-Za-z0-9_]+/
+ let var_name = /[A-Za-z0-9_.]+/
let value = dquot . store char* . dquot
let kv_pair = [ key var_name . eq . value . eol ]