aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/bib2html
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
committermat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
commit9debac461b7729b783ca5a0f5e46461ddac07173 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /textproc/bib2html
parenteedda7c96f5b61bbadc957164c030b26a221e965 (diff)
downloadfreebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.gz
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.zst
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Diffstat (limited to 'textproc/bib2html')
-rw-r--r--textproc/bib2html/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/textproc/bib2html/Makefile b/textproc/bib2html/Makefile
index 4e95e539677f..306eb80fccfa 100644
--- a/textproc/bib2html/Makefile
+++ b/textproc/bib2html/Makefile
@@ -3,6 +3,7 @@
PORTNAME= bib2html
DISTVERSION= 5.1-1
+PORTREVISION= 1
CATEGORIES= textproc print
MASTER_SITES= http://www.arakhne.org/IMG/gz/ \
http://fresh.t-systems-sfr.com/fresh/unix/src/privat2/
@@ -28,11 +29,9 @@ post-patch:
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/bib2html ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/bib2xml ${STAGEDIR}${PREFIX}/bin
- @${MKDIR} ${STAGEDIR}${SITE_PERL}/Bib2HTML
- cd ${WRKSRC}/Bib2HTML && ${COPYTREE_SHARE} . ${STAGEDIR}${SITE_PERL}/Bib2HTML
- ${FIND} ${STAGEDIR}${SITE_PERL}/Bib2HTML -type f | \
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/Bib2HTML
+ cd ${WRKSRC}/Bib2HTML && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/Bib2HTML
+ ${FIND} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/Bib2HTML -type f | \
${SED} "s,^${STAGEDIR}${PREFIX}/,," >> ${TMPPLIST}
- ${FIND} ${STAGEDIR}${SITE_PERL}/Bib2HTML -type d | ${SORT} -r | \
- ${SED} "s,^${STAGEDIR}${PREFIX}/,@dirrm ," >> ${TMPPLIST}
.include <bsd.port.mk>