aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/bsdgrep
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2011-10-02 23:28:46 +0800
committergabor <gabor@FreeBSD.org>2011-10-02 23:28:46 +0800
commit3049f0a40aed117537175f12e73fe03c73d8d24e (patch)
tree50f64d4676359bd27f50f3acf1cd76fdbfc46fcb /textproc/bsdgrep
parent678681eff970ee092453c66ecb30a3963cc9b763 (diff)
downloadfreebsd-ports-gnome-3049f0a40aed117537175f12e73fe03c73d8d24e.tar.gz
freebsd-ports-gnome-3049f0a40aed117537175f12e73fe03c73d8d24e.tar.zst
freebsd-ports-gnome-3049f0a40aed117537175f12e73fe03c73d8d24e.zip
- Fix build on >=9.X
Reported by: eadler
Diffstat (limited to 'textproc/bsdgrep')
-rw-r--r--textproc/bsdgrep/Makefile3
-rw-r--r--textproc/bsdgrep/files/patch-Makefile21
2 files changed, 19 insertions, 5 deletions
diff --git a/textproc/bsdgrep/Makefile b/textproc/bsdgrep/Makefile
index 2b412a95d64a..d579c4a39b51 100644
--- a/textproc/bsdgrep/Makefile
+++ b/textproc/bsdgrep/Makefile
@@ -35,8 +35,7 @@ MLINKS= grep.1 bzegrep.1 \
MAKE_ENV+= BINDIR="${PREFIX}/bin" \
MANDIR="${MANPREFIX}/man/man" \
CATDIR="${MANPREFIX}/man/man" \
- NLSDIR="${PREFIX}/share/nls" \
- MK_BSD_GREP="yes"
+ NLSDIR="${PREFIX}/share/nls"
OPTIONS= NLS "Compile with NLS support" on \
GNU_COMPAT "Use GNU regex library (recommended)" on
diff --git a/textproc/bsdgrep/files/patch-Makefile b/textproc/bsdgrep/files/patch-Makefile
index 5cc40a3b3294..f1ab0cafd90a 100644
--- a/textproc/bsdgrep/files/patch-Makefile
+++ b/textproc/bsdgrep/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2011-09-21 15:26:48.000000000 +0200
-+++ Makefile 2011-09-21 15:29:01.000000000 +0200
-@@ -4,16 +4,9 @@
+--- Makefile.orig 2011-10-02 00:39:02.000000000 +0200
++++ Makefile 2011-10-02 17:25:40.000000000 +0200
+@@ -4,23 +4,15 @@
.include <bsd.own.mk>
@@ -18,3 +18,18 @@
# Extra files ported backported form some regex improvements
.PATH: ${.CURDIR}/regex
+ SRCS+= fastmatch.c hashtable.c tre-compile.c tre-fastmatch.c xmalloc.c
+ CFLAGS+=-I${.CURDIR}/regex
+
+-.if ${MK_BSD_GREP} == "yes"
+ LINKS= ${BINDIR}/grep ${BINDIR}/egrep \
+ ${BINDIR}/grep ${BINDIR}/fgrep \
+ ${BINDIR}/grep ${BINDIR}/zgrep \
+@@ -50,7 +42,6 @@
+ grep.1 lzgrep.1 \
+ grep.1 lzegrep.1 \
+ grep.1 lzfgrep.1
+-.endif
+
+ LDADD= -lz -lbz2 -llzma
+ DPADD= ${LIBZ} ${LIBBZ2} ${LIBLZMA}