aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/carthage/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-01-03 19:51:59 +0800
committeredwin <edwin@FreeBSD.org>2003-01-03 19:51:59 +0800
commitd67afe459c2d885f66cc8bab949680f9c604ee35 (patch)
tree1127cbdb33164d931b49b8555bd646a82079d472 /textproc/carthage/Makefile
parent88d82d1e15f5eeb5269a5a6ba214ba32525bdbfa (diff)
downloadfreebsd-ports-gnome-d67afe459c2d885f66cc8bab949680f9c604ee35.tar.gz
freebsd-ports-gnome-d67afe459c2d885f66cc8bab949680f9c604ee35.tar.zst
freebsd-ports-gnome-d67afe459c2d885f66cc8bab949680f9c604ee35.zip
New Port: DTD parser and clean-up tool
A parser and clean-up tool for SGML DTDs. PR: ports/38340 Submitted by: Henrik Motakef <henrik.motakef@web.de>
Diffstat (limited to 'textproc/carthage/Makefile')
-rw-r--r--textproc/carthage/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/textproc/carthage/Makefile b/textproc/carthage/Makefile
new file mode 100644
index 000000000000..c63c17ca6eb7
--- /dev/null
+++ b/textproc/carthage/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: carthage
+# Date created: 18 May 2002
+# Whom: Henrik Motakef <henrik.motakef@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= carthage
+PORTVERSION= 1.0 # Cannot find any version information
+CATEGORIES= textproc
+MASTER_SITES= http://www.tei-c.org/Software/carthage/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= henrik.motakef@web.de
+
+BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison
+
+USE_ZIP= yes
+USE_GMAKE= yes
+ALL_TARGET= carthago
+
+post-patch:
+ ${CHMOD} +w ${WRKSRC}/dpplex.c
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/carthage ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/carthago ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/carthage
+ @${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/carthage
+ @${INSTALL_MAN} ${WRKSRC}/README.SPQR ${PREFIX}/share/doc/carthage
+.endif
+
+.include <bsd.port.mk>