aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/carthage
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-01-03 19:51:59 +0800
committeredwin <edwin@FreeBSD.org>2003-01-03 19:51:59 +0800
commitd67afe459c2d885f66cc8bab949680f9c604ee35 (patch)
tree1127cbdb33164d931b49b8555bd646a82079d472 /textproc/carthage
parent88d82d1e15f5eeb5269a5a6ba214ba32525bdbfa (diff)
downloadfreebsd-ports-gnome-d67afe459c2d885f66cc8bab949680f9c604ee35.tar.gz
freebsd-ports-gnome-d67afe459c2d885f66cc8bab949680f9c604ee35.tar.zst
freebsd-ports-gnome-d67afe459c2d885f66cc8bab949680f9c604ee35.zip
New Port: DTD parser and clean-up tool
A parser and clean-up tool for SGML DTDs. PR: ports/38340 Submitted by: Henrik Motakef <henrik.motakef@web.de>
Diffstat (limited to 'textproc/carthage')
-rw-r--r--textproc/carthage/Makefile36
-rw-r--r--textproc/carthage/distinfo1
-rw-r--r--textproc/carthage/pkg-comment1
-rw-r--r--textproc/carthage/pkg-descr6
-rw-r--r--textproc/carthage/pkg-plist5
5 files changed, 49 insertions, 0 deletions
diff --git a/textproc/carthage/Makefile b/textproc/carthage/Makefile
new file mode 100644
index 000000000000..c63c17ca6eb7
--- /dev/null
+++ b/textproc/carthage/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: carthage
+# Date created: 18 May 2002
+# Whom: Henrik Motakef <henrik.motakef@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= carthage
+PORTVERSION= 1.0 # Cannot find any version information
+CATEGORIES= textproc
+MASTER_SITES= http://www.tei-c.org/Software/carthage/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= henrik.motakef@web.de
+
+BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison
+
+USE_ZIP= yes
+USE_GMAKE= yes
+ALL_TARGET= carthago
+
+post-patch:
+ ${CHMOD} +w ${WRKSRC}/dpplex.c
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/carthage ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/carthago ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/carthage
+ @${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/carthage
+ @${INSTALL_MAN} ${WRKSRC}/README.SPQR ${PREFIX}/share/doc/carthage
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/carthage/distinfo b/textproc/carthage/distinfo
new file mode 100644
index 000000000000..ac3432943e78
--- /dev/null
+++ b/textproc/carthage/distinfo
@@ -0,0 +1 @@
+MD5 (carthage.zip) = a37017d82591afa36bb9841a15c7bb9b
diff --git a/textproc/carthage/pkg-comment b/textproc/carthage/pkg-comment
new file mode 100644
index 000000000000..16c3e1b80a63
--- /dev/null
+++ b/textproc/carthage/pkg-comment
@@ -0,0 +1 @@
+A parser and clean-up tool for SGML DTDs
diff --git a/textproc/carthage/pkg-descr b/textproc/carthage/pkg-descr
new file mode 100644
index 000000000000..8136ca9d7d68
--- /dev/null
+++ b/textproc/carthage/pkg-descr
@@ -0,0 +1,6 @@
+A parser and clean-up tool for SGML DTDs.
+
+WWW: http://www.tei-c.org/Software/carthage
+
+- Henrik Motakef
+ <henrik.motakef@web.de>
diff --git a/textproc/carthage/pkg-plist b/textproc/carthage/pkg-plist
new file mode 100644
index 000000000000..e1894524c324
--- /dev/null
+++ b/textproc/carthage/pkg-plist
@@ -0,0 +1,5 @@
+bin/carthage
+bin/carthago
+%%PORTDOCS%%share/doc/carthage/README
+%%PORTDOCS%%share/doc/carthage/README.SPQR
+%%PORTDOCS%%@dirrm share/doc/carthage